Smart bulb dimming with Red Series Dimmer (LZW31-SN) on Hubitat

Question: Is it possible to independently control the dimmer’s level indicator from the level output (AKA relay)?

To clarify: I’d like to use the dimmer switch buttons to issue commands to the smart bulbs and the LED bar vertical level (not the brightness) to indicate the dimming level of the smart bulbs - without actually changing the voltage output of the switch. I know that disabling the relay (8x clicks of the scene button) is supposed to do this but that seems to just disable local control. So if i actually set the level of the switch to change the vertical LED bar, it also varies the voltage output.

Closest I can get is to leave the dimmer “level” at 100% but use software commands to control the bulbs - but this misrepresents the bulb brightness. I could just use an on/off switch, but the vertical LED bar is a visual signal to the user that the switch supports dimming - it would be great if it could represent the bulb brightness (without wiring the light to bypass the switch).

I’ve tried enabling the “Smart Bulb Mode” but that seems to have no affect (I also can’t find any documentation on it). I also tried the “Child Set Level” command but that doesn’t appear to have any affect. I might have missed something or perhaps this is fixed in a later firmware release.

I’m running the Hubitat C-5 with the official Inovelli drivers from 2020-09-16 and LZW31-SN firmware version 1.45.

Thanks in advance for the help.

Yes, I believe there is (although I haven’t tried), but if you Associations 3 and 4, I believe the LED levels will follow the dim level of the bulb…not 100% sure on the theory of that, but I believe others are using 3 and 4 to make it work. I’m currently using associations 2 and 4 to control the bulb (with local control off).

Are you referring to Z-Wave associations?

I’m using Wi-Fi bulbs so I just need the independent control of the LED level indicator.

@bryanjenks - Ahh yes, sorry thought you were using ZWave like Ilumin.

I’m not even sure if there is a way; however, there are a lot smarter people than I that maybe can get this to work. I didn’t think Hubitat had any WiFi apps, so I’d be interested to see if this is possible.

Thanks @harjms.

I have the bulb control part working fine. Using the Philips Wiz bulbs - there’s a 3rd party device driver in case you’re curious. They make really nice/affordable recessed lighting fixtures.

1 Like

Nice! About the only think I could recommend is trying to get a rule setup to match the dim level of the bulbs, but that’s above my LOK.

Writing the rule isn’t too hard. I just can’t figure out how to change the LED level indicator without also changing the voltage output of the dimmer.

The rules engine could do it a couple of different ways but basically you would handle switch 8 events for button down and then switch 6 events for button up.


I actually just got this working in my office. Here’s my current setup:

  • Office Fan Light (controlled by inovelli red series dimmer)
  • 4 Inovelli RGBW bulbs in the Fan Light (so I can use it for circadian lighting during the working day now that I’m semi-permanently working from home until pandemic ends)

So I currently had the relay turned off on the Dimmer wall switch and the bulbs were working with the zwave associations perfectly, but I too wanted the wall switch dimmer LED to show what the bulbs were dimmed to.

So using Hubitat, I created two global variables and a few Rule Machine apps and got it working this week. Fairly simple:

Happy dimming!

@jws6 thanks for the detailed write up.

I see you’re using setLevel to update the dimmer’s LED level indicator. How is the dimmer switch configured to allow that?

Everything I have tried also varies the voltage output of the dimmer when I call setLevel (which eventually cuts power to the bulbs).

@bryanjenks - Make sure you do the following to your dimmer switch:

  1. Disable Local Control
  2. Enable Smart Bulb Mode


  1. My current firmware for the dimmer is: 1.48 (I used @bcopeland Zwave Updater tool)
  2. Make sure you have Inovelli’s Custom Hubitat Drivers, not the ones that Hubitat provides for Inovelli. Here’s the Red Series Dimmer one you want:

And again, this is working fine on my setup…all four bulbs are still showing a small level of light output when I set them to 1…which means they are clearly still getting full power from the switch.

@jws6 That makes perfect sense. But for some reason, “Smart Bulb Mode” Yes or No has no noticeable affect.

I’ve heard it described as forcing the power to 100% regardless of the level setting - which is totally what I would expect it to do. But it doesn’t appear to do anything for my switch.

Maybe there is something wrong with my switch? (I bought it refurb but it seems to work perfectly otherwise.)

I’m testing with an incandescent bulb attached just for simplicity and setting the level is definitely varying the voltage output. I’ve also verified the Hubitat driver is set correctly.

btw, if you want to be completely sure the output isn’t cutting power to the smart bulb, set level to 0 and try to issue a software command to the bulb directly (or put an incandescent in). The switching power supply in the bulb might continue to function at a very low input level - not that I think it’s happening in your configuration.

@jws6 Oh and if the switch is installed without a neutral wire and has that shunt across it, a small amount of power might always be present.

So I turned off my rules and tested it per your direction above and it still works. I could only set the level to a low of 1 not 0. Only way to get to zero was to turn power off which I don’t want to do. Regardless, at 1, the bulbs went all the way to 100% brightness when I digitally turned them on so it’s working.

I am using a neutral wire and again, using zwave bulbs so I’m wondering if your load needs to be much higher for WiFi bulbs to function (definitely incandescent)?

So, I excluded it, factory reset it, and reapplied the “Smart Bulb Mode” = Yes setting and it’s still dimming the output when I set the level.

Maybe there is something wrong with this one. I went ahead and ordered more dimmer switches.

Thanks very much for your patience and help @jws6


No prob. Hope you get it figured out. I’ll be curious to find out what the “ah ha” moment was when you solve it.

Good luck

@bryanjenks so I had the similar issue ("Fake" physical dimmer dilemma). Return everything to default (smart mode = off, local mode = on) and just re-wire the dimmer: put both the load and Hot wires into Hot holes on the dimmer!
Now it’ll always be connected and the dimmer will be changing the voltage, which doesn’t affect anything, but you’ll have the LED working.
The downside of it is that you won’t be able to get the power usage as it bypasses Load.

@curiouspasserby Thanks for the tip. The other drawback is it bypasses the airgap switch which makes it a bit trickier to cut power.

I did get it working though with the “Smart Bulb Mode” now that I have a new dimmer switch.

@jws6 I got the new switch (same model) and updated to the latest firmware and it’s working mostly as expected now simply by enabling the smart bulb mode.

Here’s the characteristics:
Level 100 to Level 5: full power output.
Level 4 to 0: power off.

Setting the level to 4 or 5 turns the power off and on repeatably. Like maybe it was designed to work this way? I’m tempted to start a top-level post just to explore this setting.

That might be a Hubitat thing. I’m on SmartThings. I have a dimmer where the minimum is set to 30% normally. If I turn the Smart Bulb Mode on, I can change the dimmer from either the app, Google Home or the paddle all the way down to 1% and the light remains on. It doesn’t go on or off until I specifically issue an On or Off command. Dimmer controls do nothing.

@Bry The 30% minimum might be an important distinction. I think Inovelli scales the level 0-100 to span only the remaining range allowed after the min max are removed. So a 1 is a 30% output.

Confirmed on my switch. Setting a min level of 30%, causes >=1 to be full on. 0 turns it off still.

Returning to a min level of 1 returns to the previous behavior: <=4 turns power off. >=5 is full power.

1 Like