Smart Bulb Mode doesn't work

I updated my black series dimmer to the latest firmware 1.48 and set “smart bulb” mode to yes in hubitat. However switch still cuts power to bulbs when turned off

The smart bulb mode insures that the bulb is powered at full brightness. It doesn’t have anything to do with the switch making or breaking power, so even if you have that setting turned on, the switch will still turn the bulb on and off.

In addition to setting the Smart Bulb Mode, you want to Disable Local Control. That will disable turning the bulb on and off at the switch.

What do you mean by “full brightness”? Does that mean if the dimmer is on, the power is always 120V? That doesn’t seem to be the case since if I set the dimmer to 1% and smart bulb mode the smart lights don’t get enough power to turn on.

If I disable local control, then I can’t use the dimmer to control the smart lights. What I want is to be able to have the dimmer send commands to hubitat so that I can sync it with the lights.

You should turn the dimmer to 100% on and disable local control. Then setup associations to control dim levels and on/off from the switch through Hubitat.

My bulb is a Zigbee bulb, so I don’t think I can create associates with it.

So does this mean that the dimmer can’t support any non z-wave smart bulb?

Nope, that’s exactly how it works. Set it to Smart Bulb Mode. It won’t happen instantly, you need to work the paddle a couple times. But the dimmer will no longer dim. It will essentially act like a switch.

A smart bulb is designed to be powered continuously. You don’t want the switch to be able to turn it on and off directly but turning on or cutting the power to it. So if you have a smart bulb connected to a smart switch, then yes, you want to disable local control.

Yes, associations are z-wave to z-wave. I’m not sure what you’ll be able to do with a Zigbee bulb.

Did you buy a red or black series?

Edit: just looked. Yea if you had a red series it’d be easier. I think you’ll be limited because you won’t be able to trigger scenes with a black series and your bulbs are zigbee so associations won’t work.

Nope, that’s exactly how it works. Set it to Smart Bulb Mode. It won’t happen instantly, you need to work the paddle a couple times. But the dimmer will no longer dim. It will essentially act like a switch.

To clarify, I would like the smart bulb to always be fully powered regardless of the dimmer state (on, off, any dim percentage), then I could use hubitat apps to sync the switch state with the bulbs, but from your explanation it sounds like “smart bulb” mode should make the dimmer act like an on / off toggle switch. However I’m not observing either of those behaviors. The “smart bulb” setting seems to have no affect on behavior that I can tell.

I’ve worked the paddle a dozen times over several hour period. And, I’m observing, with “smart bulb” mode on, the power is still being attenuated by the dimmer level:

  • dimmer off = smart bulb off
  • dimmer 1% = smart bulb off
  • dimmer 35% = smart bulb on

Though even if “smart mode” did make it work like an on/off switch, it sounds like the black switch / dimmer only supports z-wave smart bulbs. I guess I can either hardwire the light to be always on or get a z-wave bulb (seems the only option is zipato for RGBW bulbs since the illumins and aoetec are out of stock)

I’m not sure if you are seeing what should happen.

1 - Put a dimmable NON-smart bulb(s) in the lamp.
2 - Using the dimmer, confirm that the lights brighten and dim by via the paddle. Dim the bulbs down to a low brightness and then turn the light off.
3 - Turn the Smart Bulb Mode on.
4 - Turn the light on via the switch. It should come on at full brightness. Holding the paddle up or down will not result in the bulbs getting brighter or dimmer. (This should go into effect right away with no more than a paddle press or two.)

This is what should happen. I’m on Smartthings, although I can’t imagine it should be any different on Hubitat. @harjms is on Hubitat, so he can comment on how that mode should work with Hubitat.

I tried what you suggested and found out that what happens is smart bulb mode does cause full power for the bulb, but only at 5%-99% levels. At 0-4% there is no power. So that’s why my bulbs were still off when I tried 1%. Well solved one mystery.


Hi, I came here because of a similar confusion. I am using hubitat, a zigbee bulb and the red dimmer. When I turned smartbulb mode on and local control off, it seemed like things still functioned locally.
But I “worked the paddles” a bit and I used the hubitat app to set the level to 100%.

Now when I use the paddles nothing happens, which is what I want.
I was also very confused because in the hubitat app, if I press the “off” button on the inovelli switch, it actually turns off the bulb (cuts power to it). I was expecting that to work like the power and not work.

But once I know that it physical access is properly blocked, I am able to hide the inovelli device from any dashboard and only expose a virtual button or something to toggle the light. I was expecting that my inovelli tile on the dashboard would work just like the physical paddle - causing an event on inovelli.

Maybe I am doing something wrong though.

It usually takes one paddle flip for the Disable Local Control to kick in, so it sounds like that’s what you did. You should also turn on Smart Bulb Mode to insure the dimmer’s output is always at full power.

Disable Local Control only stops power from being cut by pressing the paddles on the switch. You can still control the switch from the app and cut the power there. That’s expected. If you don’t want the app to be able to control the switch, then Disable REMOTE Control.

So it sounds like it’s working as expected.

Can’t answer your Hubitat questions. :confused:

1 Like

@Bry Thanks Brian. I now have it working like I want. It was a bit unexpected to have to treat the bulb as a switch to turn it on and off, but once I got past that, everything is good. I even set the colour differently based on the time of day.

I just need to figure out if I can do something in hubitat with press and hold. I would like to change the dimmer level up or down in someone presses and holds the paddle up or down. But since the driver uses up and down to indicate the button that was pressed, I don’t see how to tell that the paddle up was actually held.

Using press and hold is done via Direct Association. @Chris and @harjms are using them so they can provide more information.

There is a difference between a tap and a long press, but what I don’t know is how the use of Direct Association affects the ability to use taps as a scene controller.

by direct association, I assume you mean zwave association? If so, that’s out. My bulb is a zigbee bulb. The only other zwave device I have is the hub.

Yep. So AFAIK your option for dimming is via scenes. Multiple presses up and down set varying levels.

1 Like

Yes I can!

The switch treats central scene commands and associations totally separately. So no matter what you do or don’t have associated, or what you do or don’t have as locally attached load, tapping / multitapping / tap&hold will send central scene commands.

On HomeSeer this shows up on the Central Scene module as like ‘Scene 001 button pushed 2 times’. For dimming, it’ll be ‘scene 001 button held down’, then ‘scene 001 button released’ when you let go.

If you want to use an Inovelli switch to dim a ZigBee light, that has to go through the hub as @Bry said. On HomeSeer you can link two devices together, so if one device changes it will change the other device. That’s like a Z-Wave assocation, just done in software rather than Z-Wave. That doesn’t get you real time dimming though- it won’t dim the 2nd device until the 1st device releases the paddle.

Speaking conceptually- you could get a pretty good approximation of associations if you can get the hub to play nice. That is, you set both the Inovelli switch and the ZigBee light to have the same ramp rate, AND you get the hub to send the appropriate commands.
If the hub manages the dimming, then it’d need a rule like:
IF Inovelli switch central scene status becomes ‘scene 001 paddle held down’
THEN start script (‘increase brightness of ZigBee bulb by x% every second’)
IF Inovelli switch central scene status becomes ‘scene 001 paddle released’
THEN stop script ‘increase brightness of ZigBee bulb by x% ever second’)
Then have something that syncs the levels at the end so if they were dimming for different times it keeps them aligned.

Alternatively if ZigBee has a function like Z-Wave’s SWITCH_MULTILEVEL_START_LEVEL_CHANGE then that could work too…