SmartStart in HA

Anyone have a suggestion for how to use SmartStart in HA using zwave-js-ui?

I got a new 700 series zwave stick and can now use the QRR code and it adds the device to the provisioning list but I have no idea how to get the device to actually pair to the stick so it can be used. Nothing I tried worked, which involved a bunch of different power cycling, resetting and 3-taps to pair when scanning the code.

Once you have the device in the provisioning list, it depends on the device how to trigger the inclusion. Some devices simply need to be powered on, while others need some button sequence to start the inclusion.

What device are you trying to include?

Inovelli switches, hence why I asked here.

I tried a bunch of things but I can’t get them to include using the provisioning after I have provisioned them. Of course they’ll include, but not using the provisioning data.

Inovelli has made a number of products over the years, hence why I asked. I still don’t know exactly which model you’re trying, so I’ve been tinkering with a LZW31-SN because that’s what I have most of and what’s handy for me to tinker with.

I took an LZW31-SN that’s been working in my network for a year or so now, excluded it, factory reset it, and pulled the air gap to kill power to it. I then scanned the QR code into Zwave JS UI and set it up for provisioning. Finally, I restored power to the switch, and… nothing. Hmmm…

I fiddled with air gapping a few times and still nothing. I tried triple-clicking the config button to trigger an include and still nothing. I tried a signal strength test on the switch and it came up red. Odd, considering there are three other LZW31-SNs in close proximity to this switch all testing green, including one in the same wall box. Also, you know, it was working just fine not even an hour prior. I also tried putting my controller USB stick on a longer extension cord to get it closer to the switch (got it to ~17 ft away, just barely not line of sight), with no improvement.

To test if the problem was actually with signal strength, I started a manual inclusion, which worked! I let the interview run and once the switch was all ready to go, I then excluded it. Now, I’ve been tailing the zwave-js logs this whole time, but now I’m seeing Received Smart Start inclusion request followed by The provisioning entry for this node is inactive, ignoring request... in the logs. I had never seen anything about receiving a Smart Start inclusion request in the controller logs before.

So, I air gapped the switch again, re-enabled the provisioning entity in Zwave JS UI, and then powered the switch back on.

2022-11-17T15:23:42.606Z CNTRLR   Received Smart Start inclusion request                                        
2022-11-17T15:23:42.608Z CNTRLR   NWI Home ID found in provisioning list, including node...                            
2022-11-17T15:23:42.609Z CNTRLR   Including SmartStart node with DSK *****-*****-*****-*****-*****-*****-*****-*****                                                                                 
2022-11-17T15:23:42.623Z SERIAL » 0xXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX                                    (15 bytes)
2022-11-17T15:23:42.625Z DRIVER » [REQ] [AddNodeToNetwork]                                                             
                                    action:       Add Smart Start node                                                 
                                    NWI Home ID:  0xXXXXXXXX                                                           
                                    high power:   true                                                                 
                                    network wide: true                                                                 
                                    callback id:  134

And now the switch is reporting green when I do a signal test.


  • Use the signal testing function. If it returns red, maybe it’s not really a range problem but some other messed up state issue in the switch.

  • If the signal testing function is returning red when the switch should get good signal, a manual inclusion and exclusion seems to clear up whatever issue is going on in the switch.

  • I wish I had a factory new LZW31-SN to test how this works on a fresh switch, but the best I can do is holding the config button for 20 seconds.

1 Like

I was testing a switch about 10" from the USB stick so signal strength isn’t a problem.

I tried air-gapping after setting up the provisioning entity a number of times and no luck. I’ll have to try again. From the description of how smartstart works the devices try to connect when first powered on so that made sense to me but wasn’t working.

How do you re-enable the provisioning entity?

I find the provisioning interesting. In theory I could factory reset the stick and then go around factory resetting each device and air gapping them and they would all re-add with the same name, location and security settings as they had the previous time.

I had a switch where I hit the config button by mistake and it stuck down and factory reset itself. With provisioning, an air gapping would have put it back instead of going through the adding and renaming to get it back.

While it may not be, my testing seems to indicate that a red signal strength test might also indicate a weird state on the switch. So, it’s worth trying out to see if it comes up red.

In Zwave JS UI’s Smart Start tab, the fourth column is an “Active” toggle switch. After my manual include/exclude I found that switch turned off for the device I was working on.

Actually, I’ve been informed that the signal strength test might just not do anything until the switch is included, because the switch has to know which Z-wave network it’s testing.

So, I’m not sure how to predict if Smart Start is going to be stuck or not. But in my limited testing, it sure didn’t want to kick in after a factory reset without a manual include/exclude first.

I tried again last night and it started working. I power cycled a couple of devices that were not included on a network and they started including. I found devices would also start adding as soon as they were factory reset, even before releasing the config button. A Black dimmer and switch worked fine. Two Red switches worked but one had to try twice and left a dead missing device. First Red dimmer failed to add correctly after multiple attempts. This was one of the devices I was trying the last time and it’s a little further from the USB than the others, but last time it never even tried to add itself. None of the ones I tried did.

Interesting thing is that it will keep trying to add the device over and over, starting again each time it fails. The Red dimmer caused 5 dead devices to be added before I stopped it. I reset it, unchecked all the security boxes in the provisioning and tried again and it added 3 more failed devices. I tried adding it with S2 with the DSK code and that failed too. It would only add insecure. It’s on the latest 1.61 firmware.

I’m curious how this could work. My understanding of the SmartStart features were to configure the device with pre-configured settings by the manufacturer. Are you saying that zwave-js will allow you to store your own settings on the software side, and when it recognizes a known qr code will configure that device with your own custom settings?

It’ll add it automatically and put the name and location in so that HA sees it like it was before. It won’t setup any of the parameters.