SmartThings Edge Driver missing settings like Smart Bulb mode

I am installing a new red series dimmer switch. I was able to get it to pair with my SmartThings hub and get the new edge driver installed (although pairing was quite difficult and all of the red series documentation still describes how to install device handlers, which is outdated). In the SmartThings app and in the IDE, I have some advanced settings but I do not have the one I purchase the switch for - Switch Mode (aka “disable internal relay” aka “disable local control”) where I can set the switch to work with a smart bulb so that it does not cut power when off, but instead controls the bulb via Z-Wave or a scene. That option is parameter 52 here, and you’ll note that there are other options listed there which are not in the current options.

Based on other recent forum posts, I think this is just something that needs to be added to the driver. Does that sound correct? Is it possible to contribute to the driver source code?

Since the documentation is not up to date I’ll share the settings I have today (Nov 11, 2022) in the IDE:

  • Dimming Speed - How fast or slow the light turns on when you hold the switch in seconds (ie: dimming from 10-20%, 80-60%, etc). Value 0 - Instant On. This parameter can be set without a HUB from the Configuration Button. Finally, if you are using a,dumb switch in a 3-Way setting, this parameter will not work if you manually press the dumb switch (it will only work if you press the smart switch). Set value (range 1…100) - Tap to set
  • Power On State - When power is restored, the switch reverts to either On, Off, or Last Level. Example of how the values work: 0 = Off, 1-100 = Specific % On, 101 = Returns to Level before Power Outage. This parameter can be set without a HUB from the Configuration Button. Set value (range 0…101) - Tap to set
  • LED Indicator Intensity - This will set the intensity of the LED bar (ie: how bright it is). Example of how the values work: 0 = Off, 1 = Low, 5 = Medium, 10 = High. This parameter can be set without a HUB from the Configuration Button. Set value (range 0…10) - Tap to set
  • LED Indicator Intensity (When Off) - This is the intensity of the LED bar when the switch is off. Example of how the values work: 0 = Off, 1 = Low, 5 = Medium, 10 = High. This parameter can be set without a HUB from the Configuration Button. Set value (range 0…10) - Tap to set
  • LED Indicator Timeout - Changes the amount of time the RGB Bar shows the Dim level if the LED Bar has been disabled. Example of how the values work: 0 = Always off, 1 = 1 second after level is adjusted. Set value (range 0…10) - Tap to set
  • Dimming Speed (Z-Wave) - How fast or slow the light turns dim when you adjust the switch remotely (ie: dimming from 10-20%, 80-60%, etc). Entering the value of 101 = Keeps the switch in sync with Parameter 1. Set value (range 0…101) - Tap to set
  • Ramp Rate - How fast or slow the light turns on when you press the switch 1x to bring from On to Off or Off to On. Entering the value of 101 = Keeps the switch in sync with Parameter 1. Set value (range 0…101) - Tap to set
  • Ramp Rate (Z-Wave) - How fast or slow the light turns on when you bring your switch from On to Off or Off to On remotely. Entering the value of 101 = Keeps the switch in sync with Parameter 1. Set value (range 0…101) - Tap to set
  • Invert Switch - Inverts the switch Which? - Option enabled: Enabled Option disabled: Disabled Enable
  • Auto Off Timer - Automatically turns the switch off after x amount of seconds (value 0 = Disabled) Enable - If you disable this option, it will overwrite setting below.
    Set value (range 1…32767) - Tap to set

Out of date documentation which still says to use device handlers includes:
Apologies, I had to break the links on purpose as it says I cannot have so many links in a post. Remove the space after “http” to fix the link.

  • Resources | Red Series Dimmer Switch - Manual
  • http s://
  • http s://

For others who are trying to get the switch working, I was able to install the edge driver using the instructions here for the blue dimmer switch, but I chose the “red dimmer” driver for step 4 since that is what my switch is.

As a stopgap measure, for others who find this post who are trying to enable smart bulb mode, if your switch is buzzing when you switch it on and off, you should change the “ramp rate” to 0. The buzzing is happening because the default behavior is to dim the fixture by cutting power, and smart bulbs are generally not dimmable bulbs (like, they can dim programmatically but are not “dimmable” in an electrical sense the same way dumb bulbs can be). When the ramp down or up occurs, the switch is overloaded because your bulbs require more power than it is delivering. This can damage your bulbs or your switch and may be a fire hazard although I’ll let folks with more electrical knowledge than me chime in.

If I’m understanding correctly, you have a Red dimmer running with an Edge driver and you don’t believe that Parameter 52, the Smart Bulb Mode is present. I’m not sure why you are not seeing it, but that setting is definitely present in the Edge driver.

I noticed that you referred to looking in the IDE for settings. With Edge drivers, you should ignore the IDE as it’s in the process of being deprecated and for Edge devices, not reliable.

However, I’m curious about why you are seeing device settings in the IDE since you stated you are running an Edge driver. If an device is running Edge, it will be listed in the IDE with a type “Placeholder” and there will not be settings there. So I would double-check to ensure you are really using an Edge driver.

The easiest way to check to ensure you’re using Edge is to open the device page IN THE APP. Select the 3-dot menu top right and look for the “Driver” menu. If you don’t have a “Driver” menu, you’re not on Edge.

To turn on the Smart Bulb Mode, open the device page IN THE APP, select the 3-dot menu top right and select “Settings”. Scroll down to the bottom. The Smart Bulb Mode is the last item.



Thank you for your reply! Yes, that is correct.

I used the IDE to paste in the settings I have because I could select the text there and the options I see in the IDE are the same ones I see in the SmartThings app.

Here’s a screenshot of my devices in the IDE:

The switch I’m trying to set up is named “office lights” and has a type of “Inovelli Dimmer”.
Here is the detailed view from the IDE:

The link to edit preferences is how I found the options I pasted in the previous reply.

Here is the device in the SmartThings app:

The ellipsis menu is this:

Here are the settings I see in the SmartThings app:

splitting into two replies due to image count limits

part 2/2

The information page, which has controller version 2.3.10-1:

In the IDE it is not listed with type “Placeholder”, it is listed as “Inovelli Dimmer”.

I don’t have the Driver menu, so I guess the device isn’t using the Edge driver. However, I do believe I have installed the Edge driver. Maybe I just need to associate it with the device somehow.

I followed the Device Edge Driver Installation from this guide.

I have enrolled my hub:

And installed the “Inovelli Dimmer Red Series” Edge driver:

How can I tell the device to associate the driver I’ve installed?

The device has to be added to Smartthings post Edge driver install. I’m guessing that didn’t happen. So exclude your dimmer and then re-add it. It should pick up the Edge driver then.

1 Like

Ok, I’ve got it set up now. Thank you for your help! Excluding and adding the switch again did show with the Edge driver like you said.

I guess my setup is complicated, but I did run into a multitude of issues while doing this that aren’t Inovelli’s fault but may be useful if someone else runs into the same thing, so I’m going to add more info about my setup and what I had to do to get things working.

I am using Linkind WiFi smart bulbs that I had set up previously in the Linkind app, and expected I could control these with the Inovelli red series switch as it states that you can control WiFi bulbs. This page describes how to do that by controlling a scene.

I had the bulbs set up so that I was controlling them only via Alexa voice control, which directly set the bulbs on or off, rather than a scene. This meant I needed to make a scene in the Linkind app in order to get the switch to run the scene, which was where I ran into a classing smart home problem… Linkind is now AIDot so I needed to migrate my account and reauthenticate all of the previous account linking I had done before I could add a scene. In addition, my bulbs did not migrate properly, and because I had already replaced the wall switch with the Inovelli switch, I wasn’t able to put them into pairing mode by cutting the power, so had to take out all the bulbs and put them in another lamp in order to add them into the new AIDot app, and in the meantime I was not able to control the bulbs at all because they had lost their association in Alexa. Once I got that all sorted…

I noticed in SmartThings that I actually could directly control the bulbs in a routine rather than using a scene, so tried that since I figured it would be faster. This worked but the Linkind/AIDot settings don’t allow for much control so I wasn’t able to actually get the bulbs to turn on to an appropriate brightness/color using the terrible color selector (screenshots below) so ended up deciding to go the scene route anyway.

Although the recent colors in that screenshot appear to show a bright white and a soft white, they are very dim at 100% brightness so are not acceptable for me to actually see. I tried to take a picture but the automatic brightening/exposure settings on my phone made it look fine.

Unfortunately, Linkind/AIDot scenes don’t show up in SmartThings. They do show up in Alexa, but controlling anything from Alexa via SmartThings is much more complicated than you’d think. Of course, adding to that (and the main reason for this thread) is that SmartThings removed groovy control and their SmartApps functionality. The SmartThings forums are full of posts about SmartApps which let you control Alexa things, but none of these work anymore. After quite a bit of searching, I was able to set up the Inovelli switch to run the Linkind/AIDot scene which allowed me full control over the lightbulb settings! It’s janky and convoluted, but here we go:

  1. Set up your lightbulbs in the AIDot app and make scenes for on/off/whatever other settings you want to control via the switch. Test that these work when running the scene manually in the AIDot app.
  2. Install the AIDot Smart Home app in Alexa - now your scenes will show in the Alexa app (jank 1: if you also connect AIDot in SmartThings, and SmartThings in Alexa, you may have duplicate devices, although this seems to still work fine via either “device” in Alexa).
  3. Follow the instructions on this post to get “vEdge Creator V2.5” to show up in SmartThings
  4. In SmartThings, click the vEdge Creator and create a lock (jank 2: this will have a lock icon and “locked” will mean on while "unlocked’ will mean off). Name this lock something descriptive; I did “Alexa switch - locked = office on”, although I’m rethinking what I want to name all my devices in order to use Alexa voice control.
  5. In Alexa, connect SmartThings if you haven’t yet. Ensure that your new “lock” has been discovered as a device in Alexa. Set up 2 routines for your new virtual lock - when the lock is locked, run the scene that turns the bulbs on, and vice versa for unlocked/off. Play the routines manually in Alexa or via voice control to ensure they work.
  6. In SmartThings, create a routine that when your Inovelli switch up button is pressed, it locks the virtual lock, and vice versa for down/unlock.
  7. Repeat steps 4-6 for any other settings you want - I have set the double up press to turn on party lights!

(jank 3: this setup is not very fast and isn’t completely reliable. It usually takes around 3 seconds for the lights to turn on or off, and many times, one of the bulbs won’t have gotten the message so I have to click it again.)

(jank 4: to control the lights via Alexa voice control and have the switch work properly, you need to only control the virtual locks (or set up more routines) - to turn the light on, say “lock the <virtual lock name>”. If you try to “turn on” the Inovelli switch device with Alexa, it’ll control the LED on the switch itself. If you “turn on/off” any of the bulbs directly, the “lock” status of your virtual lock will be in a state that doesn’t match the state of the lights)

(jank 5+: In order to control one fixture, in SmartThings, my office now shows the Inovelli switch, 3 smart bulbs, and 2 virtual locks, as well as the vEdge Creator “device” that’s not assigned to a room, and in Alexa I have 4 routines, 3 scenes, 2 locks, 6 bulbs (they are doubled due to Alexa discovering from both AIDot and SmartThings), and the Inovelli switch which shows as a light but the color and brightness control the LED on the switch rather than the lights that the switch controls)

This was quite difficult for me to set up correctly and seems like it’ll be prone to breaking. My technical knowledge is very high (I’m a software engineer) and I have set up many smart devices, including building my own. I have been frustrated with a few convoluted setups in the past but this one was by far the most difficult. I am planning to take the plunge into using Home Assistant at some point which will hopefully simplify and improve things. This also could have been better if I was using a Z-Wave light bulb instead of a WiFi one, or a different brand of WiFi bulb where the scenes would appear in SmartThings, but replacing working bulbs seems wasteful. I received the Linkind ones for free from a promotion from the company.

[Edit] jank 6: In SmartThings, I do have an actual lock that I control via SmartThings and Alexa. Now when I open the app I get a big red unlocked icon (screenshot below) even when my front door is locked because my “locks” aren’t locked, and there’s a super handy “lock all” button which, if clicked, will play all of my “on” routines, leaving the bulbs in who knows what on state. In addition, I used to use that handy “lock all” button to, ya know, lock my front door, and don’t want the lights to turn on. I may swap “locked” to mean off instead of on so that if one of us accidentally “locks all”, it just turns off my office lights instead of sending a bunch of different on states to the bulbs. Definitely not happy with this setup :frowning:

1 Like

Update: I couldn’t deal with the annoying parts of the setup - particularly the extreme delay in turning the lights on and off, and having the virtual locks in SmartThings and Alexa. I ended up getting a Hubitat hub since they were on sale and setting up the switch on that instead. The setup is straightforward and works well besides a 1-2 second delay which is unavoidable with wifi bulbs. I believe swapping the bulbs to zigbee or z-wave would remove that but I won’t do that until these die to avoid waste.