SmartThings Edge Drivers: LZW30-SN, LZW30, LZW31-SN, LZW31, LZW36, LZW41, LZW42, LZW45, LZW60, VZM31-SN, VZM35-SN, VZW31-SN, VZM36, NZW30, NZW31

Do you know of the notification options used in sharptools? I don’t see the option in sharptools

Are you referring to triggering and LED bar notifications via a Sharptools rule? If that is the case, that can be done in the flow section. After selecting the device, add the four setnotification items, level, duration, effect and color. You need to set all four of them for it to work properly.

Thanks for the reply! That’s exactly what I’m looking for. Do you have an example for me? I selected the light switch, under set command I see these options: {poll, refresh, resetenergymeter, setColor, off, on, setSaturation, setHue, setLevel, configure}.

Here is an example. The options you listed seem like they are missing some.


Fantastic. It turned out I had to refresh in sharptools my smartthings hub. Didn’t know that was needed. Do you have a link to where you found the values for all of these options? You have a [5] where I see [solid] as an option. Inovelli Switch Calculator Directions - Google Docs

I found the color wheel here: Inovelli Switch Toolbox

Pieced together some values from this: SharpTools-SmartThings Inovelli Notifications - #18 by sabre170

If there is something all in one place, I don’t know/can’t remember where it its. I use Routines for notifications, so this was just a test when we were beta testing the Blue 2-1. @harjms may recall.

One way to back into these parameters is to code a routine with the parameters you want. Then use TAustin’s API browser and look at the JSON for the Routine in the details tab. There settings are displayed there.

The Inovelli Switch Toolbox is fine for the color and level. 255 for indefinitely. The effects are lower decimals, so you can just start walking through them to see what you get, although there must be a chart somewhere.


I can’t seem to find the Offset setting for the 4-in1 sensor. Is it hidden or not available in the edge driver?

Confirming that I don’t see a temperature Offset setting in mine, either. EDIT: The Groovy driver used to have offsets for temp, humitity and illuminance.


The framework supports a built-in parameter for temp and humidity offsets (UI limited to +/- 10 units), Eric just needs to add them to the profiles where temp/humidity are capabilities. The offsets are then applied automatically. Or add in custom ones of course.

1 Like

I’ve updated the driver to have temp and humidity offsets.


Confirmed in the 9/11 4in1 driver.


New to the community.
Just updated the edge drivers.
Only one of my red series on/off switches is labeled as “energy metering” and doesn’t include a smart bulb mode.

On/Off switches don’t have a smart bulb mode because that doesn’t make sense for a switch. Disable local control and you have the equivalent of SBM on a dimmer.

1 Like

Can you post a screenshot of the “Driver” page from the device as well as the device itself?

Thank you. Here is the driver screenshot and settings from smartthings. From the advanced web app a shot showing the device name. After exclusion and another inclusion the name changed from metering device to switch power energy. Do you want a picture of the switch as well?


Thanks, what does the one say that doesn’t say inovelli-switch-power-energy? You say only one of them is labeled as “energy metering”?

Oh, I see. The switch labeled “inovelli-switch-power-energy” had a different label before I reset and added it to the network. The previous label was something like, energy metering. I’ll try to reset and re add the switch again to see what happens. Here is the switch pic. Could pictures of my other inovelli on/off switches (front, setting and driver) offer a better picture of what’s causing this one switch to act differently?

I wonder if the switch didn’t get included with the correct fingerprint. I saw this happen a long time ago when SmartThings started forcing everyone off of groovy. Can you send a screenshot of the devices and the drivers they are using. Here is an example:

This shows the label and the name which seems to be the device driver profile name.

Here is a smartthings screenshot
Both devices named, “inovelli-switch-power”, don’t have the smart bulb setting.

Did the red on/off have smart bulb mode as an option? I am looking at the Hubitat driver and there is no mention of it in the code. I think @Bry mentioned this already.