Smartthings z-wave stopped responding

I recently purchased as a test the Red on/off switch to replace a GE that went dead. I have had a bunch in the last year just start clicking and die. Anyway, I liked the button features of the inovelli and thought I’d try one out before going nuts. I installed the switch, the handlers and the ABC app. My kids room I set this up in only has Hue bulbs so the GE switch was set to turn back on any time it was turned off for always on power. For the inovelli, I removed local control and set the buttons to turn on and off the Hue bulbs. This was great, I could finally use the switch normally again versus just the TAP I put in that room. I also set the notifications to let me know when the front door unlocked. That worked great too! Last but not least I set 5 presses on Hold (down button) to lock all the doors in the house. Again just to test capabilities before I buy a bunch more of these. Everything went great, super fast and reponsive! I went to bed very happy debating if I should buy just dimmers or dimmers and on/offs because I could still disable local control and use the dimmers with smart bulbs as in off and get the larger notification bar. Anyway all of the sudden this afternoon, all z-wave devices stopped responding. I repaired the network multiple times, over 20 minutes each time and it just won’t work. I purchased smartthings through their kickstarter and upgraded to their second hub a few years back. I have never had an issue like this before. Has anyone else experienced this with adding in inovelli switches or device handlers?

Is SmartThings experiencing Cloud issues? I went away from ST because our internet isn’t stable at times and would interfere with the smart switches.

maybe it’s just a coincidence because for the hub, it’s just another switch.

should the switch have died or failed, it wouldn’t hurt the other devices. did you try restarting the hub?

Doesn’t seem to have cloud issues as all my WIFI and cloud connected services are working no problem. Just the z-wave devices acting up…

as stated in my other reply, it’s all of my Z-wave devices and none of my other devices that are acting up. reset the hub multiple times, pulled the batteries while doing so before i get that question. did multiple z-wave repairs at over 20min per. After reset i can usually get one device to turn on or off and then that’s it they become really slow for the second command then non responsive… @EricM_Inovelli have you heard of this happening before after installing the switch and device handlers as well as ABC? Again, everything was super speedy for the few hours i played with it after installing.

@EricM_Inovelli and everyone else. Thank you for taking your time on this. I did figure it out just now after playing a bit. the z-wave devices were very slow and not reporting their correct status to smartthings. I went to the new Inovelli switch and tried doing a few of the things i set up and got 0 response. I tried the config button 3X and got nothing. tried the config button for 10+ seconds and got nothing. tried resetting and got nothing. I went to the breaker and turned it off for 30 seconds and then back on. went to the switch and it started working again. the only setting that was wrong after the reset is the switch started local control of the lights again. I went into the settings of the switch and d"disable local control" was still set to yes. i moved to no, saved, then back to yes, saved and now everything is working well again. fast and reliable. for now. I’ll mark it up to growing pains and keep an eye on it. I still plan to expand the inovelli foothold in my house.

1 Like

thats’s strange. have you tried removing the switch from smartthings? (just to narrow things down).

Glad to hear it recovered. Remember that there is a “breaker” within the switch itself that can be pulled to remove power from the switch. If I’m honest in the few months I’ve had 15 of them installed and had to do it like 3 times for 1 switch each time. Randomly something acts up so they aren’t perfect, but 99.9% reliable. Hopefully that puts your mind at ease ordering more.

Yeah, I didn’t bother with the air gap and just went to the breaker box. easier than getting a screw driver, I can never get my fingernails in there on the GEs so I didn’t even think about it. I’ll still buy more but it does suck that they become unresponsive. I have more than 20 of these things around the house so to think i’ll have to try and figure which one is the culprit each time is a little discouraging. a whole house breaker flip would do the trick but what a pain. And worse than that… My wife and mother in law (when staying here) complaining about all my smart home stuff. They like it when it works, but boy oh boy do i get an ear full when it doesn’t.

I guess I’m having a bad night. Been at it for a couple of hours. The device stopped working again. It would turn on/off as far as the relay goes both at the switch and via the app and the notifications still work. I can change the color of the led and other settings. However, all the apps stopped working. Single taps, double taps ect. Nothing works. I cut power to the switch multiple times. Rebooted smartthings. Multiple z-wave repairs. Excluded the switch twice and replaced it in the app twice and finally factory reset by holding the config button down 20+ seconds and then replaced in the app. Still at square 1. Everything but the button pressing works. Any ideas anyone?

@EricM_Inovelli Update: It’s the morning and I spent some more time on it. Still no fix that I can tell figure out. I really don’t want to completely remove all handlers apps ect. and try to start from scratch, but nothing else has worked to this point. So many hours… I have 12 dimmer switches coming (and planning on expanding and replacing current smart switches) now and I don’t want to install into a broken system. Hopefully this has happened before and there is an easy fix i’m unaware of.

Update: I finally got it working again. I had to delete the switch, install it as a new switch and reprogram all of the automations I had set. that was day two. I hope this isn’t a common issue. Maybe I’m just lucky… I have a bunch more switches coming so we’ll see what happens. When it works, it’s awesome!

Man, sorry about the crazy issues. Keep us posted if you experience it again. We have some firmware updates for the switch but I’m not sure if that would have helped.

By the way, what was the load attached to the switch? Anything unique about your setup?

Today for the third time in about 9 days my ON/OFF switch (the first one I installed) was reset. I disabled local control and for some reason it always turns off after hours of being on. there is no automation to do so and the setting don’t have auto off. Then randomly (3 times now) it goes back to default and does not communicate with my ST hub. The notification light goes back to blue and game over. Need to remove from network and redo the whole thing again. I have installed 5 of the dimmers (got 12 so far) and they have been working for days so far. I have a little issue with the non neutral dimmer but so far so good with the dimmers…

@EricM_Inovelli It keeps resetting, Would a firmware fix this? Was it a known issue? at this point I need to pull it and replace it with one of my dimmers until i figure out what to do with it…

I did a firmware update to .17 and it seems to be holding right now. I’ll have to do more testing. I also had an issue with the association tool on one of my dimmers until I updated that to .44 now that seems to be working too. I wish there was an easier way to update firmware though. Removing it from the system upgrading and then reinstalling in the home system is kind of a pain. for whatever reason, doing a replace to try and keep automations and settings doesn’t really work…

If you add the Z-Stick to your SmartThings network you can probably do an update without excluding. Just be careful not to mess with other things inside of the PC Controller software.

  1. Put your SmartThings hub into inclusion mode.
  2. In network management in the PC Controller software press “Classic Learn Mode” and wait for it to join the network.
  3. Once this is finished you may want to save the security keys in case you want to do this process later. Otherwise you might have to rejoin the controller. Click on the little shield in the upper right and click “Save” and save the xml file to somewhere you will remember.
  4. Find the node that you want to update. The node ID is in decimal in the PC Controller software and in HEX in the SmartThings IDE. Google a Hex to Decimal converter tool and match the ID to the ID in PC Controller.
  5. In network management click on the node and then click on “Node Info”. This will let the controller know if the device was included with security.
  6. Proceed with the upgrade process that is listed in the support KB. Be prepared to wait longer if the device was included with security. Sometimes it can take 30 minutes or so to update.

That’s awesome! thanks, I’ll give it a try.

1 Like