SOLVED: Blue 2-1 Two-Switch & 7 Light Binding - inconsistent behavior

Hey all -
I have some odd behavior with my Blue Switch setup in the kitchen. Here’s what I have:

  • Two Blue switches, both set to Smart Bulb Mode
  • 7 Hue RGBW Bulbs in ceiling fixtures

I’m using Z2M in a stand alone docker and have set it up as detailed here.

The oddity is that sometimes upon turning the lights off at either switch, one and some times two bulbs will blink on and off a couple of times. They might both turn off at the end of the blinking, some times one will stay on and one will stay off and other times they both end up on. It happens less when turning on.

The bulb(s) that blink are not consistent, but they seem to be the same ~4 out of 7 that are grouped.

I have broken down my ZIgbee network, repaired everything, made sure that firmwares are up to date and have not seen any difference in behavior.

Am I missing something very dumb on this?

Any way you could take a video of it? It sounds like the behavior of when smart bulb mode isn’t on, but that doesn’t seem to be the case here.

Looks like I also need to update the instructions for the Z2M page, I copy/pasted ZHA instructions and then never fixed it… ugh.

Here you go:

Did 3 power cycles. The first caused the light on the left to blink then turn off. The others worked fine.

The lights near the windows also do it occassionally. But if there’s one thing that is consistent, it’s the inconsistency by which this happens.

Wait @Eric_Inovelli I thought we grouped in the EP1 of each switch in multi-way with the bulbs, then bound EP2 from each switch to the group.

Gah now I’m confused.

Man I’m getting confused too honestly. I don’t play with Home Assistant as much as I should so I’ve lost touch with how to set it up which is when I wrote these instructions, but things change so fast and I can’t keep up.

I wonder if honestly it would be easier to scrap the group bindings and go with individual? I have a similar setup in SmartThings (two switches + bulbs) and just individually bound everything and it works great.

I need to dust off the Raspberry Pi and mess with this again. I can’t remember who the resident Z2M guy is who would know the answer to this, do you remember? I think you’re using ZHA, right?

Hol’ up. May have found the source of the issue.

I did the exercise of rebinding the two switches via groups as mentioned in the link I provided. I found that the bindings on both switches had OnOff and LevelCtrl checked.

Just removed the OnOff from both and have had no blinking issues over ~5 power cycles. Will monitor and update the thread here accordingly.

As my late Father-in-Law would tell me if he were here - RTFM closely :slight_smile:

1 Like

Yeah and I only have one prod switch so I can’t test 3+ way anymore, unfortunately.

1 Like