*SOLVED* Lighting Automation - No Buttons found (Scene creation)

Hey everyone, I’m having trouble following along with the Setting Up Scenes walkthrough… I gotta be doing something wrong.

I have a LZW30-SN Switch in my master bedroom. It is connected to SmartThings (shows up in the app, voice commands with Alexa control it).

I’m following the instructions to the “T” as far as I can tell. However, when I get here:

  • Next click, “Select Trigger”, select, “Button” and click, “Done”
  • Click on, “Which button?”,

All I see is “(Required) No device found”

If I change “Button” to “Switch” I see my Inovelli switch, but I don’t have button options.

The original issue was due to installing the incorrect device handler - I believe I had installed “LZW30” instead of the “LZW30-SN”

My next issue was much harder to identify because the SmartThings app doesn’t exactly tell you the device isn’t connected right. I remembered the app saying the device wasn’t added, but then is showed up exactly as I expected it to “Inovelli Switch Red Series LZW30-SN” with all the functionality available. However, the light automation wasn’t working.

Long story short, a couple factory resets, My Device deletes, and banging my head against the wall I was able to get the device functioning

Which ST App are you using? The older Classic or the newer Connect?

Did you install BOTH device handlers, both the Parent and the Child (unpublished)?

I use both, but I am following the instructions and using the New App.

This is where the confusion comes in:
I do not have a “Switch Child Device” Device Handler. I don’t see instructions for that. Under the Z-Wave Association Tool I see Parent and Child but they get installed under “My SmartApps” not " My Device Handlers"

I removed the device from SmartThings and re-added it and it is now showing up in Buttons.

Ok, so I would do this in the Classic app. That’s actually the only one I use as I’m not converting until they make me. And don’t quote me on this, but I don’t think 3rd party device handlers are fully supported in the new app yet.

You have to start by getting the Device Handler code in the “My Device Handlers” section of the IDE. Once installed correctly, you’ll see the two entries in the screenshot I posted above. Here are Inovelli’s instructions on how to do that:

**** EDIT EDIT EDIT ****

I just looked at the link I posted and I’m not sure that is complete. There should be a parent and a child handler. There used to be better instructions on the old website about how to install.

Tagging @EricM_Inovelli Is there just a single DH now? What happened to the child handler?

@Bry, just wanted to update you that the LZW30-SN actually doesn’t need child device handlers installed anymore. It uses some built in SmartThings ones.

1 Like

I think what may have happened here is that the device handler was installed after the switch was paired to ST and possibly the device type wasn’t selected after the handler was installed.

If it still showed, “Z-Wave Switch” or something more generic, then ST doesn’t recognize it as a button controller, hence why you saw this:

Idk, just a hunch!

1 Like

@ericm Thanks, learned something new!

@Marine6186 Based on @Eric_Inovelli 's suggestion, go the the “Applying the Code (Optional)” section in the installation instructions I referenced. Go back into the IDE in the My Devices section and double-check the Type. If it doesn’t list it as an Inovelli, go to the bottom and select “Edit” and change the type.


I appreciate all the quick responses. Thanks everyone

I’m still having trouble, but it is a different issue. The lights are responding to the new automation. I will try to remember exactly what I have done. There are a lot of articles, some are newer than others and because I have read so many of them, I’m not 100% I remember where I read everything.

So, from the beginning:

  • I remodeled my master suite and had it rewired professionally. Asked them to install the LZW30-SN. It is just a Single-Pole installation.
  • The switch physically controls the 5 recessed lights I am trying to control with “Buttons” my wife likes to use switches and I think everyone who uses smart bulbs HATES when people turn off their switches. So these switches are the obvious choice for this application. Your products sound amazing (I’m sure they are, just don’t have them working yet :stuck_out_tongue_winking_eye:)
  • The Switch is installed and Paired with SmartThings (app shows Inovelli on the device and I have lots of addition functionality)
  • The Switch Device Handler is installed (SmartThings IDE > My Devices shows "Inovelli Switch Red Series LZW30-SN)
  • I follow all the instructions on “Setting Up Scenes”
  • When I hit the “Off” button on the Switch, the switch physically turns off.
  • When I hit the “On” button on the Switch, the switch physically turns on.
  • If I “Disable Local Control” and Press On or Off - nothing happens. *I don’t remember where I saw this tip, but it isn’t on the “Setting Up Scenes” page.

Not sure where I am going wrong…

Just trying to make sure I understand. Do you have smart bulbs in the 5 recessed lights? If so, which ones? Why are you using smart bulbs there instead of non-smart bulbs? Color adjustability? It would help to understand a bit more what you are trying to accomplish in the end.

I am using Phillips Hue Color bulbs.

I’d like to be able to turn these lights off with my voice or my switch and also setup different modes using the switch. For example:

  • Going to bed set the lights to a soft white or yellow.
  • Getting ready in the morning - turn on just the one closest to my closet.
  • The list goes on and on

Got it. Makes perfect sense.

So what you need to do is disable the internal relay. This will insure that the smart bulbs are contantly powered, which is what you want. I’m not sure if you need to disable local control or not, as I would think disabling the relay should cover that, unless you need to disable local control to get a single tap up and down to work as a scene. In not using single taps so I’m not sure.

Then, set up scenes to do what you want. You’ll want a single press up and a single press down to mimic the lights going on and off (or whatever the wife thinks that ought to do). Then you’ll set up other scenes for your light colors, light combinations on/off and connect them to multiple presses up or down.

I’ve disabled the internal relay by setting “Disable Local Control” to Yes. I can confirm, the switch no longer physically cuts power to the lights (i.e. lights always have power running to them)

But I have tried, multiple combinations in the Smart Lighting automation, single tap, double tap, triple tap… none of them are sending the command to the lights.

Let’s make sure the DH is installed correctly first. Post a screenshot of the device entry in the My Device Handlers section of the IDE. Also post a screenshot of the device entry in the My Devices section of the IDE, both in that section and after you click on it to see the details.

Thanks @Bry, here is that info

Is that larger graphic from the “My Devices” section of the IDE? Mine looks totally different so I’m not sure that’s the correct screenshot. I see Eric Maycock’s name in what you posted. Eric wrote the device handler, so that seems more related to the handler, not the device.

You’re doing this in the Classic app, right?

The top of the device details should look like this:

I just noticed under the data section that is slightly cut off on your screenshot you have info… mine shows “ZWAVE_S2_FAILED” Possibly the issue?


Quite possibly. I’d exclude the switch from the hub and then add it again.


That did the trick. It took a few tries and a factory reset to get it to show up and working correctly.

I really appreciate all the help!