Spike up the dimmer level when turning on at lower dim level

Not sure how to explain this… but some of my lights require a certain dim level in order to turn on.

Right now, I have to have a rule in place in my hub (Hubitat) to turn up the dimmer level on these lights and then return them to their initial settings.

This works, but can sometimes take a few seconds if the hub is “busy”. I would love to have this feature executed by the firmware based on a minimum on level that I set in the driver settings.

Thanks!

What dimmers or bulbs are you referring to? Many of Inovelli’s dimmers and bulbs have the ability to set a minimum and maximum dimming level as do a few other manufacturers devices, many don’t have that ability though as well.

I have the LZW31-SN Red series DimmingSwitch. The problem is that on a lot of LED lights, the voltage required to turn on the light is higher then the minimum voltage.

In my use cases, I need the light to be, say at 20% for it to turn on, but I want it to be at 15% once on.

I am aware of the possibility to adjust the minimum value and have already adjusted it for my setup to the minimum before the lights are off. But at that minimum value, they will not turn on.

Makes sense?

Welcome to the community @SViel!

I can share a bit from my experience with this exact issue. Inovelli dimmers do handle the minimum value very well. What you might be discovering is that some (many perhaps) LED bulbs dim to low intensities better when starting from some higher value. When starting from zero (off) LED bulbs often require a much higher minimum value to get them to turn on as their AC-DC power supply capacitors have to charge and that circuit has to stabilize. There are some bulbs that do this better than others but all “dumb” LED bulbs will experience some amount of the issue.

First I suggest avoiding mixing bulb manufacturers, types, and wattages on the same dimmer. It can work especially if the drivers are identical but I would encourage you to test it first.

Next I would recommend that you “calibrate” your dimmer-bulb pairs. I adopted this procedure and it works well for both incandescent and LED loads. The particulars of where to click/type will vary based on your hub but in principle it is the same. The goal is to find a minimum value that is just below the point at which the LED bulb will glow. It might be higher than you expect.

  1. Set the dimmer to a minimum value of 1% and a maximum of 99%. Click Save Preferences to commit the values to the switch.
  2. Using the device page interface (so you can drive the bulb directly to known values) start with a guess as to a value below the minimum you know will work and send the dimmer to that value with a time of zero. For example if you know that at 30% your bulbs will emit light but at 15% they won’t try starting at 21%.
  3. Increase the intensity by 1% and watch your bulbs carefully. Remove shades/diffusers so you can see the bulb directly.
  4. Repeat the 1% increment up until you see the bulb light up. Note that intensity value.
  5. Turn off the light. Wait 30 seconds. The driver in the LED bulb has to completely discharge and reset to confirm that what you see is accurate.
  6. Repeat the process again but now start only 2% below the value you noted. You should see no light at all. If you do see some light then go back to step #5 adjusting your noted value from step #4 down by 1.
  7. If you do not see any light you’re done. The minimum value you should enter into the driver is 3% below the value you noted in step #4. For example, if 31% is the first value at which your bulb emits light then the minimum value to enter into the driver is 28%.
  8. Turn off the dimmer. Enter the minimum value into the driver. Click Save Preferences to commit. For some of my dimmers I had to click Save Preferences twice though I am sure that this will/already has been corrected in a driver/firmware update.
  9. Using the device page again, set the intensity to 1% with a time of zero. You should see no light emitted by the bulb. Increase to 2% and you might see a little light. Increase to 3% and you definitely should see the bulb light up. If not adjust your minimum value by 1% either more or less accordingly until this is what you see.

The procedure looks long but only takes a few minutes to do. You will have to repeat this if you change bulbs in the future. Good luck and let us know how it goes.

– Richard

2 Likes

Hi Richard,

Thanks for the steps and the time you took to write them up. I have followed them to the letter, and can confirm that the 6 LEDs connected to my Inovelli dimmer are all of the same brand. (I purchased them together).

That said, unfortunately, this doesn’t address the issue.

My minimum value in step 5 was 29%, so I set the light minimum to 26%. When I then set the light to 1%, nothing. 2%, 3%, 4%, nothing. At 5% the light finally turns on.

Afterwards, I can set it back down to 1% and there is light, but it is brighter than the minimum… Let me explain: after I set the light to 1%, I changed the minimum down lower - to 20% in this case - and saved. I then set the light at 1% again, it dimmed down substantially.

I know from previous testing that the minimal value that the lamp will support is 20%.

So starting again from scratch, (when the minimum is set to 1%) after the light has been turned on to, say 35%, dimming it down to 19% shows no light. Dimming it down to 20% results in the minimum dimness.

However, after it has been turned off, the minimum level at which the lamp will turn on is actually higher than that. It will only turn on at 30%.

Therefore, in order for me to be able to use the full dimming range, I need to set the minimum dimming to 20%. But as you will have guessed, if someone had previously turned it off at that level, when it is turned back on (with the previous setting), it doesn’t actually turn on. The user has to dim up the light (in this case by 10%) until it turns on, then dim it back down to the lower level.

This is not intuitive and frustrates my wife to no end… (which I desperately want to avoid!)

So I created a rule using Rule Machine in Hubitat that will trigger when the light is turned on, and then automatically save the level, bring the light up to the required « ignition » level and then back down to the desired last state. This works, but most of the time, it takes several seconds for the rule to trigger, so this causes a delay in the light turning on which is frustrating to the user…

Hence my request. What would be useful for those situations is that the firmware and driver could have two minimums. A minimum « ignition » level that will provide more power to the lamp once powered on and before returning to the last set level, and a minimum dimming level that would be the actual minimum at which the lamp can be dimmed.

Makes sense? Are you seeing anything that I am missing?

Thanks!

1 Like

I agree - I have the same issue with my Phillip Warm Glow LED bulbs. It needs to ‘ignite’ at a higher level then the minimum level it can go to once the bulb is turned on.

Great feature request!

1 Like

@SViel thanks for giving this a go to try to calibrate your lights. Let me tell you first that you’ve encountered one of the most common issues with LED bulbs and one of the things I would like to see addressed in a future device firmware.

LED bulb dimming when dimmed via AC phase control in the case of a remote dimmer such as Inovelli’s is often asymmetrical. As you have discovered a higher dimmer value is required to achieve ignition but then you can reduce the dimmer value to some tiny weak level without issue. Trying to go the other direction — dimming up from off/0% to that tiny weak value does not work. For the time being you have a few options to help your situation:

  1. Try another bulb or light source — I know not the best solution as you have to purchase and test a different set of bulbs
  2. Leave the minimum as calibrated but choose a sufficiently high “default” dimmer level so that anyone who turns on the light simply by pushing the switch (or a dashboard button) will send the light to a sufficiently high value that it ignites. You can set this in the device page and the dimmer does all the work internally without a Rule and without ZWave-induced delay
  3. Use a rule to add intelligence to the dimming — this does have some major drawbacks as the limitations of ZWave really are felt with these sorts of solutions

In my home usually I choose #1 for any circuit/light fixture where the low value dimming is of high importance. That’s where only halogen and incandescent lights will satisfy as such bulbs tend to “behave” predictably in either dimming direction. I generally use #2 as the solution most of the other times there have been complaints regarding dimming. I only will use #3 when I can get away with changing the default level while a light is off. ZWave (and just about anything else IoT wireless simply induces too much latency. To really do it well the hub+network would have to be able to act more quickly than the internal firmware which I have never found possible even with a wired network. You might be able to try to disable local control so that the dimmer only reports button pushes to the hub and the hub then sends all the actual dimmer commands. That might work but as you have found there are delays incurred… YMMV but I would be curious to know how it goes if you do this!

Believe me I know this very well. My wife is the best beta tester on Earth as she always will find and accurately explain why something does not work the way it should… again YMMV

What I want to see is @EricM_Inovelli/@Eric_Inovelli add different minimum dimmer values for the upward and downward dimming directions to the firmware (and it has to be in the firmware as implementing this at the driver level would not perform quickly enough). That would solve this issue quite well as it would be possible to setup the dimmer such that dimming up from off/0% would start at that higher “ignition” value but dimming down to darkness still would enable you to achieve weaker values (along with a nice smooth fade to black).

@BuilderTroy — I do like the Warm Glow LED bulbs quite a bit but switched all of them out of my home for this exact problem. Anywhere I really need that beautiful warm look at very low dimmer values I use tungsten or halogen bulbs. There’s simply no way around it. I evaluate bulbs regularly as lighting is my profession and to date aside from some very specialized light sources with. the dimming built into them there really is no comparison/competition in this area. I do have high hopes for some of the next wave of wireless smart bulbs and other bulb replacements. Quasar Science (a major supplier in my field) produced a line of screw base bulbs which were quite good when first introduced. They have a new lineup that should be shipping in the fall that will be even better especially with regards to dimming. I am looking forward to testing them for sure.

@SViel/@BuilderTroy — what are the bulb shapes and beam characteristics of the light sources you’re struggling with the most? Recessed light fixtures? Lamps? Sconces? There may be other bulb options I can recommend you try that will help.

1 Like

Thanks for the update @rpulivella, I will cross my fingers and hope for a firmware update at some point with a configurable « ignition » level. Until then, we will do our best to accept the latency… :slight_smile:

I have GU10 recessed bulbs. Other than the ignition issue, they are working very well for us.

1 Like

I see that this is an old thread. I just added a few more Red Dimmers, and the “ignition” challenge has once again come to the forefront. I replaced some Homeseer WD-200+ dimmers that were working perfectly, although I prefer the indicators and features of the Inovelli Red Dimmers. The bulbs that had been working perfectly for years are now not firing at low startup levels. I’ve tried to cover all of the scenarios/scenes of starting the bulbs with automation triggers, but you can’t cover them all. It would seem to be a fairly easy to add a starter level parameter to kickstart the LED bulbs.

I have noticed that one of my switches does seem to fire up when I turn it on at the switch (Physically). It doesn’t when I turn it on via Hubitat (Digitally). I was able to make a rule that detects if it is turned on digitally, and then ramp it up for a few seconds before going back to the previous, lower than that required to turn it on, level.

Any chance this might be related to what you are seeing - physical vs digital?

Thanks @SViel, that’s what I’m doing today. I just flashes bright, then drops back. Not very aesthetic, but workable. I’ve tried shortening the interval, but then you get some timing misfires.

1 Like