image not found img not found

Inovelli Community

Strange Notification Issue

I’m having an issue with notifications not changing the LED colour and it’s left me completely stumped.

The switches are a combination of both the new red series dimmer and red series switch. (3 dimmers, 5 switches)

Using SmartThings I setup Notification 1 as Red, 100%, Indefinitely, Solid. I did this on all devices.
When my alarm system arms, it triggers a virtual switch that I named Alarm LED Notification.
I then setup a piston in WebCore so that when the virtual switch turns on, it turns on all of the notification devices for the switches, and when it’s off it turns them all off. (For troubleshooting I also tried this in Smart Lighting and same end result)

-When my alarm arms, the virtual switch does turn on. I can verify this by seeing the on status in the ST app and also see the activity under the Recent history.
-The WebCore piston runs successfully. I can verify this through logging in WebCore and it is receiving the trigger event from the virtual switch and it is sending the on command to the notification devices.
-All of the notification devices are receiving the on command and are turning on. I can verify this by going into the switch device on ST and seeing the “Notification 1” device is turned on.
So every step of the setup is working exactly how it should… but the LED’s stay blue even though Notification 1 is turning on.

Now here’s the part that’s got me scratching my head. If I open the ST app and manually turn on the Alarm LED Notification virtual switch, all the LED’s turn red. So I know for sure the LED’s do work and do change colour.

I’m completely stumped, I don’t know where to go from here.

Doesn’t make any sense to me either. I’m doing a similar thing to let me know when a garage door is up. The only things that are different for me, which shouldn’t make any difference, are that I’m using orange blink and setting the notification with Smart Lighting, which you tried.

This is just a shot in the dark, but maybe republish the two DH’s in case something got corrupted.

@Terk to prevent hijacking the other thread… Here are the exact details of how I’ve got it setup.

That is strange, I’m doing the same thing only on Hubitat with mine when we are away it arms the system and should turn on the notification LED and turn off all the lights, I say should as I’ve never faked away to verify the LED but I do know it shuts off all of the lights and arms. I have a goodnight scene that arms the system to home night mode and turns on the notification LED and turns off all the lights in the house and this I know works. I also have the system go into home night mode at 11pm even if I haven’t started the goodnight routine that arms the system and turns on the notification LED but doesn’t bother to turn off any lights as it likely means one of us is still up and this too works.

Have you tried changing the order to shutoff all the lights before modifying the LEDs? The only other thing I can think of is my LEDs are controlled by one rule that triggers on arm/disarm change or other things but aren’t in the actual rule that sets away or night mode, I’m also turning off then on the notification LED when I want it on since it won’t drop back to the previous notification when a more important notification ends. I also have thing in order of importance with the most important at the end of the rule so water leak notification overrides a door opening or mail in the mailbox.

Just an update on this.
About a week ago I moved my goodnight routine from a Smartthings routine to a Virtual Switch and a WebCore piston so I could control the order of events. I put the lights off command before the alarm system arms.

Now the LED’s change about 90% of the time. I do still occasionally get a switch who’s LED child device will be on but the LED itself will still be blue. I get a couple in the morning as well when the LED child device switches off they stay red. But it’s significantly better than it was.

I also see the known issue with the dimmers with the notification on and manually controlling the switch. Not a big deal since I really only use the notifications for the alarm system and we’re either not home or in bed when it’s on.

I wonder if this is smartthings related and I’d have better success if I switched the switches over to my HE hub

After the last Smartthings outage I finally went through the work of switching almost everything onto my hubitat hub.

The notifications work significantly better on HE than they did on ST.
Notifications on my red series switches are now 100% reliable.
Notifications on my red series dimmers are coming on 100% of the time, and then turning back off.

My goodnight routine can be triggered one of 3 ways. Via Alexa, the config button on my master bedroom dimmer, or when both sleep sensors are triggered in bed.

What is happening is if I trigger the goodnight routine via alexa or the config button, when the sleep sensors are triggered it fires the goodnight routine again.This sends an off command to a dimmer that’s already off, and doing so it turns off the notification LED. I can replicate this over and over again in HE by turning the child device on then pressing off on the parent device. The LED changes back to blue but the child device remains on. I believe this is the same issue that’s already been discussed in another thread although I believe that thread only talks about when the switch changes states.

I’m going to re-write my goodnight rules to prevent it from firing twice and I should finally be OK.

This happens to me also if I have Remote Control disabled on my switch. Not sure if this is your scenario.

EDIT: I just caught up on the thread. Sounds like not your scenario. Cheers!