Tips for Blue 2in1 zigbee inclusion range

Do you have another you can swap in? That’s surprising to say the least. Have you shared your setup channels and whether you have an extension or not?

@kreene1987 Home assistant, ZHA, Sonoff 3.0 -P (latest firmware), plastic switch boxes. Channel 11, Wifi on 7 I think. Other devices in mesh function well & included easily without extension cable, but got one out and moved antenna within 5 ft for setup. Also left the switch hanging out of the single gang box. Tried to include through other nodes within 5 feet, no dice there either.

I started with 4 switches. 2 pre-order, 2 Sept order, arrived with 1.5 week of each other. One I installed in basement had trouble initially including, but it was furthest away from any existing node, so gave it a pass. Eventually included after multiple power cycles, inclusion reset procedure, random button pressing. That is node at bottom of my screenshot, seems ok.

2nd switch in the top right node location couldn’t get to work, so I installed the 3rd one (currently installed). Still had ton of trouble getting it to include (but finally did, same ton of resets, button, air gap mashing) and now current state of it’s connection to other nodes shown. Didn’t try the 4th switch of the bunch yet.

All seems to be in place. I’ve got nothing that can assist other than some of the good conversations happening above. Sorry for your experience, it differs VASTLY from my beta units.

1 Like

Will see how some others’ experiences are as these flood out to other pre-order holders. Fingers crossed for Inovelli. Want this to succeed!

Just wanted to pop in and say that we’re currently looking into this with the engineers. I know it isn’t helpful to the current situation, but as @kreene1987, this has caught us off-guard as none of this was brought up in beta (including my own switches) and so we’re trying to figure out if this is a production issue or if this is just growing pains of understanding Zigbee.

Hang in there, I promise we will get to the bottom of it.


This just got a good laugh out of me since it’s absolutely something that I would have done for “testing” purposes. I can already hear my wife asking why I’m trying to add a switch all the way out in the middle of the yard?

To add another data point, I’ve been having a good bit of trouble with getting my switches to join the network (and stay connected). I ordered a pack of 10, have 5 installed so far.

  1. paired immediately, but it’s all of 8 feet from my server through a tile floor.
  2. is ~25 feet away, through a wall and a floor and has never joined.
  3. is ~20 feet away through a wall (directly beneath 2 by one floor) and joined on the first try but hasn’t reliably maintained connection, nor has it been able to provide a path for 2 to join the network when it is connected.
  4. and 5. share a box ~15-20 feet from the server, but there’s a refrigerator and furnace between them. They only connected when I moved the zigbee receiver to get a clearer line of sight and they didn’t stay connected for long even so.
  • Zigbee dongle is a Sonoff Zigbee 3.0 Dongle-P freshly flashed to the latest development branch of Z-Stack 3.x.0. Currently on a 5 ft USB 2 extension cable but I’ve got a longer one coming tomorrow.
  • Zigbee is on channel 11 (zigbee2mqtt default), Wifi is on channel 11 (but only 2 devices are on the 2.4GHz network anyway).
  • Server is running Home Assistant using Zigbee2MQTT version 1.28.0-dev commit: [ddc4345] (the latest-dev docker image).
  • All switches have a neutral wire and are in plastic switch boxes, the only switch with a metal switch plate is the one that has stayed reliably connected.


These switches were intended to be the start/core of my zigbee mesh, so the only other devices I have on the network are a couple sengled lightbulbs. The Office Lamp bulb is in a metal lamp clear on the other side of the house from my server and the Bathroom Light switch was getting comparable signal to it (LQI in the 10s to 20s) until I mounted the zigbee dongle to the ceiling directly under the bathroom.

I think I’ve seen one of the other switches up to an LQI of 30 when I was moving the dongle around, but obviously they’re not registering as connected currently.

I’d welcome any suggestions, but at this point my plan is to use a longer USB extension cable to stick the dongle in the ceiling of the garage and try installing some of my remaining switches in locations that should be helpful for creating a mesh.

Maybe swap high/low Zigbee/wifi? The difference between zigbee channel 11 and wifi channel 11 is 57MHz. If you run zigbee channel 25 and wifi channel 1, the difference is 63MHz. Plus, zigbee ch 25 sits on the sideband of a wifi channel (11), while zigbee ch 11 sits inside the 20MHz peak for wifi ch 1. You might have neighbors on ch 1 (many access points and routers default to this). With as few zigbee devices as you have now, re-pairing after a channel change shouldn’t be too much work…

I’ve been able to pair three switches that are near my Sonoff ZBdongle-P, but one that’s further away isn’t showing up when I try to add it in Home Assistant ZHA :frowning: I’ve tried using “Add devices via this device” on a device that’s only about 10 feet away, but it’s still not seeing the switch.

I have the USB stick on an extension cable, I turned off 2.4GHz wifi on my two access points, and I’m using Zigbee channel 20.

In my efforts to find any network that I do not control deliberately, I remembered that Amazon Echo Devices secretly create a network they call Sidewalk. You can disable this feature with no issues for most users by viewing account settings in the Alexa App. This did not improve the performance in my network, but it is an interesting place to check.

1 Like

Swapped channels, signal got a little stronger for the nodes that showed connected in my first post but didn’t allow anything else to hop back on.

Moving the coordinator location around on the end of a 15 ft USB cable let me get everything I had installed yesterday joined, but I haven’t found a spot that lets everything stay connected at the same time. The two switches I installed today are farther from the coordinator (though not far from existing switches) and nothing I do seems to get them to pick up.

The only spot where the zigbee2mqtt map shows nodes connecting to each other is two switches that are in the same gang box, and it’s only showing a signal strength of 49/29 on that connection.

The more I’m reading here the more I’m thinking there are some bad devices in the wild. I only have two devices to work with, but they both seem to be incredibly RF weak. I have a large strong zigbee mesh, with my furthest devices about 150’ outside the house in the backyard. Meanwhile my Hubitat hub has the external antenna mod (highly recommended!) and my RSSI is low to mid 90’s sitting ten feet away from the hub. Just getting the switch to join takes a few tries, and once it does, commands don’t always execute, and confirmation on the hub side rarely updates.
All that said, how can this be a discussion about which channel to use, or interference from other devices, when I have 48+ Zigbee devices (most of them battery-powered) that honestly work flawlessly? I’m half expecting to open this switch up and find an unsoldered antenna, I wish it was that simple!

I’ve managed to get 8 switches paired, but the one I mentioned earlier is the furthest away from the coordinator, and I wasn’t able to pair it after numerous tries. So I unplugged the computer running HA and moved it closer to the problem switch, and it paired with no problems. But after moving the HA computer back to its usual place, the switch has fallen off the network. I was able to remotely turn it on and off a few times, but it’s mostly unresponsive to remote commands. Why isn’t it finding the nearby routers? There are two other Blue switches within about 15 feet.

Well… I have good news and bad news. I just spent about an hour carefully taking one apart, reseating the zigbee antenna, and reassembling. Inclusion now happened on the first try, and RSSI went from mid 90’s to mid 80’s. Mid 80’s still isn’t great but its a measurable improvement, and more important the switch actually seems to be functioning as it was intended to. With this RSSI I’m not sure if I’ll be able to mount it in a box more than a room away from the hub, but I’ll try to work on that tomorrow…

1 Like

Was the connector noticeably loose, or did it appear well-attached? How much disassembly was needed to get at the cable and connector? 20 switches showing up tomorrow… would like to avoid doing this if it’ll really take an hour each. Otoh, if that’s what it takes to make them work, I’ll do it.

It wasn’t really loose, but I reseated it anyway. I also rerouted the wire. The improvement I’m getting is noticeable, however, I do not think this is the root issue. Someone smarter than me will have to look at this. The RSSI I’m getting now is mid 80’s and that’s really not great, its just good enough to work. I’m 10 feet from the hub. I’m hoping radio power can be adjusted with firmware, otherwise my limited understanding is leaning towards bad radios. I almost don’t even want to post this because I could be totally wrong… but reseating the antenna connector and moving the wire was enough to make the difference of the switch barely being able to communicate at all, to it working 10 feet from the hub.

Add me to the list of frustrated. Received my pack of 20 yesterday and had electrician install them today. I can only get 1 to connect, in the same room as the server. HASS, 20’ USB extension, Sonoff stick 3 .0 -P.

20 ft extension? Is this an active extension or using a hub? I think you’re past USB2 and 3 spec with that distance fyi.

Also for clarity Z2MQTT or ZHA?

Correct, 15’ USB not 20’. It’s a passive cable, using ZHA.

1 Like

Ok perfect, if you didn’t catch it already, this thread has a form to fill out with some added details if you’re willing. I know they’re trying to correlate information and work with the engineers to figure out what’s happening for people.

1 Like