Trouble setting config parameters 14 and 15 via HA and Node Red

Has anyone here been able to set_config_parameter #14 (LED Strip Intensity) or #15 (LED Strip Intensity (When Off)) in the Call Service Node in Node-Red? I am able to set #13 (LED Color) without a problem, but when I change the config to do #14 or 15, nothing happens. I watched the Z-wave log and no new commands are sent when I issue a #14 or 15 config but they are when I set #13.

The call service node:

Here are my values passed into the call service node:

And the result when I run it (but nothing in the zwave logs):
Screen Shot 2020-10-09 at 7.36.45 AM

I am running home assistant 116 and the original/native Z-Wave module with the config files provided by inovelli.

Is anyone else able to automate LED Intensity?

Thank you!

I just started playing with Node Red, so I may not know what I am talking about, but is there a reason you are passing the data as an expression instead of as JSON?

That is a good question. The short answer is it was a copy and paste from a routine I used to set the parameter 13 which I turned into a subflow and was injecting an environmental variable. Good catch!

Unfortunately, I just tested it out as json and it didn’t change the results. Here is the data output from turning on debug on the call service node if that helps:

“data”: {

Still no update in the zwave logs or on the switch on the intensity value.

Thanks for the help!

Are you able to set the value manually in HA using Developer Tools -> Call Service? That could help narrow down where the issue is coming from.

Great troubleshooting step! Looks like the issue is not within node-red but in the zwave.set_config_parameter instead. I ran the following code and no change on the switch and nothing came up in the zwave log. When I changed it to parameter 13 (change LED color), it changed the color of the led and showed up in the log. The only change in the yaml between the two calls was the parameter value between 13 and 14.

I checked my manufacture_specific.xml and the inovelli/lzw31-sn.xml files and they both look good but I am not sure if they are referenced in the zwave call or only in the HA zwave configuration page.

Found it!!!

Referenced this article by someone who had the same issue. Turns out, because the inovelli/lzw31-sn.xml file changes the call value for you to a string percentage representing the value, that is what is needed to be called when calling this parameter. So, this worked in the call config instead of what is posted above:

That makes sense, now that I think about it more closely. Parameter 14 is a list, and according to the example, lists need to be passed as a string: