Ughh.... I have 40 of these Red Dimmer switches and I need help not hating them

Is there a magical set of settings that make these switches feel responsive. I love all the features but I feel like I’ve made a $1500 mistake.

When I’m using the local switch it takes nearly two seconds from the time I press the button until… uh… light.

So, I thought “Perhaps it’s an LED problem.” So, I set the minimum to 30 thinking the ramp would skip 1-29, but a) it doesn’t actually seem to stop 1-29 and I’m beginning to think that it ramps 1-29.

Am I the only person having issues here?

1 Like

There is a setting for this if i recall correctly. It does affect dimming however as that is likely the delay. Ill let those more familiar answer, but i recall reading about this in the past.

Can you tell us more about your configuration?

  • What switch(es) are you using?
  • How are the switch(es) configured?
    – Load Only
    – 3+ Way
    – Smart Bulbs
  • What bulb(s) are you using?
  • Do the switches directly control the bulbs?

Can you enable debug logging on the switch, and provide a screenshot of the logs during the issue?

Are you using the Hubitat native driver, or the Inovelli supplied one? The one from Inovelli has many more settings to customize, ramp-rates, dimming rate, physical switch delay, etc.

  1. If you dont need to dim the lights, set parameter 1 to 0.

  2. If you dont want to do scenes and you have firmware 1.47 or higher, setting parameter 51 to 0 will turn off the .7 sec delay between when you press the toggle and when the light responds

Doing these 2 things should have the switch/light respond as quickly as a normal dumb switch.

And(!), what firmware is on the switches?
By default, there’s a 700ms delay while the switches wait to see if you are going to do anything else - so they can activate double tap, triple tap… scenes. Recent firmware version have added an option to disable this delay (with the caveat that this disables most of the scene controls). And you’ll want the latest device handler to expose the option in the Hubitat UI.
I have “Dimming Speed” set to 1, “Minimum Level” 25, and Disable Physical On/Off Delay set to Yes, everything else default (except the LED colors set for Christmas!) and I see less than 1/2 second from tapping the button to the light starting to change.
Currently, I’m on SmartThings, but I’ve also tried Hubitat C5 with similar settings/results.
Just for completeness, I have mostly neutral connected, 3-way circuits with aux switches driving 3-4 60W equiv. LED bulbs in recessed ceiling cans.

I’m using Red Switches which were part of the big order after the big delay (Sept or October).

I know that the firmware is at least 1.45+ because I can do white LED strips.

What’s the best way to check the firmware? Can I update it? If so, how?

I’m starting easy with all switches connected to the loads. The other switches are 3way Reds wired to be “virtual”. This shouldn’t affect it.

No smart bulbs. These are Philips Soft White dimmable LEDs PAR30.

Interesting… what if I don’t want scenes controlled from the light switches, but I do want dimmers?

How do I check/upgrade the firmware?

This is promising though. :slight_smile:

Duh… I completely missed the firmware on the details.

I have 1.47

Thank you. This is helping!

I’m still experiencing a pretty big delay if I press and hold the switch to initiate a dim up or down? Thoughts?

This helped so much!

Thank you

I am not sure I understand your problem.

Have you tried setting parameter1 to 1 ? While 0 will disable dimming entirely, 1 is still faster than the default of 3.

I know what he means, you press and hold to dim and no matter what settings you have there’s a lag to the switch response.

I too am pretty frustrated with what should be the main job, dimming and lighting control. It sure has everything else, but other products that were released years earlier sure do their intended purpose better.

Just reconfigured one of my switches to quicken the response times as suggested in this thread, and there is some delay before it starts dimming (~1s), but there’s going to have to be some delay for the switch to differentiate between tap vs hold.

Are you seeing more than 1s delay before it starts dimming? Are you expecting it to be faster than that?

1 Like

Also verify the minimum dim value from the off position forn your bulbs. One of my fixtures won’t turn on until it gets 25%. So I set parameter 5 to 25. Parameter 5 adjusts the scaling of dimmer such that 1% dim = 25% power. This should speed up things since it won’t be dimming up for values that don’t turn in the light. Hope that mens sense.

Note: make sure you check the min level from the off state. Once on I could dim less than 25%


Hi Stephen,
As I understand your slow dimming issue, you have the light on (for example) and you hold the bottom of the rocker to dim the lights - and you need to hold the button for a while before anything happens - correct?
Since this can start with the light on, it shouldn’t be anything to do with the min/max configuration.
I agree! It takes mine around 2 seconds before the lights start to change.
(I do almost all my light level controls through voice/Alexa - so it doesn’t actually bother me too much)

Stephen, I can somewhat feel your pain but to a lesser price tag as I installed 10. At first I hated them but much could be attributed to issues with three and four way switches. Once I swapped those out to Lutron and kept only single pole Inovelli and played around with it, I actually am starting to really like them. Not sure what the responsiveness is that you are referring to as it’s hard to describe. What I believe is that with either the light off or on, you press the up switch expecting it to get brighter it just seems really long. The default on preferences in hubitat for “Dimming speed(from switch)” is 101. I honestly don’t think that it’s too slow because I use these switches more with motion and time of day in rule machine in HE. I certainly didn’t do that right of way and you may do that at some point. I’m sure your first thing you want is for it to just work like a light am I right? Try setting this parameter to 51 to see the difference and then go to 1 to see the opposite end of the spectrum. Hopefully that helps find the right speed. One other note, I do believe that the bulbs matter. After updating some older style bulbs, I had better luck with some better LED bulbs. Good luck in figuring it out. Hopefully I understood your issue and feel your pain.

As mentioned in a different post, there would be a GREAT solution to implement in the next firmware. The possibility to change the 600ms (or 700ms) delay on these switches. We are double clicking faster than that so if it could be change to some lower values like 100ms then it would be faster. This is really an update that I’d love to see (and my wife too :wink: )

1 Like

Pretty sure that’s already slated for the next update, they just have to wait for the manufacturer to finish making the firmware update.