Unable to associate Inovelli drivers to LZW31-SN Smartthings

So just to start things off, I have 17 Inovelli switches in the house (3 - LZW30s, 14 - LZW31s) and within the last two days I’ve had to convert everything from groovy to edge because they all stopped responding to the down clicks.

This single switch won’t connect properly, and actually never has (I’ve had it less than 6 months).

I have tried multiple exclusions, factory resets, and brute force methods. When the switch connects through the “Add Devices” it does so just like every other switch - the device flashed blue > once connected flashes green > tells me I should create a secure connection so I scan the barcode > tells me everything was successful.

However, on this specific device the device label that it creates is “Inovelli Dimmer Switch” instead of the standard “Inovelli Dimmer Red Series” that all the others start off with.
Device Profile is also different. It says “inovelli-dimmer” instead of “inovelli-dimmer-power-energy” like the rest.

The driver it wants to use is “Z-Wave Switch” instead of “Inovelli Dimmer Red Series” when I try to manually change it in IDE I get the following error - “Error changing device driver to “Inovelli Dimmer Red Series”. Ensure that the driver you are trying to change to has a valid fingerprint match with this device.”

I’m unsure what to do. Much of the functionality is missing and I’ve trying resetting this device probably x30 times since getting it. This particular device was purchased on eBay.

You should not be trying to change the driver in the IDE. I’m surprised you can even get to the IDE, as it has been completely deprecated with the URL now pointing to the SmartThings Advanced Web App (at least as of a week ago or so). The conventional wisdom for the past year or so has been to stay out of the IDE since it has been largely non-functional as its deprecation was progressing.

The proper way to change the driver is to open the device’s page in the SmartThings app. Select the 3 dot menu top right, then select Driver. Then select Select different driver. That will show you the other compatible drivers installed on your hub. It sounds as if you have the Inovelli Edge Drivers loaded, so if the current driver is Z-wave switch, the Inovelli Dimmer Red Series driver should be displayed for you to select.

Sorry, I thought it was semantics. I don’t keep up with what is happening, unless something breaks. I am in the SmartThings Advanced Web App.

There are no additional drivers available in the app, which is why I went to the SmartThings Advanced Web App.

To reiterate, the 13 other LZW31-SN switches I have all worked right away without having to play with any settings in the App or Web App. This one does not want to play nice (never has)


So just to confirm even though the others are working correctly, in the SmartThings App, open the device page for your hub, select the 3-dot menu, then Driver. This will list all the drivers loaded on the hub. Is Inovelli Switch Red Series / Inovelli Edge Drivers listed there?

If it is, for some reason the switch is not presenting the proper fingerprint to identify itself. I know you said you reset about 30x, but was this a factory reset and did you also exclude the device from the hub?

To do that, in the App, open the device card for the hub and select the 3-dot menu. Select Settings, then Z-wave utilities. Press Z-wave exclusion. While that is active, press config 3X on the switch and you should see message that the switch was deleted/exlcuded. (I think it’s 3x . . it’s whatever you push to include it.)

Once the switch has been excluded, long press on the config button on the switch for about 40 seconds until you get the red LED, then release. This will FACTORY reset the switch.

Then try to re-add the switch. Click on the + to Add device and add using Scan for nearby devices.

If this doesn’t get it, then the switch may be faulty, especially since it has never connected properly.

Let us know how you make out.

1 Like

Correct. It is listed in the Drivers - both Red Series Switch types (Switch and Dimmer).

Yes, this was the process I followed for every one of my switches. Exclude (green flash when complete) > Factory Reset (until red light comes on) > Pop the tab on the bottom that breaks the circuit > Add Device

No luck no matter what I do.

Hate to say it, but I wonder if that is why it was on eBay.

I would have bought it from inovelli but they’ve been sold out for a long time :stuck_out_tongue_winking_eye:

1 Like

I wonder if it would be worth reflashing the firmware (after confirming the model number 100%). If you have a way to do it, it doesn’t sound like you have much to lose by trying.

Is there a write up on how to do that somewhere?

1 Like

I just saw your ticket which directed me here, so I’ll reply here as it looks like you’ve been in good hands!

Question for you – can you post a screenshot (or just share the letters/numbers) from the advanced web app of the Manufacturer Code and Model?

This will help me understand why it’s trying to grab the Inovelli Dimmer Switch rather than the other driver (I have a hunch, but let’s see what the data tells me :stuck_out_tongue_closed_eyes:)

Here you go :slightly_smiling_face:

Out of curiousity, what color was the box the switch came in, red or black?

Black according to the ebay listing in my email.

Ok, so I think @Eric_Inovelli will confirm that is a Black LZW31 dimmer not a Red LZW31-SN.

But that still doesn’t explain why it’s not picking up the proper driver. It should be picking up “Inovelli Dimmer Switch Black Series”.

Well, I think we solved the mystery of why it’s not picking up the same driver as your other ones :slight_smile:

The one you purchased is a Black Series Dimmer switch, which was a more basic version of the Red Series (ie: not all the bells and whistles).

The Model 0003 is what the Black Series Dimmer switch uses whereas the Red Series Dimmer Switch should be 0001 (hopefully your other switches show that).

So, the Edge Drivers are programmed to only work with the corresponding Model #'s, hence why you got that error (invalid fingerprint).

Can you make sure this driver is installed and see if it helps your connectivity issues?

The drivers are located here: Inovelli Edge Drivers - SmartThings

Edit: Looks like @Bry beat me to it lol

My guess is that the Black Series one isn’t installed. Mainly because in the first post, it mentions that it’s trying to pick up, “Z-Wave Switch” which is the generic SmartThings Driver.

1 Like

@Marine6186 – I forgot to mention above that you may have to remove (unpair) the current switch from SmartThings in order for it to work with the new driver. Sometimes SmartThings plays nice and will let you switch the driver over after the device is installed, but other times it will tell you that there are, “No Compatible Drivers” or something like that when you try to switch.

Thank you! I feel like a dummy haha! I’m glad it is something simple like this. I will try to get things working later tonight :sweat_smile:

Lol it’s all good, it’s why we’re here to help! Fingers crossed it works out for you :slight_smile:

So, I’ve made progress but it still feels like it is missing something.

When I try to create a routine, I only have 6 options and none of them are button presses, like the Red Series. I’m not trying to do anything fancy. I’m just trying to create a simple on/off with up/down presses, with local control disabled. But when I go into routines I don’t have button options.

Is this due to the limitations of a Black Series switch or is something still messed up? I can’t find any documentation on the site.