Unable to load /config/ozwave/config/manufacturer_specific.xml

Can someone point me in the right direction?

Unable to load /config/ozwave/config/manufacturer_specific.xml

I’ve followed the instructions in this guide https://www.reddit.com/r/homeassistant/comments/fu92cg/idiots_guide_to_getting_inovelli_switches_up_and/ as best I can. I used the “file editor” add-on to edit the file as described above. So I know the file exists, it looks like it is in the correct location and I didn’t transfer the files from my Mac, so there shouldn’t be any problem with the way the text is encoded or anything.

But it’s clearly not reading any of the device information, after including my new Inovelli switch it shows up as “unknown” and no configuration parameters are available.


Sounds like you have a formatting error inside the file that’s preventing it to load. Was it loading properly before you made edits to it?

Well, I don’t think I tried it before the edits. If I go back and put the unedited file in its place, do i need to reinclude the devices? factory reset? How do I get it to try to reload the file?

I would:

  1. Put the manufacturer_config.xml back to what it was before you made any changes (grab the original from the openzwave git repository)
  2. Restart Home Assistant
  3. Make sure you don’t see that error anymore

That will prove that you at least have the openzwave base configuration working correctly. Then you can edit the manufacturer_specific.xml file again and carefully replace the Inovelli sections with the ones from here: https://github.com/InovelliUSA/OpenZWave/blob/master/config/manufacturer_specific.xml#L967. Make sure you replace both Inovelli sections, there are two of them in a row.

Then remove the switch (a simple z-wave remove is fine), reboot Home Assistant for good measure (dunno if this is actually required but do it anyway), check for no errors, then add the switch again.

That seems to have helped quite a bit. :slight_smile:

I’ve re-added the switch and it’s showing the correct Inovelli name. It’s also added the light and two sensors to HA.

Still nothing showing up under “Node Configuration Options” for configuration parameters. Isn’t this where I Would see options for changing things like minimum brightness and ramp rate?

Did you also copy the config files into the Inovelli folder?

Sometimes I’ve found I have to wait a bit and then it shows up. Or reboot Home Assistant. Or both?