Unable to upgrade firmware on VZW31-SN on Hubitat C-8


I have a VZW31-SN and a Hubitat C-8 hub on latest firmware ( Using the Inovelli supplied 2-1 Red driver from github.

Switch came with 1.0 production firmware installed but I’d like a couple features in the 1.02 firmware.

Using the built-in Hubitat firmware updater, every time I try to update the switch, the transfer counts up to 100% over a couple minutes and then I get the “Device Firmware Updater: ERROR: The transferred image does not match the Firmware Target”.

I have tried with the 1.0, 1.01 and 1.02 firmware versions, all downloaded (as RAW) from guthub. MD5 for the 1.0 matches the MD5 listed on files.inovelli.com. The 1.01 and 1.02 files are not present there to compare MD5’s.

Every version gives the same error once the transfer completes.

Is it paired S2 or no security?

Are your devices paired with security? If so, use this workaround (an alternative community driver rather than the built-in app or “original” driver):

(EDIT: Hey, that poster looks familiar :smiley: )

Even if the Red isn’t paired S2, try the steps above that Robert linked to.

I originally wrote those steps to get around the fact that the Hubitat built-in updater doesn’t work for S2 devices, but it works just as well for no-security devices too. I now just use those steps for all my ZW updates.


Yes, I have it included with S2 Security.

Thank you both very much, the linked process got it upgraded!

I searched high and low for an answer, but here and on Hubitat’s community. But I think I was focussed more on it being an issue on the switch side that I never found the link above.

1 Like