Unresponsive LZW31-SN

Hi there,

I have an unresponsive lzw31-sn red series dimmer that is not listening to smartthings settings changes like LED color, but is listening to smartthings on/off commands. I believe it may be stuck in “disable remote control”. Is there a way to turn this off using the switch? I know that “disable local control” is 8x configuration button presses.

EDIT: I just factory reset it. I believe I wasn’t able to use the smartthings app to set settings or turn off “disable local control” after I turned it on. I thought this was to only disable the on/off/dimmer not the configuration settings. Is this intended?

Ok it has happened again. I’m unable to set the LED strip color if “Disable Remote Control” is enabled. I can’t control it via smartthings app or webcore. This also extends to child LED devices. I have to enable remote control in order for any LED commands to work. I really think the LED color should be separate from the on/off/dimmer or at least have the child devices not care about “Disable Remote Control”. Am I missing something?

I’m also unable to disable “Disable Remote Control” remotely, if that makes sense… it seems like the switch is ignoring the zwave command because of the setting. How do I physically disable “Disable Remote Control” via the switch? Something really seems amiss with the remote control setting…

To clarify, I have a couple of issues 1) Sometimes the switch gets locked up and I am unable to turn off “Disable Remote Control” and I am assuming this is because the switch sees a remote command to disable it, but since remote commands are disabled it ignores it. To fix this I am just asking how I can turn this setting off locally using the configuration button. 2) When “Disable Remote Control” is enabled, is it possible to sill control the LED color and intensity remotely?

This is expected behavior. Disable LOCAL control disables control at the switch itself (instead relying on scenes sent through z-wave, while disable REMOTE control disables the z-wave radio from communication (exception is to set disable remote control back to off).

Disable remote control SHOULD allow changes to it via the ST app, I’ve done it before when I disabled remote control.

While Disable Remote Control will keep you from doing a number of things via the ST app or other things with hooks to it, you should be able to turn it off via the app. I’m not sure why you can’t though.

You can also turn it off in the ST IDE. Open the page for the device and go to the Preferences section. Click on Edit. Find the box that says Disable Remote Control - Disable ability to control switch from inside SmartThings. The value for that field is to the right of it. Yours probably says “1”, which is disabled. Change it to “0” and save. This will restore Remote Control.

Once you get it going, double check to make sure you have the proper DH installed. You want Inovelli Dimmer Red Series LZW31-SN

  • Author: Eric Maycock (erocm123)
  • Date: 2020-09-21

There is a later DH was is also OK. If you don’t have 9/21 or later, update it.

AFAIK, no, at least within the app. Not sure about hooked apps like webCore.

This agrees with my understanding and user experience. This is basically saying ONLY changing that one setting (enable remote control) is allowed.

@Bry Thanks, I was unaware of being able to edit preferences in the Samsung IDE, this should fix the issue I was having when I was unable to change the Remote Control setting after I had previously changed the Remote Control setting and the switch got confused and locked up.

As far as the LED it seems like if Remote Control is disabled, you are unable to change its color remotely or any child LED device remotely. This has been tested by me via Smartthings app as well as webcore. I really feel like the LED should still be able to be controlled remotely (or at least the child LED devices), but maybe that’s just me. The use case is using the LZW31-SN as a scene controller and I do not want to change the load output at all but still want to utilize the switch LED for notifications. For right now I just have Local Control disabled and have the switch hidden in a “DO NOT TOUCH” room in ST.

Here is what I think you’re looking for. This will allow you to keep Disable Remote Control On but still change the LED color . . or whatever . . with webCore.

The first step is to create a child object for Disable Remote Control. It’s at the bottom in the dimmer’s settings in the app. Then go into the list of things exposed to webCore and select it.

Then this. It will temporarily turn of Disable Remote Control, change the color, then turn it back on. Hopefully I’ve understood what you’re looking for.


@Bry That is what I am after for my second question, but it doesn’t seem to work. If I make the child device and then select it in ST… With the switch on: disableRemote (IDE) = 0
With the switch off: disableRemote (IDE) = 0

I’m now also unable to change disableRemote via the switch settings (Previous setting fades out and then back in) OR via samsung IDE. It is currently stuck at 1. Is there a way to do it physically at the switch similar to 8x for disableLocal? This is what was happening with the original question.

Lots of issues, ugh. This is a refurbished LZW31-SN and it has the latest device handler.

I couldn’t find anything to indicate how to turn Disable Remote Control on or off via the switch.

Seems you have weird juju going on. Since you have the latest DH, I think the best thing to do is factory reset the switch. See if the issues persist after that.

I agree, but this will be the second factory reset. It seems like it is all related to Disable Remote Control, almost like the switch is not listening to any remote commands, even those changing that specific setting. I think I will just go back to how I had it, with Remote Control enabled and just hidden in ST unless this can be addressed.

I don’t think there is anything to be addressed. From my testing, everything seems to be working fine. If you reset it again and the problems persist, I’d ask Inovelli for a replacement.

Well now it isn’t even responding to holding the configuration button, I’ll try resetting at the breaker.

Ya, it’s completely unresponsive now at the switch. Holding configuration button for a whole minute did nothing. Scenes are still working, though. Airgap does not resolve either.

Hey sorry if this was mentioned, I’m just skimming the convo while eating sushi lol.

Did you try tapping the config button 8x? If so, what color did the LED bar turn (should turn either red or green)?

If it turns green you should be good to go.

Tapping it 8x turned the LED green and I am now able to factory reset it… Holding it turns it green and then red… Do you know what happened? Local control disabled I’m guessing. Still doesn’t explain why I couldn’t control it via IDE.

Yeah basically what happened was somehow (either via the UI or locally) the switch had it’s local (at the switch) and/or remote control disabled.

To disable local control, you press the config button 8x (it should turn red) – and then to re-enable it, you press it 8x again (should turn green).

I’m sorry for hodgepodge of issues, they keep coming up and resolving… Anyway, to summarize these are the issues…

  1. the switch freezes up when certain disable local/remote settings are changed. I’m not able to change them in IDE or in ST switch settings and I wasn’t able to even factory reset it. Tapping configuration button 8x allowed me to interact with the configuration button to factory reset but I still wasn’t able to change settings in ST switch settings, so I did a factory reset. This is the more serious issue and I don’t know what caused it but it has happened twice with this switch.

1.1) is there a button combo to toggle disableRemote like the 8x?

  1. assuming 1 works itself out or something, is there any way to control the LED color if disableRemote is enabled? If the parent device has to reject all commands is there any way that a child could work instead?

Ok, once you get it paired back to ST, can you check this page out and make sure the raw code isn’t just all 0000’s:

Here’s where you can find it: https://support.inovelli.com/portal/en/kb/articles/how-to-find-your-device-info-for-troubleshooting-smartthings#Finding_Your_Device_Information

No, unfortunately not.

No, because when you disable remote control, it disables any remote commands sent to the hub and back.

I stand corrected! Thanks @Bry :slight_smile: