VZM31-SN Blue Series Remotely Disable Local Control

Forgive me if I am missing something obvious… but I have looked around and cannot find this anywhere. I am trying to implement a simple “nap time” toggle using a multi tap gesture. When nap time is enabled, I want to prevent accidentally turning on the overhead light fixtures that the dimmer controls locally.

I believe that this is possible using the red series dimmers but I cannot determine how to do this with a blue series dimmer. What I would want to do is remotely disable local control so that when nap time is toggled on, tapping the dimmer paddle only would send commands to the hub and not effect the load at all. Could anyone give me some clues as to how to achieve this? Or perhaps this is a feature that the blue series simply cannot achieve?


I think you just want an automation to turn on “Local Protection”, that’s the equivalent to disable local control.

You want to do this on a Blue series, right? (The blue is a VZM31-SN.)

On the Blue, local protection is Parameter 256, if you can get at it programmatically. A value of “1” turns on the protection, disabling key presses.

Indeed I am using a blue series VZM31-SN. Is it possible to set that parameter programmatically using Habitat? I thought that it had to be exposed as a pre-fabricated custom action? If this is possible then for sure it would work. I have two other instances of a similar flow where I am using a red series dimmer. The red series driver exposes a local protection toggle as a child device:

I am looking to duplicate this functionality. I am more than happy to do it by setting a parameter value if there’s a way to do this.

Title corrected BTW… thanks for catching my misspelling.

1 Like

Hubitat . . .
@mamber ?

Yes, you can programatically set any parameter using the setParameter custom command

After you click on “Add another parameter” enter parameter type “number” then integer 1 or 0 to enable or disable Local Protection


That’s it. Thank you. I was looking around for “Set Parameter” as an action and could not find it. I did not think to look for setParameter within the custom command choices. I have tested this and it functions exactly as I would expect. Thanks so much!