VZM31-SN Config to use Smart Bulb Mode and also controlling load remotely

Here’s my use case:
VZM31-SN - with the Pantry Light connected to the load and controlled with Zigbee2MQTT/Node-Red.

  1. I want to use the physical toggle to turn on a group in Z2M for my downstairs lights via an automation. This should not affect the load on the switch (Pantry Light).
  2. I want to use a contact sensor via an automation to turn on the Pantry Light without affecting my downstairs lights.

I seem to be running into an issue where the ONLY way to control the load remotely, via automation, is to have Smart Bulb Mode Off. My automations still work, but when I press the physical paddle on the switch, it is also controlling the load.

I feel that I have tried every combination of Smart Bulb Mode, Local Protection, and Remote Protection parameters to get it to work and have not found a solution yet. I have also tried setting the parameters via the Z2M interface as well as directly on the switch. The key thing I observed is that with Smart Bulb Mode on, there is no remote control of the load in any scenario.

Does anyone know of a way this is possible?

Have you considered just directly hotwiring the Pantry line/load in the switch box and just using the Blue as a (no load) scene controller? That would get you off of SBM, which doesn’t seem to be serving any purpose in this setup anyway.

This would require a neutral for the Blue though.

How do I then automate the light in the pantry with a Zigbee contact sensor without introducing another device? The light is a 4ft fluorescent fixture. I’m also not too keen on having a fixture in the house that can’t be disconnected from power via a switch or air-gap.

Ah, I assumed the light load was smart - my apologies.

So SBM = Off, Remote Cntl = On, Local Cntl = Off doesn’t work? I have a similar (I think!) situation where a Blue is wired to a dumb ceiling load that is rarely used… I primarily use that Blue to control a floor lamp’s Hue bulb (via rules, not binding).

SMB is Disabled, Remote Cntl is Enabled, but my Local Cntl is Disabled – I’m then able to do everything I want from that switch (incl ceiling light control) via rules.

The bummer is that none of it works if my hub happens to go down, but I keep instructions handy for how to re-enable Local Cntl from the switch if necessary - that’d at least get me the ceiling light back. No need to do that yet, knock on wood.

Assuming you meant SBM Off, Remote Protection On, and Local Protection off, I tried that, and it didn’t work, so I reversed the Remote Protection and Local Protection. That worked. I thought for sure I had tried it, but must not have.

Here’s what worked, and how I achieved it: Smart Bulb Mode Off (Down Paddle + Config x4), Remote Protection Off (Down Paddle + Config x15), Local Protection On (Up Paddle + Config x10). It’s important to note that Local protection needs to be on when doing the config, so if you try the SBM setting, and don’t get the LED indicator flashing, you need to turn it on first.

Thanks for the second set of eyes!

1 Like

Right on! Apologies for syntax confusion, but sounds like we ended up on the same sheet of music. I’m glad to hear it’s working as hoped!