VZM31-SN show wrong firmware version with latest Z2M release

Any one know how to get the version number to update in Z2M. The old method doesn’t work.
Dev console.
Endpoint 1
Cluster genBasic
Attribute swBuildId

Error 2023-05-02 13:57:39Publish 'set' 'read' to 'Kitchen Lights' failed: 'Error: Read 0x040d84fffe02bdeb/1 genBasic(["swBuildId"], {"sendWhen":"immediate","timeout":10000,"disableResponse":false,"disableRecovery":false,"disableDefaultResponse":true,"direction":0,"srcEndpoint":null,"reservedBits":0,"manufacturerCode":null,"transactionSequenceNumber":null,"writeUndiv":false}) failed (Timeout - 17631 - 1 - 110 - 0 - 1 after 10000ms)'

I didn’t know about this old method, but just tried it and mine now shows 2.14 instead of 2.08.
z2m version 1.30.4

I did have to reconfigure the switch after

1 Like

You are right. It works on all of my switches. Except one. The Kitchen Lights I noted above.

I’ll probably factory reset that. See if that helps.

Tried a few more things. But ultimately on this 1 switch it took a factory reset. And the procedure above. All the rest worked with the procedure above and a reconfigure. Not sure why this one was different.

1 Like