VZM35-SN/HA/ZHA issue

That’s exactly what I have, though the trigger names are slightly different. Traces never register a trigger, no matter which trigger I try.

Guess I may try z2m, but I really would like to resolve without having to move everything over…

1 Like

What is your button delay set to in the device settings?

5, if I’m looking in the correct spot?

Yup, that would be 500ms which is fine. I’m hoping somebody else who may have more ZHA experience can jump in here.

Appreciate your help!

Unfortunately that’s a known issue, I just got the fix and will be getting a PR in. If you’re comfortable running a custom quirk, I can get you the config to put there? Otherwise it’ll depend when the PR is merged and updated in Home Assistant.

Edit - Link to quirk here if you want to go that route.


Thanks for the info! I’m open to trying the custom quirk - just will have to figure out how to do that. These are my first Inovelli switches. Is this a ZHA problem? If Z2M is working, I may spend the time switching my devices over vs the custom quirk…

Here’s the link for the ZHA config that would have to go in (you’d add the config pointing to a folder, make said folder and create the VZM35SN.py file in that folder). It is limited to ZHA, so you can also swap over to Z2M and give that a shot too.

Especially if these are some of your first Zigbee devices, I’d definitely give Z2M a try too just to see what you like better. I had a couple thermostats I had issues with via Z2M and that’s part of why I ended up back on ZHA.

1 Like

Thanks for sharing this @chack!

I copied the code you shared here and created a new file in my custom_zha_quirks directory called inovelli_zephyr.py. Then I restarted. The Zephyr seems to be picking it up correctly, but button presses still don’t show up when I listen for zha_events. Any idea why?


Not offhand, it was a pretty immediate change on my side. I see where it pulled the right quirk, and if you restarted HA then that’s all I had to do. Can try deleting the pycache folder in that custom quirk directory maybe? Or you can try adding the __init__.py file and see if that changes anything - can just copy it from the current.

Thanks. I can’t find the pycache (I’ve seen this suggestion on other forums too, but I can’t find it anywhere in my config folder in either VSCode or the default Home Assistant file editor. Is there a trick to finding it?

In the meantime I tried adding init.py to the zha_custom_quirks folder and copied the contents from current. It still didn’t work after a restart. :frowning:

1 Like

That file will need to be “__init__.py” not “init.py” just as a heads up, and the __pycache__ folder would be in the same zha_custom_quirks folder. As an example from what I’m seeing -

Apologies for the confusion. I accidentally removed the underscores in my reply. The file name itself was exactly “init.py” though.

I managed to locate the pycache folder using the terminal, so I deleted it and then restarted Home Assistant. But the quirk still doesn’t seem to work both with and without init.py (restarting in between each time).

1 Like

@chack I’m seeing the same behavior. HA Config:

custom_zha_quirks folder:


Custom quirk seems to be applying to the switch:


Deleted pycache, rebooted multiple times, still no dice. The only events I see are on/off.

1 Like

Alright, follow up questions for you both (and apologies if you already gave this elsewhere) -

  • What version of HA are you running?
  • Are you getting the error for the switch re the active_power_reports (this should be yes as it’s not merged/live currently)?

I’ll try to pair another switch tonight and test another idea or two.

Here’s my version numbers:

  • Core2023.11.0
  • Supervisor2023.10.1
  • Operating System11.1
  • Frontend20231030.1

Yes, I do see that active_power_reports error in my HA logs.


Ok, so I took a new switch out of the box, 1.04 firmware just like you. Connected it up, joined it to my existing deployment, and it worked as expected w/ button presses like the other one I had.

I updated from 2023.10.5 to 2023.11.0 (I’m running a docker container, so just core but also usually don’t go for the .0 releases myself) to make sure it matched up and wiped out my changes for the other PR. Validated again that it worked, even removing/re-adding the device.

I then wiped out the quirk I was using that’s got some older lines from testing it included as well, and replaced it 100% for the one I shared and also replaced that __init__.py file along with removing the pycache folder. Rebooted HA and I still get button presses.


So…could you try removing and re-adding the switch, and then clicking the “Reconfigure” button on the device page and see if that changes anything? Firmware reset if you really want to also?

1 Like

Well… this is crazy, but removing and re-adding the switch immediately showed all button presses. No reconfigure or f/w reset needed. So, maybe the quirk wasn’t fully applying until it was set up fresh?

The only other thing I can think of is that I had added a line to my config to change the device type from a light to a switch. It was showing the old device type with a (hidden) tag after it. Now it only shows as a switch. Not sure if @MasterDevwi has that in his config or not.

Regardless, thank you for all your help @chack!

1 Like

Glad to hear it!

Yeah, old entities, etc will persist after they go away. You can either click on them and remove/hide them individually or when you remove/re-add they’ll get cleaned up that way too.

1 Like

My HA:

  • Core2023.11.0
  • Supervisor2023.10.1
  • Operating System11.1
  • Frontend20231030.1
    I have tried multiple times to make these switches work rfor my ceiling fans but they only show as ON/OFF. I carefully followed the instructions to either configure manually (holding down paddle and click conf button 3 times) and in HA (manage Zigbee device etc), but no luck.
    I asked Inovelli for guidance but was only given these same instructions… which don’t work. I just requested a RMA.