Wall switches appearing as lights in google home

is there a way for the wall switches (both reds and blacks) to appear just as switches in google home? previously, if I renamed the switch like “fan”, for instance, it would show as a fan in GH. I see that I can change the device tipe of other devices but can’t do it with my inovellis.

it may seem practical if the switch shows up as a light, but in my case, if I say “change the light to green”, then the LED in the switch would turn green too… the other day I told google to change a specific light to a color and the speaker didn’t hear me well and changed everything that could change color in my home, to that color. and that included of course… all the switches. (again both reds and blacks)

or in my bedroom where I got a light and the celing fan, if I tell gogle to turn on the light, it would turn both the fan and the light (even though the switch is called fan).

I see what you’re talking about but don’t have the same issue as you. I’ve had some success in renaming devices when GH gets them confused or groups them in a voice command.

I see that you were able to get modify the icon by specifying as a fan. My fans display a fan icon but the device type is Fan (Switch) and the device type is configurable. I wonder if you can temporarily rename the light switch with “fan” in the name to get it to look like a fan, then go into GH settings and change the type. Then rename it again in ST.

This is just a WAG. I have no idea if it would work but it’s worth a shot.

I renamed the zigbee switch to “fan” and google inmediately changed the icon to a fan. the switch in question is a sonoff that I control with the red series routines. the same doesn’t happen with the inovelli. it remains as a light all the time.

I’d like them to be configurable because as I said, all my wall switches changed colors by mistake the other day when the speaker didn’t hear me well on which light I wanted to change. everything turned to that color (bulbs and wall switches) and I had to go one by one and changing all the red and black switches to my previous color choice.

in my hallway I got a red series with an illumin bulb. if I say “change hallway to green”, both the bulb and the switch LEDs turn green.

Ok, so now that GH thinks it’s a fan, can you click on the gear icon in GH for that device and change it to a switch? It probably says “Fan (switch)” now.

I can do the device type change with the zigbee switch if I wanted to but I only needed to rename it as a fan in smartthings for it to appear with a fan icon in GH.

with the inovelli wall switch I don’t have any choice but accept what google think it is. in this case, a light… or a colored one because it lets me change the color of the led as if it was a bulb.

I don’t think you are understanding what I’m suggesting. Now that GH thinks is a Fan (Switch), can you change device type to a switch in GH?

once I rename the zigbee switch from the smartthings app as a fan and GH recognizes it as such, I’m able to change the device type en GH.

Inovelli switches are Zwave, not Zigbee. Are you saying you can change the Inovelli switch or are you referring to some other Zigbee switch?

what I’m saying is that I can change other devices but not the inovellis. no matter what I do, they appear as a light in GH while with only a rename in smartthings GH recognizes my other devices. the zigbee switch was an example.

what I did with the zigbee switch is what I’ve done with the inovelli reds (and blacks) and still they’re shown as lights in GH.

Groundhog day . . .

Forget the Zigbee switches. I got that.

You renamed an Inovelli switch to put “fan” in the name and now GH thinks it’s a fan, right?

Now that GH thinks it’s a fan, can you switch the device type in GH after clicking on the cog icon.

A: Yes
B: No

it’s always been named as “fan”. since day 1 but it just won’t let me change the device type.

It looks like I see the same thing: most switches show up as “Device Type: Switch”, which gives you a drop-down to select what the switch is controlling (and tries to guess based on the Display Name). But Inovellis do seem to show up as “Device Type: Light”, which has no option to change it. I’ve attached screenshots.

I think that’s incredibly short-sighted of Google, and is one reason that I don’t use Google Home as my primary way to control devices (mostly, I use it for voice control). Another annoyance is that I can’t choose the order of rooms in the be app, or of devices within a room (both alphabetical, and I’m not going to call a room “01 Living Room” just to make it show up first :wink:).

That said, I wonder what capability in SmartThings (and ultimately in the DTH) are causing it to show up as a “light”. If it were something like the color changing feature, you could try making a version of the DTH without that capability, and apply it to the switches that are at issue. Of course, you’d also lose the ability to set the LED strip within the ST interface, but you could still control it through the usual parameter setting mechanism.

Other ugly workarounds might include moving the switch to a different “room” in GH (so it doesn’t get picked as a “light” in that hallway) or even another location (GH, unlike ST, allows you to move devices between locations).

.

1 Like

Interesting – thanks for posting pics.

@EricM_Inovelli – is there anything we can do from a device handler standpoint that would fix this?

this is what I see in my GH when I open one of my inovellis. as you can see in the screenshots, they’re treated as color bulbs (but without the diming capability).

I’m not too familiar with the inner workings of Google Home, but if you delete the following line towards the top:

capability “ColorControl”

It may correct the issue. Users had asked to add LED color control to the handler via that capability, but there are always unintended consequences. I don’t know if after that line is removed if the Google Home devices need to be resynced or if something else needs to be done.

2 Likes

thanks! u guys rock! :muscle::muscle::muscle::muscle::muscle:

Nice work @EricM_Inovelli

1 Like

I see it worked fine with the reds but with the blacks it only disabled the ability to change the LED colors.

for the moment it’s good enough for me since since I got the fan with one of the reds. which is gonna be replaced in the not-so-distant future by a fan switch. maybe the fan+light oooooor, the soon-to-be_released inovelli’s fan switch (pun intended :stuck_out_tongue: :stuck_out_tongue: :stuck_out_tongue: :stuck_out_tongue: )

Since the ColorControl is for setting the LED color, not the color of a luminaire controlled by the switch, perhaps the LED color could be controlled by ColorControl could on an “virtual RGB bulb” child device.

1 Like

Yeah, totally, that is a great idea. I have been meaning to get to creating LED color child devices as I think that is the best way to go.