Why is getting start so insaleny hard?


I’m starting a new setup for a new house with a Bunch of Inovelli switches and Hue bulbs and, as a software engineer who likes to tinker I was like “this is going to be fine” and it is not… So this is a bit a rant hopefully some at Inovelli who works on the documentation reads this.

So I’m at the beginning, 4 hrs into the adventure and I’ve achieve close to nothing. I want to do a what is done is this Video with Zigbee Bindings but EVERYTHING is a struggle.

  1. First off, ZHA has changed changed the UI so it took me a while to figure out where to find the Clusters now that is it hidden in two layers of sub menus?! So I eventually find it and I’m like great, what are clusters? I figured this would be easy to find documentation about that but nope searches like “Clusters in Home Assistant explained” yield nothing.
  2. Anyway I find the clusters and I have two, Type: in and Type: out on the same Endpoint Id. Meanwhile, the video has 3 with with different Endpoint Id, what are Endpoint Ids and Type? Mystery… I click the first one Endpoint 1, type: in because that matches the video.
  3. And now I’m like ok that part should be easy but No the list I get has nothing to do with the documented list on the website.
    1. I couldn’t find swicth_delay as documented and had to figure out that I actually need button_delay
    2. A bunch of parameters missing from the list too, maybe I need to change the mode from ON/OFF to dimmer? The documentation indicates that that’s a thing but doesn’t explain to switch it.
  4. In the end I managed to reduce button_delay to 300 and turn on smart_bulb_mode yay. So I can turn my lights on and off and that’s it. Dimming still doesn’t work and I’ve spent 1 hour on it already.

Anyways, I wish this was easier. A comprehensive 1 or 2 hours video tutorial on how to do a basic setup with the switches should be enough to allow someone to then infer whatever else is needed but these 1 minute videos and the dozens of pages with stale information just make it really hard.

I’ll keep trying for a bit but I’m very tempted to give Hubitat a try at this point.

I found ZHA very difficult as well. Zigbee2mqtt is much easier and has support for more devices.

I’ll probably get crucified for this, but IMO home assistant is the problem. Everyone touts how great it is and it’s “easy” to set up. But like you, I have a tech background, run a home server, multiple OSes in my household, and constantly tinker with open-source software. Home Assistant has been the most frustrating piece of software I have ever attempted to use.

I use Hubitat and it has been flawless. Everyone says it’s “difficult” but I’ve found it dramatically easier than home assistant. It works flawlessly, which might be part of the reason I have been unwilling to get through the steep learning curve for home assistant.


Not me. :grinning: Tech background as well . . .

I run SmartThings, Hubitat and HA at one of my locations. ST is my production hub at both. While HA is incredibly able to work with almost any smart device, that capability comes with the cost of an extremely steep learning curve. I find that I can get almost everything I need to work under ST, leveraging a couple add-ins. And for those things that aren’t ST or Hubitat compatible, I can usually bridge them to solve that issue.

My thinking is that if you want the power and flexibility of HA, you move to that ecosystem after you have had some experience with devices running on another hub. That will give you a leg up on getting started.


I feel ya man, trust me. I’ve tried so hard to put something together for Home Assistant for years, but it’s impossible.

The moment I create a video, they release a new version the next day and my video is outdated. On top of that, everyone’s setup is different.

I can’t tell you the amount of work I’ll put into a video only for it to be outdated and then get lambasted via tickets (or a thread like this – not blaming you, I’m just as frustrated lol).

I’m open to ideas to make it better. I even tried to have a community lead knowledgebase so that it could always be up to date, but I couldn’t get that off the ground either :frowning:

Hubitat has a learning curve for sure, but generally only when you get into more advanced stuff, and if you’re a software engineer (I am as well) you shouldn’t have any problems that can’t be resolved. For the most part, getting up and running with basic things in Hubitat is pretty easy, and the user community is great. I don’t think you would regret going that route.

I recently bought a new house and had the opportunity to start over with home automation as well. I stuck with Hubitat and went almost exclusively with Inovelli Blue switches and Hue bulbs. Aside from the cost of nearly 50 Inovelli switches and almost as many Hue bulbs, I am happy.

1 Like

I agree completely :+1:


Well, this is not how I expected this would go… Apparently, this is a popular opinion lol.

Thank you all for your support. I found a video that shows a “Configuration” panel that is being referred to in the Innovelli doc that I couldn’t find. But turns out the reason is, I don’t have it…
So I asked what he had done to have this panel in the comments and the author responded that he hadn’t done anything special… So, I re-paired the switch (which I guess is different from “Reconfigure”) and voila the Configuration Panel showed up.

Let’s see if I can get them to do what I want now…

I wouldn’t. If you ever want to get into any sort of advanced automations, Rule Machine is incredibly frustrating! HA’s automation platform is significantly more intuitive. Yes some of the more advanced stuff in HA is more complicated than HE, but it’s also significantly more advanced than anything HE is capable of doing…

Not to mention the hubitat hub itself is underpowered and prone to slowdowns and crashes. Spend any time on their forums and you’ll see tons of people running 2, 3 somethings even 4 or 5 hubs because a single hub starts having issues as your smarthome grows. The new C8 model here in Canada costs about $300 taxes inc. Multiply that by 2-5 hubs and you’ve spent a ton of money and still have something with less power and less capabilities than HA.

I find HA complex, because it is. It takes time to understand parts of it. But, the basic system is pretty good once you figure out where to find things and how to do basic stuff. Then, the more complex stuff can start to seem easier.

The frustrating part I’ve found is the forums where it seems there are many people who will post yaml bits as examples even though they don’t work. I can now recognize some of the obvious wrong stuff that was touted as solutions.

I’ve never used ZHA. I have a few devices on zigbee2mqtf and it seems pretty easy.

I also run it all with Docker containers which gives me easy access to the configuration. hAOS convolutes that.

I agree the Rule Machine editor is very frustrating when the rules are more complex. If you are getting into advanced automations on HE, you should be using WebCore or Node Red instead of Rule Machine. Either of those can support very advanced and complex automations.


Or the SharpTools Rule Engine, so simple a caveman can code with it.

The benefit of Node Red in Hubitat is it offloads the automations to another machine which actually helps prevent the hub slow downs. I had given up on RM and went back to WebCore since I was used to it from ST, but that was back in the days where all of the slowdown issues were blamed on using third party apps. Then I switched to NodeRed and it really made things significantly quicker. I’d highly recommend it to anybody on HE.

1 Like

I forgot to mention that the developer tools are very handy in HA. They make testing stuff easy.

Just wanted to point out that clusters and endpoints are part of ZigBee standard, so I would not ding HA or Inovelli for not being clear about that. Learning/understanding ZigBee is not an afternoon’s effort - nor is learning/understanding HA. Like anything else you evolve an increasingly richer understanding of these, and as you do you find you can do increasingly amazing things.

TBH, in all my years of using Zigbee and home automation platforms including HA… I’ve never once needed to even think of “clusteMs” to accomplish anything. Maybe it’s because I went down the Z2M route, but clusters aren’t even a thought in my head when I want to do anything with any zigbee device on HA. :man_shrugging:

I joined this forum today looking for help and this sounds like me. Software developer for 35 years but brand new to Home Assistant. I bought a Home Assistant Yellow and have it all setup. Started with a couple Sengled smart bulbs and have those working fine with ZHA. Ordered a refurbished Inovelli Blue 2-1 switch that just arrived yesterday. Wasted a bunch of time so far. I have it paired with ZHA. I wanted to put it in Smart Bulb Mode and create an automation so that the switch controls the smart bulb but none of the switch presses seem to be showing up in HA. I goto developer mode and listen for events using * and none of the switch presses create an event. I created an automation so that when I command the switch on/off in HA it will turn on/off the light but I cannot for the life of me get actual physical button presses to control the light via an automation. I also can’t tell if the Inovelli switch will actually work as a dimmer. I set it to Dimmer mode in ZHA but I don’t see any new controls that allow me to command it to dim. I also do not see the blue led bar change when I hold the up or down physical buttons so at this point I’m ready to go find a sledge hammer. Since its my first smart switch I’m not sure how it’s supposed to work but it doesn’t seem right. I first want to just get a normal bulb and try to get it manually dimming but every bulb I found yesterday was LED and said non-dimmable. I wanted to start my own topic but the new topic button was greyed out so I figured I’d add to this venting topic that seemed similar to my experience. :slight_smile:

Welcome! Personally I find zigbee2mqtt much easier to use than zha. It sounds like in your frustration you might have turned on local protection (disables the wall paddle). To turn off local protection press Down paddle + 10x config button.

Yeah I was searching for help everywhere last night and ended up down the zigbee2mqtt rabbit hole. I didn’t really understand that it was a separate entity from ZHA I thought it was going to interpret the zigbee and send mqtt commands to ZHA or something like that. Anyways I installed the Mosquitto broker and zigbee2mqtt but I never could get it configured right and then it seemed like ZHA got hung in an “initializing” state forever so I shutoff all the mqtt stuff and rebooted to clear that up.

I did do a lot of button mashing so its possible but there is a “local protection” field in the ZHA parameters for the switch and its been off the whole time. Plus the paddle still works for on and off it just doesn’t seem work as a dimmer. I thought maybe it was distance to the HA yellow so I moved it upstairs ten feet away from the switch to rule that out.

I’ll probably try to factory reset the switch again. I just didn’t want to flip the breaker after my wife had already reprogrammed her alarm clock…lol. I had a heck of time with the initial pairing. I had installed the switch but had to leave before I paired it. It was flashing when I first powered it up. But I get back home and it was solid blue. None of the instructions I read seemed to put it into pairing mode. I flipped the breaker and used the air gap and held down config for 20 seconds. Then I read you need to hold down up and config. Doing the 2 button combo I finally got it to start pulsing blue. Turn around and grab my iPad and its already solid blue again before I could tell ZHA to search for devices. That happened twice. Finally I grabbed the iPad and stood right there and sure enough it flashed blue like 3 times then turned green and back to solid blue. I was getting frustrated cause I hadn’t even told it to sync in HA yet. I just happened to go into HA to control the bulb in the room when I noticed the Inovelli switch was in the device list. So I have no idea when it paired because it NEVER showed up when ZHA was searching.

@Gilrock ZHA and Z2M are competing products. ZHA Is built into HA and Z2M is an addon that also requires a mqtt (mosquitto) broker, and the mqtt integration. With Z2M everything is exposed without having to fiddle with the developer console. When you tried Z2M did you disable ZHA? I assume you pointed them to the same physical zigbee radio? You might want to start your own thread and I can post my z2m and mosquitto config. Feel free to tag me.