Within ~12 months 50% of Smart Dimmer Switches are Broken -- Help?

Have ordered multiple switches from you and installed 6 so smart switches so far in our home…purchased because of the no-neutral required capabilities, but have had issues throughout, but even more so on 3 smart switches that don’t work now (about a year after install). 2 of my switches don’t work AT ALL and can’t even manually click the switch to respond. the LED lights don’t light up even though there’s power running through it. The other problem switch doesn’t work through a manual switch, but can be voice-activated still via Alexa or Smart Things app…but again, I can’t just walk up and switch the lights on by hand. All 3 of these have gone bad over the past ~month after about ~12 months or so being installed. What help can you provide to resolve this issue (refund, replacement, etc.)? My fear is that with all of these going bad now, the remaining switches will ultimately go bad too in the near future. Please help and let me know what other information you might need. Thanks.

Interesting that you’re having that issue. I have many Inovelli switches which have been installed for quite some time and I have never had a single failure. Inovelli’s failure rate, I think, is less than 1%.

What troubleshooting have you done?

  • Have you tried pulling the airgap to reboot the switch? The switches contain an MCU which is essentially a little computer, so it’s not out of the realm of possibilty that the switch has just frozen. Cycling the switch via the airgap or breaker will correct that.

  • Have you switched out bulbs and then encountered the issue with the switch? If you change the load, that can affect performance and power feed, especially with a non-neutral.

  • Have you installed bypasses on the non-neutrals? While an installation may have worked at one point, overall changes to your circuit in terms of power demand can impact the current being leaked back to the switch to power it. That can result in a switch that was once adquately power no longer being so. The bypass should resolve that.

1 Like

Hey @palmdog13 – happy to help out publicly, but have you submitted a ticket? Typically, the forum is not a place to share sensitive data, so I just want to be careful as it seems like this was worded as a customer service ticket.

I deleted your Amazon Order info as I’m not sure if that can be reverse looked up publicly or not. I don’t think it can, but just to be safe, I did.

Anyway, again, happy to help diagnose this and of course, take care of your situation.

Let’s go through these one by one as they sound like separate problems.

Along with @Bry’s questions, can you let me know what Hub you’re using? I’m guessing based on your profile that it’s SmartThings, but I just want to make sure.

Here are a few questions to help me diagnose this issue:

  • Can you let me know how these are setup? Are they single-pole or multi-switch?
  • What lights do you have on these (ie: LED, CFL) and what is the approximate wattage?
  • Have you checked the wiring to make sure one of the wires has not popped out (sometimes this happens if the plate wasn’t compressed well enough)

This one should be an easy fix – can you tap the config button 8x rapidly (the LED bar should light up Green). I think based on the fact that your switch can be remotely controlled, local protection must have been turned on by accident (ie: when this is on, you cannot manually use the switch – this is a feature used for smart bulbs).

We’ll make sure to resolve any issue you have, I can promise that. As @Bry mentioned, our defect rate is actually around 0.3% (actual defect rate, not user induced – not saying that is the case here, just saying in general), so I think we can figure this out via some troubleshooting. Either way, we’ll get to the bottom of it and take care of you.


@Eric_Inovelli thanks for the note back and the other inputs. I followed @Bry instructions and pulled out the airgap to reboot the switches. that worked on 1. check. I then held down the reset/command button or whatever on the top right for 8 seconds and that worked on 1 (weird as it only worked on like the 5th attempt of doing that. who knows). but the 3rd switch still hasn’t “come back to life” or worked even after following all of these steps outlined. any help is appreciated in getting this one resolved/fixed…thanks in advance.

A hard reset is accomplished by holding config until the LED bar turns red (~20 seconds). Try that next.

Thanks for the reply @kreene1987 but that still didn’t resolve the issues…it really shows no signs of life. ha

Hey @palmdog13 -

If you open up a support ticket we can go ahead and RMA that switch for you and get you a replacement!

1 Like

thanks…i did create a ticket (#13519), but didn’t hear back yet. Might have been a missed email or something on my end.

Yea it looks like Christian responded to you on the 16th - may have gone to your spam mail. I’ll take the ticket and send you an RMA label.

1 Like

okay. i’ll watch for a new email to come through. thanks

Morning. Was a note or email sent through? as I didn’t see anything over the last few days.