Z-Wave 800 Series 2-1 Switch (On/Off & Dimmer) | Project Phoenix

Yes, I saw this and it fixed it for me as well. MAX level of 87 seems to fix it

Odd as it’s only 4 LED can lights.

Never mind my question - I figured it out.

From what I gather, if I use my switches as On/Off only, then I should set parameter 22 to “No AUX Full Wave”. It would help reduce issues if I have (or install) a non-dimming bulb and bathroom exhaust vans. Thanks!

FYI, this switch isn’t rated for fans. You want the fan switch for that.

1 Like

@t_shaun @Eric_Inovelli They are in receiving so once they’ve been received into inventory we’ll start shipping them out. Lots of backorders to fill but we’re quick so barring any issues they’ll be out in the next few days. Watch your inboxes! We will have positive stock once we’re done so feel free to order more :slight_smile: :wink:


A post was split to a new topic: Red Series 2-1 Issues (Clicking, Flashing Cyan & Yellow)

How can I get Hubitat to identify these switches? I already update drivers through HPM.

You’ll need to manually set the correct driver Type yourself in Hubitat - long story short, Hubitat won’t be able to identify these natively.

They should work just fine, but like @harjms mentioned, it would probably be best to bench test it first if you can.

Sorry for the confusion lol. As @Bry mentioned, definitely try to hardwire them as these switches are not rated for outlets. In theory if they are single-pole and you use Full-Sine Mode (Parameter 22), it should work, but we can’t officially endorse it as it’s not rated by UL for outlets.

Another option for you would be to use a Z-Wave smart plug (Zooz has some) that supports the wattage and then use Z-Wave Associations from the switch to the plug.

But if you want a hardwired approach to control an outlet, then I would recommend what @StevenZwave mentioned.

I haven’t made a location yet, but I will throw something in GitHub and let you guys know shortly. Great idea!

No, I just hadn’t updated the GitHub page :flushed: – I just added the parameters and descriptions so it should be up to date!

Looks like I made a mistake – checking with the other Eric. I thought this made it into this firmware file. But I don’t see it either. I was testing 1.01 and I see it in the 1.01 change-log. I’m just noticing this today as I updated the GitHub parameter page.

If you need Leading Edge, let me know and I can share the 1.01 file. I feel really dumb.

Yeah this is my fault (again… arg)… the correct parameter is 161.

The GitHub page should be up-to-date now with the correct parameters.

Looks like @mamber nailed the rest of the questions you had – let me know if you have any more!

Yeah sorry about this, this also happens on the Blue Series switches and this was the explanation we got from the engineers:

The reason this happens is that the traveler wire is used to detect when the dumb switch is toggled. When there are many bulbs, the switch can sometimes get confused about whether the switch is flipped or not when the circuit is at a higher level. So it flips the load on and off quickly. Lowering the max level will get rid of the interference on the traveler.

Correct :slight_smile:

When did you update them? We just pushed an update late last week. The problem was that there was a new fingerprint that was used on the device that we didn’t have in the driver. So, if you installed the driver before last Friday, then that’s likely why it’s not picking it up.

I’m also not too familiar with HPM and how it grabs drivers. I just installed the driver manually from GitHub, so maybe there’s a disconnect there? I’m not sure.

I can tell you that I was able to get it to detect following these directions (I just re-verified just now): https://support.inovelli.com/portal/en/kb/articles/setup-instructions-red-series-2-1-switch-hubitat


Thanks Eric, that worked and got the switches working properly now with the drivers. I couldn’t find any links to the new drivers, appreciate you linking them.

1 Like

A post was split to a new topic: Red Series 2-1 & OpenHAB Integration

A post was split to a new topic: Red Series 2-1 Documentation

FYI - there are some (really nice) settings that aren’t updated on the page yet. Specifically, the fact that the Dimming Speed and Ramp Rate parameters actually support values up to 254, as follows:

5-100 = 100 ms (500 ms - 10 seconds); 101-160 = seconds (minus 100); 161-254 = minutes (minus 160)

I’ve already put this to use to ramp my bedroom lights from Off to On over 5 minutes when I wake up. :grinning:

As an aside, I am super impressed with these switches. I previously had one Red series switch and a couple of HomeSeer switches, but the bulk of my switches were UPB technology installed in 2006. The feature set in the Red 2-in-1 switches is incredible, and the dimming is nice and smooth. Great work to you and the team!


5-100 = 100 ms (500 ms - 10 seconds); 101-160 = seconds (minus 100); 161-254 = minutes (minus 160)

It sounds very cool that it can handle such a wide range of times, but I’m a little confused about how these get set from the above. So would 11 seconds be set as 111 and 11 minutes would be 171?

1 Like

Yes, that looks correct to me. (Going with the Z-Wave JS parameter documentation and what I can find in the Hubitat driver as I work on my own since the only official-ish source I can find right now is the Z-Wave conformance doc. :smiley: )

Let me check on this – my understanding was that Z-Wave could only handle up to 100 (not 255 like Zigbee).

I misunderstood the engineer – hoping to get everything double-triple checked. There are so many parameters that I have a hard time keeping up sometimes. Thank goodness for @EricM_Inovelli lol.

Oh that’s really cool! I hadn’t thought to use it for an automation purpose. I use the Ramp Rate settings to have it so that when I turn on the light, it comes on instantly (like an on/off switch) and when I turn it off, it will fade off over 2ish seconds.

Thanks! Yeah these switches have come a long way and I have to give the credit to the community, you guys are awesome! So many cool ideas that we would’ve never thought of.

I was comparing our Gen 1’s from 2017 to these and while we thought the switches back then were awesome, these are night and day in terms of feature-set. Really goes to show what constantly innovating can do.

Let me do some digging here. I am “spoiled” with SmartThings in the sense that the UI doesn’t allow all these custom parameter changes. It just shows the values I can choose from. In other words, it just shows 1ms, 2ms, 3ms, etc but doesn’t give me an option to input specific values.

1 Like

I was working on the 2017 switch SmartThings Edge drivers a few months back and it really made me think about how far we have come. I think there were like 9 parameters on the dimmer and @Eric_Inovelli and I would stay up late with China testing firmware and it was sooo much easier lol. I miss those days in that regard, but it is cool to see everything we have added with the help of the community.


I’ll have to find that one video of me absolutely losing my mind when I was testing out non-neutral Z-Wave Association or something with our Gen 2’s.

At the time, I didn’t think it was possible to dim up/down a smart bulb using an aux switch in, “Smart Bulb Mode” (aka Disable Relay lol) and then, I just pressed the aux switch and it worked.

I’ve never been more embarrassed to have geeked out over something lol.

That’s what I’m seeing. I’m setting it to 165 for five minutes.

For any other Canadians wondering about Aartech shipments, I placed a pre-order on July 5th and just got a notification today that it’s now on its way to me! So they seem to be in stock now and have caught up on their pre-orders.