Z-wave association of red dimmer with zooz zen34

Hi,

I have a red dimmer (fw v.1.57) in my kitchen and it’s working great to control the main room lighting. We love it! I setup a zooz zen34 remote (I’ve heard that the Inovelli team has some history with this remote) and am having some issues getting dimming to work via associations.

Using zwavejs2mqtt I have setup a group 2 association that turns the red dimmer on/off correctly with the correct ramp rate on a keypress.

I’ve setup the group 3 association to control “dimming”, but there is no dimming behavior when the paddle is held. It actually turns it on/off with out any ramping. I even removed the group 2 association and that doesn’t change the keyPress held behavior.

I’ve read on other topics here about virtual 3-way circuits that there is a need for a group 4 association to control the red dimmer, but the zooz zen34 does not offer that association group (zooz for v1.2 & zwavejs2mqtt: 5.9.0).

Any ideas if dimming is possible via direct association between these two?

Thanks!
Elliott

The zen34 is a switch and not a dimmer. I don’t think you can hold to dim. You can use scenes to dim to a certain levels.


P0

Scene Control (select hubs only): trigger up to 8 scenes or control up to 8 devices with multi-tap control.*

Hi and thanks for the reply!

One of the features listed in the manual under the section on “Associations” is:

“Association Group 3 for direct Dimming control of other devices”

I assume that either I have missed something in my setup or the Inovelli switch requires group 4 to associate dimming behavior.

Cheers,
Elliott

Strange. I tried it with a lzw42 and it didn’t dim either. Not sure why.i find the association behavior very limiting with the zen34. I have it associated to 2x lzw42 and it sometimes only toggles 1. I’ve stopped using it for that reason.

2 Likes

Oh, good. Glad to hear I’m not the only one using it around here.

Being battery powered and mobile probably open up a set of issues not normally seen by stationary, mains powered switches. Odd that it will only control one bulb at times. Sounds like a connectivity issue to me.

For me, I have very reliable operation with it and it’s nice to turn on/off the lights, so I’m hoping I can get dimming setup as well. I’d like to fully explore associations before I look to create dimming automatons.

If anyone has some insight into the association behavior for group 3, I’d appreciate it.

1 Like

Interesting you had the same problem with your associations! It’s incredibly frustrating, I really wanted to use associations with these switches as I have a couple functioning as “fail-safes” in the event HA goes down unexpectedly. Since a few of my ZEN34’s regularly only toggle 1/2 lights or 3/4 lights, it’s borderline unusable. Worse, it’s not always the same light, sometimes it’s the left, then the right.

Also Elliotjohnson, for what it’s worth I also tried to set up dimming on my end with two of my switches and it did not work at all. Does not appear to just be you.

1 Like

Thanks for confirming that.

I’ll do some more debugging on this and I appreciate all the help.

Regards,
Elliott

I’ve spent a bit more time with the remote and contacted Zooz support. They passed along a new firmware version 1.30 for the zen34 and I’ve upgraded.

What I’m noticing now (I didn’t notice it before) is that it is controlling the dimmer. For instance when the dimmer is at 50 and I hold the paddle up, the red dimmer will jump instantly to 99. If I tap the remote down and then tap up it will turn off and then return to that 99 value.

When I hold the remote paddle down it sets the value instantly to 0 and when I tap it back up the dimmer returns to the last value (which was zero).

So it does appear to actually control the dimmer, but the result doesn’t seem to follow the dimming speed setting on the red dimmer.

Any thoughts on this? Any configuration variables I should be looking at on the Inovelli side?

1 Like

Parameter 1 should be what’s used when changing the level via association. But, you could try parameter 3 as well to cover all bases. You need a longer time, maybe 3-5 seconds so you can see the difference.

That remote only having group 3 makes total sense. Group 4 is for sending the final level after you are done dimming, and that remote doesn’t have an internal “dimmed” level so it has nothing it can send.

When associated dimmer to dimmer, group 3 would tell the other dimmer to dim while the button was held and then when you released the paddle group 4 would send the final dim level which did the final synchronization of the other dimmer. With only group 3 associated, the other dimmer would follow while the paddle was held but it would always be a little behind and end short with it’s level. With only group 4 associated the other dimmer would do nothing until the paddle was released and then it would adjust its level.

Group 2 is for on-off. With dimmers, the other dimmer in the association will not use parameter 3 when it is being turned on or off. Without group 2 associated and say parameter 1 set to 3 seconds and parameter 3 set to 0 seconds on both, the one where the paddle is tapped will turn on or off immediately but the other dimmer would still ramp because it is not sent the turn on or turn off signal, only a ramp to level signal (with the level being 0 of off).

I know this is more than you probably need to know, but hopefully it helps with knowing what the association groups should be doing which might help with why something happens.

Depending on the hub you are using, you might be able to log the operation and see what commands are being sent.

3 Likes

Good to know. Mine is 1.1.

PJF,

Thanks for confirming the desired behavior of the various association groups.

With group 3 associations I have configured the switch to have a dimming speed of 1 second and the ramp rate to sync with the dimming speed. The manual and zwave control for these values are all synced to that 1 second interval.

The behavior with group 3 association when held up is to instantly jump up to a dimming level of 99 and when held down to jump to 0.

I’m not sure if the group 3 messages get received by the Inovelli dimmer and are interpreted incorrectly or if the zooz switch sends messages to the dimmer in a way that triggers the behavior.

I have another red dimmer and I’ll see if I can get it to control the other dimmer correctly with the same associations. I might look at sniffing the traffic to see what the switches are doing differently.

Best,
Elliott

2 Likes

Thanks for confirming that new firmware fixed the issue. I have a couple switches on 1.1 and 1.2 firmware, I’ll try to reach out to their support for the 1.5 update as well then

I believe it wasn’t a change for my situation, but
I hope the upgrade helps you out (I was given v1.30).

Elliott

I have been testing this and I believe that it is because the Zooz is sending a “duration” value of 1 with the “startLevelChange” command. So it is dimming from x to x in 1 second. When I change that duration to 0xFF (default) or 0x02, 0x03, 0x04 then it works.

2 Likes

EricM,

Thanks for digging in and demystifying this. I will report this to Zooz and see if they have any suggestions.

Best regards,
Elliott

2 Likes

@elliottjohnson did you have any luck reaching out to zooz?

Yes, I did get a response. They mentioned that they would look into a firmware adjustment to allow the duration to be configurable, but I’ve not heard anything back.

I’ll reach out to them in the new year to see if it is on the horizon.

Please open a ticket with them, since it shows that there is interest in the feature.

Thanks,
Elliott

2 Likes

FYI - I got a update from zooz support that they would be looking to do a late Feb/early March release that might make this value configurable.

2 Likes

As an update, their support reached out with a v1.40 of their firmware that adds a configuration parameter 5 for adjusting the dimming timing for group 3 associations.

Using this pre-release I’ve been able to control the red dimmer correctly! Hopefully others here find this useful. I would reach out to their support to see if they can share the firmware.

5 Likes