Zigbee Bulbs turn off immediately, don't ramp down

I’m using Zigbee2MQTT to bind groups of bulbs to my switches. When they turn on or change brightness, they follow the ramp time and smoothly transition. When I turn them off, they turn off immediately with no transition or ramp down. I have the default 2.5 seconds set and the rest of the times mirroring that by setting them to value 127.

Any ideas as to why this is happening?

They wouldn’t happen to be sengled?

1 Like

Nope. They’re all Philips Hue.

Can you post your bindings?

@stu1811 sure thing. Here’s the binding and the group for good measure

Take a look at this thread and see if anything there is helpful: Annoying Blue 2-1 Behavior w grouped Hue downlights

Two things stick out to me:

  1. Add the switch to the group (endpoint 1, level control).
  2. Set the transition time on the group, has to be done manually from the config file.
1 Like

Thanks for these steps! I tried each. Adding the switch to the group made no difference in functionality. Then I added a transition time to the group of 3 seconds in the config file still with no luck. I wonder if it is something to do specifically with Hue bulbs. But it is odd that they transition brightness from the switch and turn on with the ramp as well. It is only turning off that causes them to turn off immediately.

Let me know if you have any other thoughts. I didn’t see anything else in that thread.

I wonder if it’s a behavior difference in the bulb firmware vs the downlight firmware. Guessing you’re running latest hue firmware on the bulbs?

Indeed I am. Zigbee2MQTT shows them all on the current firmware releases. I looked into factory resetting the bulbs as well, but realized I did that exact process when I moved them from my Hue Bridge to Zigbee2MQTT in the first place.

I think I figured out what I had done to fix this!

On the bulbs in Z2M, there’s a settings specific page which has a transition setting for the bulb itself. I have that set to 2 seconds, matching my Inovelli switch settings.

@rohan So I wish that was it for my fix! But unfortunately, I had already set those to 2 seconds for each individual bulb. I presume since it is a group that is being controlled by the switch and not the individual bulb that the setting doesn’t have any effect. I’ve tried playing around with different values just for kicks too.

I actually have the opposite issue with Ikea bulbs. lol Transition of bulbs set to 0, ramp rate of the switch set to 0. But when physically controlled they ramp down. I can’t make them instant with binding.

Sorry, I’m all out of ideas. Between the bulb transition, switch transition, and group transition, it seems to be working for me.

1 Like

No worries @rohan thanks for all the troubleshooting help!