Zigbee disconnect = non-functioning switch!

I’ve had two 2-1 Blue switches installed for just over a month now. I’ve just got my first potential impasse that may lead me to not purchasing more in the future: if the switch disconnects from the Zigbee network while in Smart Bulb Mode, there is no way to reset the switch back to a standard switch. It just becomes a non-functioning light switch.

I came home yesterday to my housemate mentioning the lights weren’t working. I glanced over to see the LED blinking cyan every second. I assume this means it has disconnected from the Zigbee network. I pushed the buttons on the switch and got no response from anything. I tried to put it back into non-Smart Bulb Mode using the buttons, but this didn’t take. After pushing it intermittently for a few minutes, it flashed Green, Blue, Green, and then became responsive again.

This is the second time this has happened in a couple of weeks. Full stop, if there’s ever a chance that a light switch stops working and cannot fall back to being used as a regular light switch, I’m uninstalling the switch. I don’t want to install smarts if there’s a chance that I inadvertently make my house more dumb in the process.

A few details about my Zigbee mesh:

  • Coordinator: SkyConnect, latest zigbee-only firmware, on USB extension cable
  • Zigbee2MQTT: 1.30.3-1
  • 2-1 Firmware: 2.14 (latest)
  • Zigbee channel: 25
  • My APs and other 2.4GHz are on separate non-overlapping RF channels. I’ve also done a wireless analysis and used the channels with the lowest utilization.
  • I have loads of Hue bulbs (all around my home) and two Zigbee thermostats that have no issue. Instant, constant response on my network.

Has anyone else had any general connectivity concerns with their 2-1s? My switches are in open spaces surrounded by many other Zigbee router devices. One of them is within a 3m range of the Zigbee coordinator, and in direct line of sight of several Zigbee router devices.

I’m rather concerned. I want to love these switches due to their ability to act as a smart light switch that can bind directly to groups of bulbs, but I’m genuinely worried that my criteria of “must always be able to operate its base function” will not be satisfied here; especially if it’s ability to stay connected to a Zigbee network is not near-perfect.

Quick question for you – is this in a non-neutral setup? I’ve actually never seen this happen, but my thought would be that this is in a non-neutral setup and it’s not quite getting the power it needs to work properly (usually when a bypass is not used).

As for the reverting back to a dumb switch, this is something we talked about and I’m not sure why we didn’t implement this feature, but I’ll check with the engineers. I feel like it was hard or not possible to implement.

There is a way to set it back to a dumb switch manually, however, if this happens again in the future.

Hold down on the top of the paddle, then tap the config button 3x (while still holding the top of the paddle) and then release both – the LED Bar should flash red indicating it’s in On/Off mode.

But, what I think we need to address is the disconnection from your Zigbee network as this shouldn’t be happening.

Are these connected directly to your SkyConnect or are these on their own gateways and API’d in to Home Assistant?

Here are some other questions so I can better help diagnose this issue:

  • What does the date code say at the top left of your switch (under the faceplate at the top left of your switch there should be a four digit date code)?
  • About how far from the coordinator is your switch and are there any other Zigbee devices in between that are directly connected to the SkyConnect?

For the smart bulbs, what brand are you using?

Hang in there, we’ll figure it out.

I’m having this same issue, but the suggested reset does not take me back to having manual control. Here’s the story.

I connect my Blue 2-1 switches with the following settings:

  • FW version 2.14 connected to Z2M
  • Smart-bulb mode - Off
  • Local protection - On

My coordinator kicked the bucket. This leaves the switch sitting as-is and unable to pair with a new coordinator. I have found that when in local protection mode, it is not possible to initiate pairing, or do any of the manual configuration button presses. Essentially, it appears my 2 switches connected to that coordinator are bricked.

I’m hoping for a more aggressive reset that is like a hard reset or a manual way to turn local protection off. I have tried over a minute of Up+config, Up+3x config, and everything else I can think of. Air gap pulled several times, and it just stares at me waiting to connect back to a coordinator that doesn’t exist. I’ve got 7 of these switches working (except for crap signal strength) until this mess. These are the only two that were on that coordinator.

OK. I kept digging and found a single mention on this community of a Down and 10x config to take the switch out of local protection mode. Problem solved. I would not have had this issue or the 2 hour search for a solution if the documentation of the blue switches was up to date to include this info, and found in the same place as other documentation on the website (not here where everything gets lost).


I think there’s an update coming soon; bringing the old support pages back.