4-in-1 Sensor Battery Reading Stays At 100%


I have had the 4-in-1 Sensor connected to my Hubitat since February 6th, I am using the Hubitat driver, as supplied by Inovelli. My sensor is set to report as follows:

  • Luminance: 60 Seconds / Threshold:10
  • Humidity: 120 Seconds / Threshold: 2
  • Temperature: 300 Seconds / Threshold: 5
  • Battery: 7200 Seconds / Threshold: 1

Currently in Hubitat the sensor still shows as 100% battery. I feel like this must be inaccurate as I have changed the readings to be much more frequent that the stock settings, and it’s located in a room where there is frequently motion.

Has anyone else seen this? Is it a bug? Is it really just that good?

Hi Stephen. Yes, I am having the same issue and I have had my sensor running since mid-February and it’s still at 100%. I also have my reporting settings much more aggressive than default, in fact I am even reporting humidity every 60 seconds and battery every 2 minutes, just to see if I can get it to drop.

I opened a call with Inovelli about a week ago, but haven’t heard anything back yet.

Has anyone received an update to this? I just had a sensor stop working and the battery indicator still was reading 100% in Hubitat, yet the battery is dead now. I replaced with a new battery and we’re up and running again. @EricM_Inovelli Do you know why hubitat isn’t getting proper battery reads on the 4-1 sensors?

My 4-N-1 shows battery level at 85% (verified last night).

A few months ago I updated my driver to the latest one from Inovelli and my battery started working again. Quite the substantial drop compared to the 100 percent but assumed it was accurate. I have no way to confirm if true.

The change didn’t happen right away, it took a day or so to show a new number.

Which driver are you using? The standard one that Hubitat has in it’s list or the custom one that Inovelli provides: https://raw.githubusercontent.com/InovelliUSA/Hubitat/master/Drivers/inovelli-4-in-1-sensor.src/inovelli-4-in-1-sensor.groovy

I’m using the latter and my battery states have never changed.

I’m using the latest Inovelli driver.

That inovelli github driver is the one I’m using. The notes in the driver have multiple updates since I originally made this post, one of which includes

“2020-06-24: Requesting battery report on every wake up.”

I’m unsure if this is the reason, however, all of my sensors began reporting less than 100 percent (I have three) after updating my custom driver to this one. It did take a day or two after applying the driver update.

Also as an FYI, I did try setting one to the Hubitat built in driver and still had 100 percent reading. It was only when I changed it to this updated driver that it showed less than 100 percent.

1 Like

Very strange. I’ve been using the github driver since I installed these months ago and it’s been updated with all the new changes over time. However my batteries have never shown anything less than 100. Do you know what firmware your 4-in-1 sensors are using? Should say in hubitat device page. Mine are reading 2.03…wondering if I need to update firmware?

Mine are also 2.03

Every time the device wakes up the driver requests a battery update. You might want to check the logs to see if that is happening. I think the device is setup to wake every 12 or 24 hours.

The logs for all 3 only show them capturing motion, but not reporting battery.

Do your logs go back a period of 24Hrs +. There should also be a line that says something like “the device woke up”. The battery report should only show up every 12 or every 24 hours (I can’t remember which).

I noticed that my sensors are also showing 100% still (one of them has been running for 9 months now). Here are my observations:

  • Sensor Report Method (Parameter 110): Always
  • Battery Level Read Interval (Parameter 104): 60 (I confirmed that the parameter value was sent/saved successfully)

I had changed the battery report interval to 60 seconds in order to see if the device was actually sending the Battery Report when it was supposed to (it was previously set to 24 hours, but I didnt want to wait that long for testing). However, I noticed that the device was NOT sending the Battery Reports. If I manually send a Battery Get command, the device responds with a battery level 0x64 (100%). Measured battery voltage was 3.01v. Since the CR123A battery voltage range is typically 2.0v - 3.2v, I was not expecting to see 100% (I am not sure how the device calculated battery level though)

Since the device did not appear to be sending reports at the scheduled interval (potential known issue here), I decided to update to the Beta firmware.

After updating to Beta, the reporting interval issue appears to be fixed, but the device is still reporting 100% battery.

I installed in May this year and the three sensors have 1 battery reading the first time they paired and have never given an update. Logs show that

@jws6 Do you mean in the event list (rather than the log)? Hubitat will not show duplicate entries in the event list. For example, if you got a report of 100% when you include it and every day the device sends a report of 100% for 4 weeks, the event list will only show the first.

@EricM_Inovelli I checked the logs. Doesn’t appear that I’m getting reporting for 2 of the sensors. The only one showing battery updates is the one that I just replaced the battery about a week ago (and it says 100%).

Are you seeing any “WakeUp” log entries?

dev:4222020-11-06 12:04:36.101 pm infoInovelli 4-in-1 Sensor: Battery report received: 100
dev:4222020-11-06 12:04:36.099 pm debugInovelli 4-in-1 Sensor: BatteryReport(batteryLevel:100)
dev:4222020-11-06 12:04:35.079 pm infoInovelli 4-in-1 Sensor: Requesting battery report
dev:4222020-11-06 12:04:35.036 pm infoInovelli 4-in-1 Sensor: There are no association actions to complete for group 1
dev:4222020-11-06 12:04:35.026 pm infoInovelli 4-in-1 Sensor: initialize()
dev:4222020-11-06 12:04:35.024 pm infoInovelli 4-in-1 Sensor: WakeUp Notification received
dev:4222020-11-06 12:04:35.023 pm debugInovelli 4-in-1 Sensor: WakeUpNotification()

Also, make sure all the logging options are enabled.

@EricM_Inovelli - Changing all the parameters per your suggestion…the disable info logging was set to 30 by default so that one may have been the cause. I also updated one of my sensors to the beta firmware to see if that makes a difference. Will report back.