Black Series Scene Control with Home Assistant (HA) (migrating from SmartThings)

After experiencing the proverbial last straw with SmartThings, I’m going down the rabbit hole and transitioning to the dark side - Home Assistant :). So I am back at square 1 - learning the HA platform. I have Home Assistant OS (I believe that’s what it’s called -installed on a RPi4 using the SDCard image), and a Zooz ZST10 700 series stick. I was able to add one of my red series on/off switches fairly easily. I added the blueprint for the red series on/off switch to help with scene control.

So now I’m on to prepping for my numerous black series dimmers (LZW31). I was using the LZW31 dimmer with SmartThings with the latest firmware which added basic scene control. So now that I’m moving to HA, I’d like to disable local protection (that’s a whole other thing to figure out) and add button press and held events so I can control some smart lights (Wiz lights). I was doing this fine in ST (when ST behaved) and would like to do the same in HA.

I searched and I don’t think anyone has created a HA blueprint for the LZW31 - probably it won’t ever get created since it’s a discontinued product. Being a HA newbie now how does one do this? I do I tie the button press and held events to an automation?

Please forgive misuse of terms, I’m still learning HA.

Thanks folks!

1 Like

I can’t answer your specific questions right now, as I am also just starting a migration to HA. I made an emergency purchase of a Hubitat hub when I sensed that Wink corporate was about to implode a few years ago. My time using Hubitat was OK, but I am really frustrated with their change control and QA/QC lately. The last update release was followed by over a dozen emergency builds to fix simple bugs that should have been caught in the pre-release testing. I’m using our holiday break from work to install HAos and test/learn it.

My only Z-Wave device on HA at the moment is an LZW45 bulb, to see if the Z-Wave USB stick and HA protocol stack are stable. I have moved a few of my devices over to HA, including AlarmDecoder and all of my HomeKit presence automations. The last thing that I plan to move over are my LZW30-SN’s and LZW36’s, because I have way too many multi-tap automations that we use every day to re-implement in HA right now.

Anyway, just letting you know that someone else is also going down the HA rabbit hole, and frustrated with the obsolete docs and terminology differences…

1 Like

I hear ya although I guess I’m surprised to hear that about Hubitat - I thought it was a better version of ST (i.e. the simplicity of ST but local control). ST pretty much pushed me over the edge with frequent outages, sluggishness and network blips (i.e. hit a button, nothing happens, hit it again, it works - look at logs, some java exception occured in the cloud…) All the youtube clips I’ve watched about HA being steep in the up front learning curve is absolutely correct, but the payoff is pretty big once everything is defined and starts working together. I’ve already braced myself for a lot of late night tinkering sessions with this but I’m really looking forward to local control.

Hopefully the HA gurus here (you know who you are :slight_smile: ) can help us!

1 Like

It’s the same as the Red dimmer but you only get single presses and holds. There should be a Red dimmer blueprint you can use.

1 Like

Thanks, I read in a another forum that the red series blueprint didn’t select black series devices. I will try one tonight and see if it works, that would be great.

Welcome! I’m a former ST user as well. If you’re adventurous skip blueprints and go straight to nice red. There are several of us using various versions on HA. I’m using supervised version on Ubuntu.

You’re right, it won’t.

You could copy the blueprint and modify it for the Black dimmer. Post it on the HA forum for everyone and so that you can just import it or create a yaml file and save it in the blueprints directory of your HA install along side the other files.

I think this is the blueprint you want to start with,

I think if you install the editor they talk about here you can easily create the blueprint file in the right place. I don’t run HA that way, but I think this is the HASS Configurator that I run as a Docker container and it’s handy for modifying files.

Copy the text from the blueprint then go to the editor and create a new file in the blueprints directory. Make sure the file name has .yaml as the extension. Forgetting the extension has bit me a few times. Paste the text in, change the description stuff, delete the 2x and up parts and change the model. You should be able to read it easily enough to know how to edit it.

BUT even simpler, if you install the editor just open the " LZW31-SN_Dimmer_Scenes.yaml" file and delete or comment out the line “model: LZW31-SN”. Then you can select any Inovelli device. Just use that knowing the limitation of the devices you can select. You have to restart HA for the change to take effect.

If you decide to go Node Red and you follow the link @stu1811 posted, don’t use that subflow. Use the pallette to get the Inovelli nodes as given in the solution link.

I’m a fairly new HA user. I’m no guru, but I think I might be approaching minimal competency. It’s really pretty simple to create an automaton from scratch that detects scene events from Inovelli dimmers without using blueprints.

I don’t have Black devices, so I can’t give specific help, but I’ll attach a screenshot of an automation that is triggered by a Red dimmer scene event for reference. In this case, a double-tap up on one of two dimmers turns on another light. It might point you in the right direction.

Expand to see the screenshot (It's kinda long, and I didn't want to take up too much space.)

One useful tool in determining what trigger details are being sent is the events option under the developer tools menu. Start listening to “*” (without quotes) and then trigger the event on the switch. You’ll see the actual event that is sent to HA, so you’ll know what central scene and value you need to use in your trigger.

Hope that helps get you started.


All great suggestions so far! It’s worth mentioning that I was able to get one of my red series on/off switches in HA, disable local control (using 8x tap on config button), and then assign scenes for on/off of the WIZ lights it controls. It works GREAT. I used the blueprint for the red series on/off. Super zippy and I am glad EVERYTHING is all local (even the WIZ light integration is local - need to go send the dev who integrated it into HA some $$ - he did an awesome job).

So now I tried one of my black series dimmers - interesting it’s allowing me to use the red series on/off blueprint with it, I assigned button press 1x to a scene but nothing happens (I didn’t have much hope but I had to try).

@magicalbrad excellent suggestion of looking at the events (thanks I learned something here) but I appear to have a chicken/egg problem. I don’t get any events for the press/held events, I suspect I can only see events if it’s been configured in an automation. @magicalbrad looks like you’re using a raw automation (no blueprint) which looks like the way to go at the moment.

So right now it might be attempting to use one of the scene controls and the 1x press (just trying to turn on). See screen shot of the options - I’ve tried all 3 and nothign happens. So I’m missing something but feel like I’m getting close…I know this works with this switch as I had it configured in SmartThings. I feel like we had this discussion about the HA button codes (therefore someone has figured it out already) for the black series dimmer firmware update (1.52) - I can’t seem to find where it was discussed though.

The event listener should be able show you every event HA receives, regardless as to whether or not it’s being used anywhere. As I don’t have Black dimmers, I’d just be guessing as to what events should be triggered or why they’re not showing up for you.

FWIW: I may be able point you in the direction of enabling/disabling local control through HA, rather than all the config button clicking. In zwave2mqtt–which I believe you’re using–expand the dimmer’s entry and look for the “protection” section. In there you can change the “Local protection state” setting. (At least that’s how it works for Red Dimmers.)

Well, might as well check that zwaveJS2MQTT is working. Go there and expand the dimmer line and then the central scene line. Click on the dimmer paddle and see if the undefined switches to the button press or button hold. It only switches momentarily then goes back to undefined.

Thanks for the central scene section tip. I tested it out on my working red series on/off switch and like you stated, I see the events popping in on the various scenes (press 1x, press 2x, etc. etc.). I switched over to my black series dimmer and nothing. Hmm…Is there a scene control enable/disable parameter possible (just grasping at the moment)…

So progress (for the most part). I think part of my issue was pilot error - I had “Local protection state” set to 2 - NoOperationPossible and I think SmartBulb mode off. This is what you’re supposed to do with Red Series since there’s no formal SmartBulb mode (and I was always getting confused in ST b/w black series and red series configs). Anyway I set Smart Bulb mode to Enabled and Local Protection to ProtectedBySequence (which I have no idea what that means ,other than I think this is the parameter to Disable Local Control). At this point I was now getting the events to fire in the events viewer and central scene debugging.

I was able to set the scene and the button presses come through and set them up in a raw automation and it works! Kinda ;). This switch is also a 3-way switch with a GE Aux. I do remember having quirky issues with 3 way and this black series dimmer in smart bulb mode (like it seemed like it would work and then days later I would have to hit the main switch before the aux switch would work again) - If I set to non-smart bulb mode and unprotected it looks like it works as it should from the master and aux paddles. The aux 3 way paddle doesn’t seem to do anything. I think this is where I’m confused on the various mode (I have other 3 ways but they are on red series and they work fine with smart bulbs in ST at the moment - well when ST isn’t foobar’d).

Anyway I think I’m left with just fiddling with the config options to see if I can jiggle the handle to get 3 way working. I’m happy at the moment as I at least have the main black series dimmer switch in this config work. I’ve included the screen shots of what I tweaked (and when I need to come back later and try to figure out how to do this all over again lol).

Odd. I didn’t do any of that and have the scenes working on a black dimmer. The only changes I made were switching to neutral and changing the led bar color and the ramp and dim times.

I’ve never tried an aux with a black dimmer. What are you trying to achieve? You want the dimmer to stay on at 100% output all the time and the aux to do what exactly??

I do know the aux switches don’t cause scenes.

Are yiu running firmware 1.52? I’m wondering if it’s the switch now. Actually I have a few other black series dimmers (still on smartthings) and they work fine with dmart bulbs.

Does anyone know the values for parameter 22 (set the switch type). I think I remember having an issue having to set the 3 way switch type to momentary vs toggle.

Basically I am trying to use the black series dimmer just like a regular on/off switch (yes I know it’s a dimmer, I got them with the hope of being to control the dim levels of smart bulbs, I’ve given up on that for now and just want to use it as an on/off for smart bulbs via scene control). Now I had this 3 way config with the GE aux switch working in ST (firmware 1.52, smart bulb mode enabled, disable local control set to No). I’ve now brought a second black series dimmer in
the same 3 way config - was working in ST and in HA only the main black series switch works with scene control and the aux switch is not responding.

Does anyone have black series dimmers working in a 3 way in HA? Apparently the issue is in software and some parameter got reset when I included it.

What a PITA

I think the original issue of scene control with a black series dimmer in HA is solved and works great. My other issue with 3-way setup for smart bulbs (being able to trigger the 1x up/down from the aux) is pretty much a wrap. After reading every post here directly or indirectly related to 3-way configs, it doesn’t appear to be a supported configuration (at least in HA). I’m irked that it was working in ST with the same switches and in HA it’s not. Anyway, I’ve been meaning to right size my switches anyway and will be pulling all my black series switches off of anything with smart bulbs and putting in red series on/offs (and moving those black series somewhere else with non-smart bulbs where they should work just fine).

Maybe this will help someone else save time and materials (I wouldn’t have bothered with the GE aux switches had I known and just bought an extra smart switch and put in a virtual 3 way config).

I’m still happy with the power of HA though and it’s solved a lot of my original problems…


None of the switches support scenes from an aux switch, so it could not have worked on any platform. Switching to a Red won’t fix the issue you’re having either.

When you set smart bulb mode you can turn the dimmer on and off with single up and down taps via the aux switch. That can be captured. You can also dim it and capture the new dim level. None of these require using automations. All of those actions cause the led bar and what is in HA to show the changes, but the output stays full on.

Here is an example of how you get the dimmer level changing to another device.

@PJF thank you for this! I didn’t realize that scenes don’t trigger from the aux button (I thought that the aux paddle up/down event was detected by the smart switch and in turn triggered the scene). I guess I was stuck on scenes being triggered from the aux paddles b/c as I mentioned this seemed to work in ST. Possibly the ST device handler was doing some voodoo underneath. Anyway, I then considered your service yaml to detect brightness state change. Since I am only on day 3 of my HA adventure I haven’t gotten to services yet :slight_smile: but it did prompt me to look at state changes in an automation. I noticed that my automation (say my lights on automation) would trigger on any state change in brightness (I have my ramp rates on my black series switch set to ramp up/down to 255/0 instantly). I couldn’t add a condition or trigger that detected brightness level at 255 or 0 - I am assuming that should work and I’m not understanding how to do it properly. This was progress though.

After just really what amounted to trying different types of triggers, I noticed that the “Light On” and “Light Off” triggers actually worked. I thought these wouldn’t work in smart bulb mode enabled or local relay disabled. Seems like those events are still registered and I can trigger on them. So it turns out it’s actually simple to do (or one of those $1 to hit the nail and $4999 to know how to hit the nail things…).

So now my black series dimmer switch and the accompanying GE AUX switch turns on/off my WIZ smart lights very nicely and it’s fairly quick too.

Thank You guys for sticking with me through this - 18 short hours later with the communities help, I got it to work :slight_smile:

(and I don’t have to swap these black series dimmers out!). Reed at Smart Home Solver (youtube) was absolutely right about HA - the emotional swing with HA is real - very big Highs and very deep Lows lol).

Much appreciated!

Glad you go it. HA has the problem that you can search and find about 5000 posts with ways to do something but most of them either don’t work or don’t do what you want.