Blue 2-1 "Wake" needed?

Hi there - setting up my new Blue series switches and am having some trouble getting my switches to respond lights as expected. Here’s the setup:

  • Home Assistant
  • Conbee II Zigbee Stick
  • MagicLight Wifi Bulb
  • Blue Series single pole with neutral wire

The switch is set to smart bulb mode and “disable relay click on off mode” is also enabled. I created an automation using a simple scene for the smart lightbulbs in the room triggered by “Up press”. Pressing up once seems to turn the switch on, but not trigger the scene. A second press triggers the scene and turns on the light.

Looking at the logs it seems that the “switch opening was opened” but a scene wasn’t triggered. I thought smart bulb mode would keep the opening open, is there another setting I’m missing so I don’t have to “wake” the switch to start a scene? Is it possible I didn’t install the switch correctly?

Thanks for any advice!

Quick question for ya - are you using ZHA or Zigbee2MQTT?

I’ve been using ZHA

Awesome, thank you. Is there a way you can share the automation at all?

I can try to help, but I’m not super well versed with Home Assistant. I at least wanted to get some preliminary data so others can hop in!

alias: Downstairs Bathroom Lights On
description: “”
trigger:

  • device_id: xxxxxxxxxxxxxxxxxxxxxxxxxxx
    domain: zha
    platform: device
    type: press
    subtype: Up
    condition: []
    action:
  • service: scene.turn_on
    target:
    entity_id: scene.downstairs_bathroom_lights_on
    metadata: {}
    mode: single

Thanks for taking a look! I’m still finagling with the settings and parameters and there must be a setting I’m missing.

A “failure” (ie. click up with no scene triggered) still says that the “switch opening was opened” and “switch light turned on”, but the event is never fired. On the second press, the zigbee event is fired and it performs as expected with the automation and scene. Trying to figure out how to bypass this “wake” - the logs are showing the opening open, so the connection to HA is still there, it just doesn’t seem to be sending the event trigger.

Awesome, and your post gave me a good reminder to fill in the directions for ZHA in the, “Scene Control” section… whoops!

This will give me a good chance to learn while I create the instructions :slight_smile:

@chack, @kreene1987 do you guys have any ideas with this ZHA setup?

1 Like

How much is going on in the scene to turn on those lights? What happens if you change the automation to just turn the lights on instead of turning on the scene? (I recognize this takes away the versatility of reusing scenes, etc, just something to check)

Otherwise, anything in the logs with a warning when you press it the first time? Mode=single won’t run if the automation is considered active.

Good question. Just tried and yielded the same result with trying to trigger the entities directly vs. the scene. The switch is opened by clicking the up button but the zigbee event “Up press” isn’t triggered. No warnings in the logs unfortunately, sharing screenshots of the logs so you can see the difference below:

Up Press 1:
Up Press 2:

The process seems to be:

  • Up press one:
    • Switch opening was opened
    • Switch light turned on (doesn’t actually turn on any lights, just “wakes” the switch and readies for an event)
  • Up press two:
    • Up press zigbee event fired
    • Scene triggered
    • Switch opening closed
    • Switch light turned off

Also not quite sure why firing the “up press” event a second time would close the switch opening. Is there a way to have the opening and light in an “always on” state? Maybe I’m misunderstanding what “switch opening” represents…

Images links didn’t seem to work, so re-posting:

Up press 1: https://imgur.com/a/bPNVDBA
Up press 2: https://imgur.com/a/69kLXYH

What version of HA are you on?

Also if you go into Developer Tools > Events > Listen to events > “*” > Start Listening and then click the button again, do you see anything on either the first or the second attempt?

For reference, it should look like (ignore the time difference, repeated events for comparison -
Logbook:
image

Events:
image

2 Likes

I upgraded to Home Assistant 2022.10.5 (OS 9.3) just last night, so hoping everything is up-to-date.

When I listened to events and subscribe to zha_event the first click yields no results, but the second click fires an event.

image

2 Likes

Is this only the case for ‘on’ or do you see the same when you press the config button or “off” ?

Same result unfortunately. Both the off and config buttons don’t trigger events until the on button is pushed once, then all buttons trigger events.

Adding screenshots of the switch settings if at all helpful (couldn’t get it to screenshot the whole page unfortunately…)





Not expecting it to be directly related, but just for confirmation…how are you running HA and what are you running it on? Also using an extension cable with the conbee II? Any other zigbee devices currently and if so do you have similar ‘lag/waking’ with those?

I’ll be getting my HA instance over to 2022.10.5 later today and have a prod blue set up to compare with on my end as well fyi.

Running HA on a Raspberry Pi (I know, not ideal and may eventually migrate to an old PC) and not currently using an extension cable, but the switch is only 6 ft away. I have 3 other zigbee devices (all Blue Series switches) connected. Currently experiencing a similar “lag” issue with the switches that are connected to smart bulbs. No lag with the switch connected to a regular bulb that’s not set to “smart bulb mode”.

I’m seeing HA respond and make logs on the initial “up press” to open the switch, so HA seems to be communicating with the switch on that first click, just not sending the desired zigbee event.

1 Like

The reason for the extension cable (especially with the Raspberry Pi) is you’ll actually get interference with the coordinator from the usb3 ports even if you aren’t plugged into one. I don’t think that’s what’s going on here, but you’ll likely get better Zigbee performance down the line by changing that.

So 4 Blue Series switches, 3 are set to smart bulb mode? And all of those experience the same issue, but the non smart bulb mode one sends events on the first press?

Roger that re the extension cable, seems like a good thing to invest in for the future.

Correct on all points in the second paragraph. All 3 set to smart bulb mode, all experiencing the same “lag” issue, non-smart bulb one is sending events on the first press.

1 Like

I misspoke: the up press on the non-smart bulb turns on the light (dumb light) but still doesn’t trigger a zigbee event. The light turns on because it’s a dumb light, but fails to trigger a scene.

Noted, in that case do you still get an event on the second press for that one?