Blue On/Off - Missing Events in ZHA / Remapping Relay

I recently received some Blue’s (yay!) and I’ve been trying to get them to work. I feel like I’m very close, but not quite there. I’m running Philips Hue bulbs off of various different circuits and Home Assistant with ZHA attached to a deCONZ Conbee II. I’d like to leave these bulbs associated with the Hue Hub for now, but may re-visit that later.

The first problem is that I want to map buttons on the switch to fire off zha_event’s to Home Assistant, I think the parlance here for this is “scenes”, but under the hood I’m using HA Automations to catch zha_events and respond accordingly. The most frequent issue I’ve noticed is that the switch seems to get stuck in states and decides not to fire off events. Sometimes when I press up, double up, or hold up I’ll get something like this in my logs:

2022-10-21 12:24:27.967 DEBUG (MainThread) [zigpy.zcl] [0x5177:2:0xfc31] Decoded ZCL frame: Inovelli_VZM31SN_Cluster:button_event(button_pressed=2, press_type=3)

Other times, I won’t get anything at all. When this happens, I can usually break out of it by hitting the opposite button, in this case button 1 (down), then I can repeat my previous button 2 action successfully. I feel like I shouldn’t have to toggle down+up or vice-versa to get these things to work.

The second, and less important issue, is that it would be nice if I could re-map the default on/off behavior that triggers the load relay to a different sequence (double, triple, hold, etc). My switch is well located to control hue lights on other circuits, AND also attached to an outlet that I could use it to control completely independent of the light situation.

What version of HA are you using?

Home Assistant 2022.10.4
Frontend 20221010.0 - latest
Basically only core inside a Docker container, not supervised.

1 Like

You should see the zha events come through naturally, as an example from monitoring all events so I made sure not to miss it -


I’m using the same setup, though back on 2022.9.4 (and a beta switch, not prod). You should see all of the trigger options available with scenes, Triggers > Add Trigger > Device, does this not show up? (edit, more than what’s shown too…up to 5x presses)


I believe I get the same behavior (missing events) whether I’m looking for the events naturally as you say, or through the debug logging that I turned on while troubleshooting.

I have those trigger options, I just switched to event based triggers while I was trying to get this to work. Neither seem to be 100% reliable.

edit: I can try to change my container to 2022.9.4 to see if it makes any difference.

Gotcha, those device trigger options are hitting the same events fwiw, just presented simpler for your benefit :slight_smile:

Is this happening on all of your switches or one in particular?

Edit - shouldn’t need to downgrade, I’m wondering what the cause is of the events not always coming through or seeming like they’re ‘sticking’ at times.

I’ve been waiting to get into switches, so this is the first and only one I’ve tested so far. I have others from the same order that I could swap out.

1 Like

So a few things to try I guess. First, you can hit “Reconfigure” from the device info page and see if that changes anything. Can also do a factory reset at the switch and then rejoin it (and can try reconfigure again).

If neither of those are working, maybe try a different switch and see if the behavior persists?

It’s not hard to downgrade, so I tried that… no change.

Reconfigure doesn’t pass and the results vary slightly on which bindings are failing each time I run it.

Factory reset, still had binding issues, tried reconfigure, no luck.

I can swap the switch out in a little while, I may also look at messing with the firmware on my Conbee II, but I tend not to mess with that once I get it working.

Reconfigure should be 100%, so noting that at least. I’ll be curious if you see a change with one of the others when you get a chance to swap it.

I swapped the switch out for another one that seemed to pair, but wasn’t working quite right so I reset it and now no matter what I do I can’t even get it to pair. Not sure where to go at this point.

I’m not going to be too much help here, but I’ll try my best :slight_smile:

A couple things you can try regarding getting it to pair would be to reboot HA, factory reset the switch again (wait for it to start pulsing blue) and then start the pairing process in HA.

I’m not sure how close/far you are from the Conbee, but I’ve noticed sometimes with Zigbee you have to be fairly close to the hub initially. I know in theory this shouldn’t be the case, but I could not, for the life of me, get my Philips Hue bulbs to pair with Hubitat the other day and had to bring them within 2 inches. Once they paired though, it worked great from far away.

1 Like

I am having a similar issue with zigbee2mqtt and home assistant. I setup an automation to trigger on a double up event to change the color, and have only gotten it to work twice out of the probably 100 times I’ve tried. Still unable to figure out a pattern to when it works.

I tried parsing the messages in NodeRed, to figure out what value in the message changed for a button event, but every time it tried the messages were the same (except for message ID, time, etc…).

Do you have button delay set? Try something very slow like 900ms to start

I put a few more switches in (I’m up to 3 now), hoping that maybe they’d help form a stronger mesh together. It took a good bit of trial and error to get them paired, but they seem like they’re in a good state.

I’m still getting flaky behavior though. It seems like the link quality / RSSI isn’t great. I don’t have problems with any of my other Zigbee devices and I’m not sure at this point how I could improve the link quality.

edit: I feel like I should clarify that regardless of link quality, I still get stuck in these states where the switch simply will not fire events until I hit the opposite button. For example, it doesn’t matter how many times I press up, nothing happens until I press down and then up.

I’m not sure if what I’m experiencing is the same thing but I’m having some sort of “random” behavior too. First issue was having a hell of a time pairing. Multiple reboots, resets, etc would not help. Controller was 10ft away behind one wall. I finally moved my controller about 3 feet and it suddenly paired.

Even after pairing I’m seeing a lot of wonky issues with the “action” events (multi-taps, config taps). I’ll come into the room try all my multi-tap and config button automations and they just won’t work at all. I’ll do the normal light switch a couple times and trigger the switch normally in Home Assistant, then the actions/events will suddenly work flawlessly.

It’s so hard because I keep questioning if it’s my controller, Z2M, or the switch.

When it’s not working, are you seeing the events in HA?

I think I’m seeing similar behavior. I’ll toggle the switch up/down a bit, then it’s like it wakes up and starts working normally. When it gets like this I do not see events in HA until it suddenly wakes up (I have no idea if these have some sort of low power standby mode, just guessing).

Unrelated, I’ve noticed if you disable the relay click that some current seems to leak through to the load side when the switch is “off”. Not sure if this is intended.

Ok, so in my Kitchen I have 2 switches setup in a 3-way arrangement. The documentation doesn’t make it clear if one or both of them should be set to 3-way AUX, but I have them both set to that at the moment. After I grouped these switches in HA, it created a new device called dresden elektronik RaspBee II Kitchen light switches_zha_group_0x0003. Whenever I press up or down on either of these switches, I am now getting consistent events that I can trigger my smart bulbs off of (yay!).

Now I just need to figure out how to make single pole switches do something like this. Since I have a motion sensor in the kitchen, I did notice that I need to fire zha_group_0x0003 events whenever the motion sensor changed the light state, otherwise the wall switches seemed to get upset, which supports my theory that they will not send events for states that they already think they are in (ex. if the switch thinks it’s off, but the lights are on because of motion sense, pressing off on the switch does not work).

I started tracking RSSI from some of my switches. One is fairly consistent, with periodic boosts, the other is all over the place.

As in you have two Blue Series installed in a 3 way setup? You shouldn’t be using 3-way AUX. 3-Way AUX is used for a single Blue Series with one or more aux switches (white series or eqiv). If you’re using two Blues, then you should have only one wired with the load and the other without the load (line/neutral required). Then you bind the switches together.

1 Like