Blue Series 2-1 Firmware Changelog | VZM31-SN

If we pair to another controller to update firmware and then pair back to the main controller, do we have to set up bindings and/or automations again?

I am still testing a few alternatives. I’ve got some coming today that are really cheap and a large stock of and I am hoping I can get them to work. This is the one of them that I have used: Baluue USB JTAG Programmer Boundary Scan Equipment USB JTAG Emulator JTAG Emulator ARM Emulator Emulator Programmer Debugger Programmer V9 ARM Scan Tool Efficient JTAG Emulator : Electronics

The key is that they need to support jlink v9 or higher.

I’d say a Zigbee dongle and zigbee2mqtt is a good option. You can just run the z2m container independent of everything else. It has a web interface and everything.

@avi The short answer is that you don’t need to recreate all of your automations and possibly bindings. In the ST driver there is an option toward the bottom that says “Re-send all configuration”. After you factory reset the device, add it to the other network to update it, and then re-add it back to ST, you enable that setting. It sends all of your configuration options to the switch and recreates any bindings you had setup.


That’s my home setup in a nutshell. I use a Sonoff Zigbee Dongle Plus, with zigbee2mqtt and NO Home Assistant (I prefer Node-Red for automation). I do have HA running on a separate Pi box, but that’s more for fiddling around… it’s not “in charge” of anything. I find that the z2m web interface is reasonably full-featured, although there are areas where it could improve. No issues with reliability, though… quite the opposite. Stand-alone z2m (and ZwaveJS-UI on the same box) are far, far more reliable than what I had with my previous setup (popular proprietary solution that many here are still using, so I don’t want to bad-mouth it)


I don’t see a reason why it wouldn’t work. I’ll try it out and post the results. Tag me if i forget.

1 Like

@mamber Zigbee2MQTT requires an MQTT server to be running. Either point the config to an existing server or temporarily startup one. I followed these instructions to start an mqtt server and zigbee2mqtt on a linux machine via docker-compose. Once z2m is started pair the switch and then go to the OTA tab and check for updates.

1 Like

5 posts were split to a new topic: Zigbee2MQTT Recommendation

Can confirm. I run 2 instances of Z2M. 1 using the HA Add-On. And the second in an LXC container on my home server. If HA is down when I startup the server, the LXC version of Z2M will not boot. Once HA is up and running I need to reboot the LXC container.

Now it should be theoretically possible to use Z2M directly with Hubitat since HE is capable of sending and receiving MQTT messages. Somebody would just need to write an app to interpret the messages in a way that HE can make use of it. It should also be theoretically possible to use ZwaveJS with HE as well.


Has anyone experienced this issue on Hubitat or is it isolated to Home Assistant?

Unfortunately (or fortunately) I haven’t gotten around to installing most of my 40+ Blue switches and I’m wondering if I might be better served by waiting and going with Reds instead. Zwave is what I really wanted to begin with (for exactly these types of routing issues that are present in a lot of Zigbee products) but I got impatient and jumped on the Blue pre-orders because nothing better was available.

Zigbee is going to be best going forward.
Z-wave isn’t problem-free either.

I haven’t seen any reports, but I would imagine the same issue exists as I experience this on SmartThings (just didn’t have all the fancy tools to diagnose it).

I do anticipate this being fixed with the next release and the good news is that I can personally tell if the fix is working.

Regarding swapping out for Z-Wave, we can certainly work something out if need be. But I can say confidently that I will continue to use Blue Series in my house exclusively (aside from a couple strategically placed Red Series switches for my Z-Wave locks/garage door opener) so hopefully that alleviates some of the concerns you have.


Do you know when 2.11 will be released?

We are waiting until we test 2.12 which has all of the network issues hopefully fixed. I’m hoping to get the firmware this week, but we haven’t received anything from the manufacturer yet.

After 2.12 is tested, I think we will release it as there doesn’t seem to be any other issues outside what’s been fixed in prior versions.

I’ll continue to update everyone once I test it for a week or so. I want to make sure I’m not seeing a lot of the network congestion and binding issues over normal use.

Edit: My best guess would be in 2 weeks if all goes well.


Does this also include a fix for default level local for group bindings? Because that has never worked.i set 100 and it just turns the light on but not turn the lights on to 100%, it turns it on to the previous brightness setting. It doesn’t send a brightness command. (Home assistant and my switches are on 2.08)

1 Like

The default level sound similar to the problem I have with remote level. Firmware bug: defaultLevelRemote does not work

1 Like

Not sure honestly – @EricM_Inovelli has this been captured?

It has never worked since I got the switches from the factory firmware to all the updates since.

We just got 2.12! I’m currently flashing all 30+ switches. Should be a fun night!


How’s that flash on ST?

Working as well as the mobile presence is in Hubitat. :yum:

How’d the flash go? Any prelim experiences on reset issue? Thanks for sharing Eric!

1 Like