Blue Series 2-1 Firmware Changelog | VZM31-SN

The new formatting is much easier to read. Thanks for making that change!


Look forward to it – thank you, Eric!!

Happy to report that the 5 Blues I have online are still behaving well on Hubitat with 2.05 – I had that one instance of unsolicited bindings on one switch after installing 2.05, but after I factory-reset and re-paired it, it’s been behaving since.

I’m confident 2.07 will help even more - thank you again!

  • Fix the wrong destination endpoint used when sending some commands.

Is this the one that fixes the tap events not showing up?

Thanks for all your hard work on the firmware!

Yes, we believe the wrong destination endpoint was causing this and it is addressed in 2.07.

FYI, I did just flip the switch for ZHA & Z2M.


Can confirm 2.07 fixed the groups issue using ZHA.


For those of you who did the update in Z2M but are still seeing the “old” firmware, it appears to be a Z2M bug (maybe related to this, or this issue). Z2M keeps a cache of the firmware and doesn’t seem to always update it after the firmware update applies.

If you want to verify what firmware your device has, go over to the dev console for the device and send a genBasic message with the swBuildId attribute and you’ll see the real firmware version.


Yeah, looks like it fixed the issues I was having!

1 Like

Odd, when I updated to 2.06 it still reflected 2.05 in the z2m UI. Now that you’ve pushed 2.07, after update I see 2.06 in the UI. Confirmed by reading the swBuildId from the dev console:


Am I missing something? Seems like my z2m is 1 release behind for some reason…

Firmware 2.07 fixed the issues I was having with actions (button presses) not being sent consistently.
However now it has created an issue where it does not control zigbee groups it has been bind to. Individual bind lights work as expected.

I have the switches setup like in the video and it worked previously.

I’m on HA using z2m.

1 Like

Hello, I have 4 switches using Z2M in HA. I initiated the ‘check for news updates’ for all 4 switches and it looks like 3 of 4 are on 2.07. However, I have one switch that’s “stuck” on 2.00. When I check for an update now on that switch it says it’s checking for an update but then it says there’s no new update.

I saw a comment above about restarting the device via the cluster, but I’m not sure if that’s applicable to my use case or how to perform this action. I tried restarting Z2M but that didn’t fix this issue.

Anyone have a tip on how to fix this?

@epow Interesting. I can confirm I also wasn’t able to auto update to 2.07 (HA + ZHA), so I downloaded the file and did it manually.

@mike789 I can also confirm that I can’t seem to control a Zigbee group from my switch on 2.07.

So far I seem to consistently be getting ZHA events, so I’m much happier with this firmware.

On a separate note outside my previous issue, I’m also experiencing this same issue with 2.07 as well when it comes to group binding. I can see the switch binding set up properly it’s just no longer working; which really stinks because 3 out of 4 of my switches are in smart bulb mode to only control certain hue lights I’ve binded to the switch.

I’m seeing the same issue. I wrote a Z2M bug report. ZHa reported the correct firmware version.


Reporting that l am also unable to control bound groups on 2.0.7. I even tried recreating the groups and bindings. If it matters, I use z2m and my group consists of one switch and two Phillips Hue downlight retrofits.

Same - control of bound groups no longer working on 2.0.7, neither via switch nor software, with Home Assistant ZHA and Sylvania/Ledvance bulbs.

Same here. How can we roll back?

1 Like

Instead of rolling back you can bind to individual lights as a temporary work around. Overall this firmware is better as actions are working consistently now.

Individual binding works - Have to remember to check OnOff cluster along with LevelCtrl.

zigbee2mqtt. Sengled bulbs.
Switch on 2.07 - actions are working great though.

Not to pile on - but I see the exact same behavior - I can no longer control groups that my switch is bound to.

I did have to do a similar thing as mentioned - bind to each individual light - but I would really prefer to move back to the group with a firmware fix :slight_smile:

Individual binding worked for me. Wow, these are SO GOOD now!