Blue Series 2-1 Firmware Changelog | VZM31-SN

@hydro311 The issue may be related to a “group” bug or an invalid endpoint bug that we are working on right now. Should have a firmware update in the next few days for these bugs.


I’m seeing this behavior between Inovelli 2-1 Blue Series devices. I installed three dimmers within a few minutes of each other and a fourth dimmer 24 hours prior. That fourth dimmer has not found its distant cousin as of yet. But the three I installed nearly at the same time found each other within about 10 minutes. I cannot separate them at all no matter what I try including using the unbind function in the Zigbee Binding User App (Hubitat). These three dimmers also behave as though they are one dimmer when using the button controls on the devices. See here for more: Blue Series: Hubitat Zigbee Group Behavior - #15 by rpulivella

1 Like

Hey @EricM_Inovelli,

A quick thought on formatting the change log. It might be easier to read if you reversed the order so that the newest was always on top. This is similar to how github shows releases.


Thank you, @EricM_Inovelli ! I’m just very happy it’s not considered a “closed case” quite yet – that’s great!

I had 5 good (04: and 94:DE) switches to bring back online (the firmware update on Hubitat worked like a champ!) – I did that late yesterday afternoon.

Several hours later, one of the switches had bound itself to a few Innr 224 plugs and a Leviton plug-in zigbee dimmer. I factory-reset that switch and re-paired it late last night, and so far so good this morning… No unsolicited binding on any of the 5 switches overnight, so your initial fix definitely helped – hopefully, this next one will squash it once & for all.

Thanks again for the help and responsiveness – I know you guys are in a war-time cadence right now dealing with everything, and we all appreciate your hard work to get it all done right!


Good suggestion on the changelog. It would be good to see newest version first and each version includes:

  • version number
  • date of release
  • list of changes/fixes/features

One additional thing, post on this thread that a new version is available. I don’t get notifications when a post in a thread is updated (unless there’s another/better way to get notified).


Thanks for the suggestions. I will make some changes with the next release.


I’m going to be pushing this to ZHA & Z2M in the morning. If all goes well I will send it to Hubitat.

November 8, 2022 / v2.07 / 0x01020207

  • Remove the sending of multicast commands to avoid switches that would accidentally control other devices within a group.
  • Fix the wrong destination endpoint used when sending some commands.

The new formatting is much easier to read. Thanks for making that change!


Look forward to it – thank you, Eric!!

Happy to report that the 5 Blues I have online are still behaving well on Hubitat with 2.05 – I had that one instance of unsolicited bindings on one switch after installing 2.05, but after I factory-reset and re-paired it, it’s been behaving since.

I’m confident 2.07 will help even more - thank you again!

  • Fix the wrong destination endpoint used when sending some commands.

Is this the one that fixes the tap events not showing up?

Thanks for all your hard work on the firmware!

Yes, we believe the wrong destination endpoint was causing this and it is addressed in 2.07.

FYI, I did just flip the switch for ZHA & Z2M.


Can confirm 2.07 fixed the groups issue using ZHA.


For those of you who did the update in Z2M but are still seeing the “old” firmware, it appears to be a Z2M bug (maybe related to this, or this issue). Z2M keeps a cache of the firmware and doesn’t seem to always update it after the firmware update applies.

If you want to verify what firmware your device has, go over to the dev console for the device and send a genBasic message with the swBuildId attribute and you’ll see the real firmware version.


Yeah, looks like it fixed the issues I was having!

1 Like

Odd, when I updated to 2.06 it still reflected 2.05 in the z2m UI. Now that you’ve pushed 2.07, after update I see 2.06 in the UI. Confirmed by reading the swBuildId from the dev console:


Am I missing something? Seems like my z2m is 1 release behind for some reason…

Firmware 2.07 fixed the issues I was having with actions (button presses) not being sent consistently.
However now it has created an issue where it does not control zigbee groups it has been bind to. Individual bind lights work as expected.

I have the switches setup like in the video and it worked previously.

I’m on HA using z2m.

1 Like

Hello, I have 4 switches using Z2M in HA. I initiated the ‘check for news updates’ for all 4 switches and it looks like 3 of 4 are on 2.07. However, I have one switch that’s “stuck” on 2.00. When I check for an update now on that switch it says it’s checking for an update but then it says there’s no new update.

I saw a comment above about restarting the device via the cluster, but I’m not sure if that’s applicable to my use case or how to perform this action. I tried restarting Z2M but that didn’t fix this issue.

Anyone have a tip on how to fix this?

@epow Interesting. I can confirm I also wasn’t able to auto update to 2.07 (HA + ZHA), so I downloaded the file and did it manually.

@mike789 I can also confirm that I can’t seem to control a Zigbee group from my switch on 2.07.

So far I seem to consistently be getting ZHA events, so I’m much happier with this firmware.

On a separate note outside my previous issue, I’m also experiencing this same issue with 2.07 as well when it comes to group binding. I can see the switch binding set up properly it’s just no longer working; which really stinks because 3 out of 4 of my switches are in smart bulb mode to only control certain hue lights I’ve binded to the switch.

I’m seeing the same issue. I wrote a Z2M bug report. ZHa reported the correct firmware version.