Blue Series 2-1 Firmware Changelog | VZM31-SN

That’s a question for ha discord in the ZigBee channel.

I’m curious too as my switches didn’t update yet but I didn’t manually request the update either yet. Waiting to update to 2023.4.3

Yes, that is the correct definition.


let me know if this looks right

Of course not. But what if I’m really hungry and eat the cardboard packaging while waiting for the update to complete? Could happen.

Seriously, thanks. Can’t wait to start installing these switches this weekend.

Looks correct to me - all param IDs and data types match what @EricM_Inovelli provided.

Mine (attempted to) auto update two days ago, but I just saw Inovelli OTA URL Changes by codyhackw · Pull Request #1159 · zigpy/zigpy · GitHub , which is a change from a few months ago that changed the URL for the Inovelli update JSON. I’m still running HA/ZHA from November 2022, so it’s checking the old URL that has 2.14, rather than the new one that’s only at 2.08.

BTW, I was having trouble getting my switches to update, but got it working by pulling the air gap on about half of my switches and letting it try overnight. I don’t know whether it was reducing the number of switches or just letting it try for several hours (or if both were needed) that ended up working–I still saw failures when only half the switches were on the network, where the switch would show the flashing green progress, then after like 30 minutes, three quick red flashes. It does seem like ZHA should stagger the updates instead of trying to update every switch simultaneously.

In any case, I love the new firmware so far! As I had mentioned in another thread, my main gripe was that even at the lowest dimming level, some of my lights were still fairly bright. Now, those lights are really dim at about 9% and cut off completely at 7 or 8% (so I’ll probably set the minimum dimming parameter now). Thanks to the Inovelli team!


I’ll make sure to add that to the disclaimer next time :rofl:

1 Like

Just to keep the community up to date, the PRs required to make this work on Zigbee2MQTT have been posted. We’re now in the hands of the maintainers to get these merged.


Has this update been pushed here?

Just a note for Hubitat people… I had an issue on C-8 where the switch would complete the firmware upgrade, but not refresh and would eventually be either non-responsive or questionably responsive. Running a Zigbee Network rebuild would resolve the issues. Not sure if its a C-8 issue, a me issue, or a switch issue…

Just been doing them in batches and then rebuilding the network, and refreshing them.

The firmware update is great. From flickering LED lights where dimmed to not noticing it or eliminating it completely! Wife is happy. Now I have to replace all the LED switches with updated Blues… Bye bye Zooz switches (bought when Inovelli ones we’re available), guess I’ll put them on the few bulb based fixtures that don’t matter.


I’ve flashed 30 blue series (each took 4-6 mins to flash…way better than 30) and haven’t encountered an issue as you described with a C7 hub. I believe @SViel had some inclusion issues after an upgrade on his C8, but I believe that may be a Hubitat software problem.

1 Like

I might pull my C7 out and see if I have the same issue.

1 Like

I am indeed having an issue pairing a switch on the C-8. Works for me on the C-5 though. Still under investigation…

Otherwise, updating the firmware of two of my switches has worked great.

What coordinator device are you using? It’s recommended to use a Texas Instruments coordinator such as the SONOFF Zigbee 3.0 P-Series (NOT THE E SERIES)

Also: Make sure you’re running the latest firmware on your coordinator device.

Tbh, I haven’t had much luck with anything else. Most other coordinators (and I have 16 here I’ve tested), are just not stable on larger networks or networks with Inovelli devices.

Could be too far from the Hub or could be the switch isn’t ready to pair even though it shows it is.

Do this:
1.) Perform a reset on the switch itself.
2.) Once it starts flashing in pairing mode, pull the airgap out to kill power to the switch.
3.) On Hubitat, start the pairing process.
4.) Immediately after, push air gap in.
5.) You’ll have a 99.9% chance it will pair without issue.

Hope that helps. :slight_smile:

1 Like

So far had one switch go weird after firmware update. The light it’s attached to is on. But the switch doesn’t turn it on or off anymore.
I also can’t hold the favorite button and press the paddle 3 times (up or down) to change the mode.
And pulling the power disconnect then pushing it back in didn’t fix anything.

I’ve not tried holding everything to do a factory reset yet. But that one switch I guess didn’t like getting it’s firmware update.

Thanks! I was just about to try that, and decided to have a control case and just reset and started pairing - worked on the first try… might have been an issue with an earlier hub platform, or somehow a user issue…. Regardless, I am able to pair it on the C-8 now, so all good!

1 Like

Love this community. Been delayed getting into the new house, but all this work sure will make it easier when I get to upgrade 110 blue switches and the firmware changes should help make the Zigbee network stable at that size! :smiley:

Funny, I’m having the same issue with just one of my 30 switches that just updated. Can’t reset it. When local (i.e. at the switch physically), any button or reset combination does nothing… yet in Z2M, the actions are reported… and if I control it remotely via Z2M dashboard, when I turn the switch on, the right lights come on.

I’ve tried cutting the power via the breaker. Same behavior.

This one’s a head scratcher.

Today I got all the switches updated (HA with ZHA).
I my bulbs are LED, different types in different rooms and I wasn’t satisfied with any of them,
some were worse them others. Some would flash at the end of the ramp up.
But no, with the new firmware dimming it is smooth as butter. It is perfection. I couldn’t be happier.

On a side note, I noticed the “Double tap to full brightness” is showing twice and is grayed out.
Is this expected?