Blue Series 2-1 Firmware Changelog | VZM31-SN

I am seeing updates too but something is off.

You can see in the screenshot that the first two with an available update are on 2.14 which is correct.

The 3rd one was on 2.08 and I ran the update for it this morning. It now shows 2.14 as the firmware but does not show the available update.

Is this because zigbee2mqtt does not know of 2.15 yet so it falls back to displaying 2.14 as the version for switches that are really 2.15?

Maybe update or restart z2m. Mine is updating to 2.15 today.

The update should be available for Z2M and Hubitat users. This version has been tested by several people with good results, but I still recommend that you update one device configuration (ie smart bulb mode, 3-way dumb, 3-way aux, different load types, etc.) at a time and test the functionality that you use before proceeding. There are a few isolated reports of bulb compatibility and a new one about extra reports when using scenes? Blue 2-1 On / Up Behavior (Firmware related?) - Switches / Firmware Discussion - Inovelli Community)

This version makes leading edge the default dimming type (like it was before 2.11). So, if your load is compatible and you want to try trailing edge you can do the button combo of “hold down button then press the config button 13x”. Please only do this if you are using compatible bulbs and are having flickering or other issues. Reach out to us if you need to know if your load is compatible.

@mathd please try this procedure to show the correct version: Blue Series 2-1 Firmware Changelog | VZM31-SN - Switches / Firmware Discussion - Inovelli Community

If you have ZHA and would like to try the update please let me know. I can share the update instructions with you.

1 Like

Thanks for the update @EricM_Inovelli. Glad to see this finally released.

@mathd Z2M has some weird caching behavior that causes incorrect display of version following an update. You can manually confirm the correct version following the link EricM sent. I just did, and it looks like 2.15 installed successfully!

I previously posted here that 5 out of 6 of my switches have successfully updated to 2.15 from 2.14, but one continues to just loop through updating, and failing back to 2.14. It seems like my post may have gotten lost in the shuffle, or there is no information.

I am using ZHA and simply have the update file in my zigbee OTA update folder. I am wondering if there is another method I should try using to try to get this update to stick?

edit: because it may help, I believe that I have snagged the debug log for the entire update process here: home-assistant_zha_2023-08-24T17-41-22.681Z.log - Google Drive

1 Like

This is a bug in Z2M.
Go into the device page, then over to Dev Console.
Endpoint: 1
Cluster: genBasic
Attribute: swBuildId
Click on Read, you’ll see this result

Then go back to the about page and click Reconfigure (yellow button)
It will then display the proper version.

1 Like

Same, in fact most of mine seem to be failing to update on ZHA with the otau folder method.

1 Like

@mathd please try this procedure to show the correct version: Blue Series 2-1 Firmware Changelog | VZM31-SN - Switches / Firmware Discussion - Inovelli Community

That worked, thank you!

1 Like

I’m using smartthings but use HA for updates. Is there instructions to update 2.15? Feel like at one point I came accross them but with the size of the thread now, I’m not sure. Ty

I’m surprised that there isn’t a parameter to select the bulb type and based off that selection it would choose how the mosfet power trimming is done. That way this configuration can be read over the network as well.

Is there a way to read which mode the switch is in currently in v2.15? (Can you read if switch is in default dimming/trimming type LE vs TE?)

1 Like

@EricM_Inovelli , I would like instructions on how to update my firmware for the blue series using ZHA. All 3 of mine are showing 0x01020208.



I thought Leading Edge vs. Trailing Edge was going to be a driver setting. Is that still happening? Is it in the Hubitat driver?

Please confirm that in 2.15 we can switch from the default leading edge to trailing edge by “holding down button + 13 taps of config”. Please confirm that trailing edge will work for 3-way setup with a dumb switch on the other end, with a neutral wire and all led bulbs. Thank you :slight_smile:

There is a param 26 that is not exposed via drivers at this time to change between leading edge and trailing edge. You can read the param to see what the current setting is.

If you do the button combo to change the mode (down + config 13x = trailing; up + config button 13x = leading) it will flash

light blue = trailing
pink = leading

Since changing the dimming mode remotely can cause issues I’m not sure having the option available in the driver is the best idea. I prefer that the person is there at the switch able to verify that the load is ok. I’m still considering this though.

@nathanphillips001 trailing edge will still only work in some configurations. 3-way with dumb mode is unfortunately not compatible. This list shows which configs it can work in. The ones that say Trailing Edge are the only ones compatible:



If the switch is set to single pole mode with a neutral, can I set it to trailing edge even though it is physically wired as 3 way dumb? Are there any safety issues?

There shouldn’t be any safety issues if the load is just typical LED bulbs. If it is set to single pole mode it wouldn’t be able to detect when the dumb switch is flipped though so it may not work as expected. If you change from single pole mode to 3-way dumb mode then it will change to leading edge.

1 Like

I have found the following.

No flickering in any bulb type if I use 2 smart switches (bound with Zigbee Binding) and set the master switch (the one connected to the light) or both to Single Pole Sine Wave. On regular Single Pole I have flickering on some LED bulbs and even some incandescent bulbs, but this flickering started after going from 2.14 to 2.15. Even if I change from leading to trailing or back and forth nothing changes. The only thing that has made them not flicker is by setting them to Single Pole Sine Wave.

This was on regular light (LED) and one (INCANDESCENT) with switch in ON/OFF mode. No dimming. Sine wave is definitely the way to go.

When testing leading vs trailing, this was when switch was set to dimmer mode.

Very strange . . . especially the incandescent. Can you try a factory reset on the switch? What kind of bulbs are the LEDs?

Edit: Also, does the flickering happen at certain levels . . . or can you describe it some more?

1 Like

So the original test is where I saw the worst flickering:

ON/OFF mode, LED bulb, single pole (switchType: 0 )

It was fixed by setting switchType: 3 (Single Pole Sine Wave)

When set to DIMMER mode, I saw no flickering and nothing changed when I went from LE to TE and vice-versa.

Both tests were done at max brightness. It seems when in ON/OFF and in switchType: 0, the switch is sending pretty steep bursts of current at the load, and with each cycle it causes buzzing and flickering. I replaced the LED bulb with a standard bulb and the same occurred. I tried a different LED bulb as well that was marked dimmable just for the sake of that in ON/OFF mode and it was the same flicker.

I have also tested this with different bulbs and switches just to be sure. Not sure what switchType: 0 is doing in ON/OFF mode but it seems strange.

I have a couple switches that seem to refuse to update from 14 to 15 via z2m (several switches update just fine). They go through the process, but they stay at 14.

I have done the dev console-Gen basic-swbuild dance and it confirms 14.

I have reset the switch with up-config with no luck.

One of the switches is less than 10’ from the controller, and a different switch in the same gang updated fine. Switches much farther away updated fine.

Any suggestions/thoughts?