Blue Series 2-1 Firmware Changelog | VZM31-SN

Do you happen to have a link to the bug for the MQTT addon for HA? Would love to see what has been filed for this and if it is an accepted bug.

Yes, messages are no longer retained with 2.0.16+ (with a lot of reained topics?) · Issue #2887 · eclipse/mosquitto · GitHub

That is the MQTT release. HA follows the MQTT release with their own release of the add-on.
HA should post an update that regresses the MQTT core back to the older version prior to the problems. They won’t take ownership of it, and the MQTT GitHub staff are aware of the problem but haven’t started looking into it yet. Likely won’t happen till next year.


Ah perfect, thank you. I run mosquitto and zigbee2mqtt in their own docker project and can just force mosquitto to run at 2.0.15 to remove the issue. Thank you so much for the link to the bug before I got deep into my Zigbee network at the new house. I should exceed that number and it would have been a big issue for me.

Interesting that my mosquitto hasn’t been updated in a year, but I still have this problem. Mosquitto runs on a separate box for me, not as part of HA itself. Still, building the MQTT add-on against the newest mosquitto seems to cause the problem, even when its talking to an external MQTT server.

Thanks for posting this, since I’ve been struggling with this since early September. I found a partial backup that contained Mosquitto add-on 6.2.1, which contained the last working version of Mosquitto (2.0.15) and the problems are gone.

This thread helped me greatly as my MQTT devices are not working well and causing issues with my HA automation’s.

Using this tread for direction, I executed the following steps to solve this MQTT issue:
1 Stopped the Zigbee2MQTT add-on service
2 Stopped the Mosquitto Broker add-on service
3 Uninstalled the Mosquitto Broker add-on
4 HA partial restore of the Mosquitto Broker add-on v6.2.1
5 Started the 2 services up successfully

Backups are a life saver!

@EricM_Inovelli Any thoughts on this? Is there a waiting list for the wiring harness? :slight_smile:

Just an FYI Eric M is currently out of the country and will be returning mid next week! So likely no response from him before then…

Hey, the OTA is giving an error 404. GitHub shows firmware 2.15 has been deleted. Any ideas? I need to update this switch, and I really don’t want to hack Z2M for my friend to make this work.

@EricM_Inovelli @Eric_Inovelli @Courtney_Inovelli , are you guys able to update your JSON to point to the correct file? It seems someone has moved 2.15 into production folder and renamed firmware file, but never updated the JSON file so the JSON still points to the old location and no switches will update. Getting error 404.

Please update this:

Man you guys are psyho sometimes lol. I’m reorganizing GitHub at this very moment and trying to make it more user-friendly.

Let me get with Eric M – I guess this is what happens when the marketing guy starts tampering with things.

1 Like

@Eric_Inovelli I always pick the worst time to do anything, lol.

I mean on a positive note, I think someone asked like 6mo ago to move 2.15 to the Production folder, so at least you know we’re listening haha

1 Like

It’s funny, I haven’t had to install any switches for over a month, and then out of nowhere a friend asks me to install his. I started today of all days at this exact time, and went to firmware update and got errors.

It does seem I always pick the worst timing for things.

Alright, I updated the json file. We are good until Hines decides to move it again . . . jk . . . kind of.

3 Likes still doesn’t have 2.15…

1 Like

Hi, I followed this guide to view my firmware version but I don’t see it under the “Current States” section in my hubitat. Under the “State Variables” section I see that it lists fwVersion is 2.00, however I tried updating the firmware today (you can see “Last Update Time” in the Device Details section).

I have a hubitat C-7 on version

I have a couple questions:

  1. How do I update the firmware?
  2. How do I get the “fwVersion” to be in the Current States section like the guide?
  3. What version does softwareBuild 01020200 correlate with?

Current States Section:


State Variables Section:


Device Details Section:

Device Driver Version:

Will 2.15 be re-added to the manifest? I have a couple of switches that I’m finally getting around to installing this weekend, and I’m not interested in playing around with forcing OTA using a locally-hosted file. Would rather leave my z2m setup alone and wait for 2.15 to be restored to the production OTA pathway. @EricM_Inovelli @Eric_Inovelli

Hi @surelyhungry, to update the firmware you click on the update firmware button on the device page: Blue Series • Updating Your Firmware • Hubitat | Inovelli Help Center. I think the firmware version is only shown in the state variables for Zigbee devices. If you push the “Refresh” button on the device page, wait a minute, then hit refresh on your browser it will show you the firmware version in your state variables. 01020200 is 2.0. You don’t need to really pay attention to the swbuild and can just rely on the string representation of the firmware version.

@epow z2m has the latest firmware version in its manifest.

1 Like

But what about ZHA?

1 Like

did you ever resolve your issue? I have a switch that is in an endless update loop. The logs seem to indicate the switch was updated to 2.15, but the switch doesn’t show that as the version. I’m guessing the switch was updated fine, but the firmware version is not reflected accurately. So the switch keeps going through the update loop over and over.