Blue Series 2-1 Firmware will not Update

Running HAOS 11.5 / Core 2024.1.6
ZHA integration with Conbee III

My switches currently show a mix of firmware versions (0x01020208, 0x0102020b) neither of which is the current 2.15 (I think?).

No matter what I do literally nothing happens. No LED indicator, no change to version shown in ZHA, no errors. I have already followed the below instructions:

  1. Official firmware update guide, tried both the inovelli_provider: true and false methods. Firmware .ota file is in /config/zigpy_ota folder.
  2. ZHA Toolkit method. Green checkmark in UI but nothing happens.
  3. Developer tools service call, both the “args” and “params” versions of the YAML. Green checkmark in UI but nothing happens.

Restarted HA between attempts, also tried with different switches with no effect.
Renamed firmware VZM31-SN_2.15-Production.ota and VZM31-SN_2.15.ota but made no difference.
Waited 24 hours for the auto download method. Nothing working.

The inovelli_provider: true method won’t work as the current firmware file ZHA points to still lists 2.08 as the most up to date version (@EricM_Inovelli any word on that?).

Could you please share the snippet of your zha config in HA? And a screenshot of the zigpy_ota folder if possible?

snippet from configuration.yaml:

# Update Inovelli Blue 2-1 Firmware
      inovelli_provider: false
      otau_directory: /config/zigpy_ota

# Enable zha_toolkit:      

zigpy_ota folder:

Update: as of 10 minutes ago I updated HA to Core 2024.2.0 which features a firmware update entity in the device. It is reporting as up-to-date despite showing different versions on different switches.

I confirmed that 0x01020208 = 2.08 and 0x0102020b = 2.11 so I’m still out of date.

That config looks right to me, are you able to add the following to your configuration.yaml file? -

  default: info
    homeassistant.components.zha: debug
    zigpy: debug

Then restart HA, after it comes back, go through one of the steps to check for an update and then Settings > System > Logs. Can download them and if you want, you can PM them to me and I’ll take a look, or you’re looking for something like this and the surrounding logs for that device (though this snippet is from a fan switch and the image type would also be a different number) -

2024-02-07 17:53:06.043 DEBUG (MainThread) [zigpy.zcl] [0xE1EA:1:0x0019] Decoded ZCL frame: Ota:QueryNextImageCommand(field_control=<FieldControl: 0>, manufacturer_code=4655, image_type=513, current_file_version=33685765)
2024-02-07 17:53:06.044 DEBUG (MainThread) [zigpy.zcl] [0xE1EA:1:0x0019] Received command 0x01 (TSN 37): QueryNextImageCommand(field_control=<FieldControl: 0>, manufacturer_code=4655, image_type=513, current_file_version=33685765)
2024-02-07 17:53:06.044 DEBUG (MainThread) [zigpy.zcl] [0xE1EA:1:0x0019] OTA query_next_image handler for 'Inovelli VZM35-SN': field_control=0, manufacturer_id=4655, image_type=513, current_file_version=33685765, hardware_version=None, model='VZM35-SN'
2024-02-07 17:53:06.045 DEBUG (MainThread) [zigpy.zcl] [0xE1EA:1:0x0019] No OTA image is available

Actually, something that stands out to me is that file size. How did you download the OTA file?

You’ll want to go here and then on the top right you can click this -

Or just do Ctrl + shift + s and it will prompt you to save the file. It should only be 300KB, so the 404KB suggests to me that you might have the wrong file and that’s what’s causing you issues.

Thanks, I downloaded again and noticed the filesize was different. No success on update however. I’m sending log file for review.

I can reproduce this on 2024.2.0. Wondering if it’s a side effect of the changes to how they’re doing OTA now, I’ll reach out to some people and will circle back when I know more.

Edit - The functionality still exists, but it currently requires another key/value pair while they’re working on the OTA piece more. I’m verifying if there’s an added recommendation to avoid using it in the meantime as there’s a reason they disabled it for now.