Blue series routing trouble?

I got my 10 pack of Blue series installed and I’m having some problems with connectivity when devies are routed through the switches. Some devices just stop responding. Here’s what I’ve done:

  • Zigbee2MQTT installed on Home Assistant with Sonoff stick
  • Deleted existing network, set new network key and changed channel to 25
  • Set all wifi APs 2.4ghz to channels 1 and 6 so they don’t overlap with zigbee 25
  • Paired all of the blue series switches first
  • Factory reset (on and off 10 times quickly) and pair some Sengled bulbs

The Sengled bulbs being routed through the Blue series switches pair just fine but then they stop responding to any commands from zigbee2mqtt. This is a bummer because I bought the Blue series specifically to have high quality repeaters everywhere in my house to improve reliability of lighting.

Any thoughts on what could be going wrong here?

I’m seeing lots of lines like this in the logs

Failed to read state of 'kitchen_lights_bulb_6' after reconnect (Read 0xb0ce181403531cd2/1 genOnOff(["onOff"], 
{"sendWhen":"immediate","timeout":10000,"disableResponse":false,"disableRecovery":false,"disableDefaultResponse":true,"direction":0,"srcEndpoint":null,"reservedBits":0,"manufacturerCode":null,"transactionSequenceNumber":null,"writeUndiv":false}) failed
 (Data request failed with error: 'No network route' (205)))

Which seems to indicate that although the bulb joined without a problem shortly after joining it appears to lose its route which is via a Blue series switch.

Actually now it looks like nothing will route through the blue series. The network map shows the only bulbs that are responding have re-routed directly to the stick. Sorry to ping you directly @Eric_Inovelli but I’m pretty stumped here and the WAF is dropping rapidly while the network isn’t working.

1 Like

No worries on the ping. Let me tag @EricM_Inovelli who can probably speak further on any routing issues. But I’m confident being Zigbee 3.0 certified and being defined as a router, this likely isn’t an issue with the the switches.

Hang in there, we’ll figure it out!

Here’s my limited network with some routing through the 2in1 (front hall light)

Can you clarify which Sonoff stick you’re using? And are you using a USB extension cable?

Yes, I have tried two different USB extension cables. Stick is model ZBDongle-P (zstack 3.0 TI CC2652P + CP2102N w/ external antenna). I have verified that I’m on channel 25 and my wifi access points are set to channels 1 and 6 for 2.4ghz.

Before rebuilding the whole network with Blue series I had 4x sengled smart plugs as repeaters. The network worked ok most of the time but would sometimes drop a motion event, fail to set a bulb in a group, or have a 3-5 sec lag on a command. Those plugs were dodgy, they would randomly go into loops of clicking their relays on and off even when they had no load.

After rebuilding with 10x blue series things seem amazingly fast and stable after pairing some bulbs – for about 10 minutes. After that some of the bulbs will just refuse to route through any of the blues and can’t reach the coordinator with a good signal themselves. Commands fail as above with “no network route”.

This is what my network map ends up looking like. The bulbs pair fine but after a little bit of time they refuse to route through the Blue series switches and end up dropping off the network.

lqi values for some of your direct-attached Inovelli switches are really low… any possibility you can re-locate your coordinator to bring those values up? Maybe not a permanent solution, but it would be an interesting test to see if it helps keep the bulbs attached.

I have tried moving the coordinator, no improvement. LQI is seemly always low in my house I think due to the construction (it’s 125 years old brick with lathe and plaster walls). I have trouble with wifi performance including 5ghz as well so I’m pretty sure it’s the construction. I bought all these Blue series hoping that they would act as high quality routers to fight through the poor signal propagation!

It’s strange as you can see from the picture above – when one of the bulbs does decide to route through a blue series switch it has a really high LQI. They would all work great if they would just route through the switches!

They also appear to be randomly deciding to route through the switches or just be completely disconnected. Different bulbs work at different times thoughout the day!

A separate issue I’m having is that the Sengled bulbs flicker (60hz flicker) on the blue series when they’re in color temp mode. They didn’t flicker on the red series.

1 Like

When you pair the bulbs are you pairing them through a specific switch, or using the “enable all” pairing mode? I’ve had much better luck pairing twitchy Aqara / Xiaomi devices by only allowing them to pair through a specific repeater. They seem to be “sticky” and will mostly keep routing through the router they were first paired with. I don’t have any Inovelli Blues to try this with, yet, but I can say that this has worked with my Ikea outlets acting as permanently-set routers for Xiaomi contact sensors. Maybe bulbs will behave similarly?

I tried that but it didn’t seem to work. There was no noticable difference in behavior. They started out fine with high LQI to the switch for a little bit then just dropped from the network or routed directly to the coordinator. It seems like maybe the “pair via device” function doesn’t work in zigbee2mqtt? Every time I’ve tried the device ends up with whatever route it feels like anyway.

1 Like

It’s possible that some devices play well with this feature and others don’t. I’ve never tried it with anything other than Aqara / Xiaomi motion and contact sensors… works really well for those. Too bad it didn’t give your bulbs “sticky” routes… are there any bulb config parameters that might be in play? Running out of ideas…

The bulbs don’t expose any config params that I know of other than transition time and XY color conversion. Sengled are definitely cheap bulbs but IMO they’re 70% as good as hue at ~12% the price per bulb. I filled my house with them because they’re “good enough” and affordable enough to have adjustable lighting in every room.

1 Like

For reference, here are the details about my network


I notice that the coordinator firmware is somewhat outdated at 20210708 (that’s what shipped on the stick). I wonder if updating it might help but I’ve never flashed one of these sticks before, seems like a bit of a PITA.

It’s not that bad really… start with this cross-platform tool- it requires that you have Python on your machine:

You’ll also need the firmware for your stick- the latest dev build (20220928) has been pretty good for me… grab the version appropriate for your stick here:

The command I ran on my PC to flash the latest firmware was this:


py -e -w -v -p com3 --bootloader-sonoff-usb CC1352P2_CC2652P_launchpad_coordinator_20220928.hex

You’ll have to tweak it for whatever com port your device shows up on, filename for your particular build, and you may need to remove the sonoff-specific flag (read through the instructions on the cross-platform tool to see if you need it or not). Oh, and if your stick isn’t recognized (and you’re on Windows), you’ll see something like this in the device manager:


In this case, go install this UART driver and the stick will be recognized, after which you can flash it:


Thanks for the tips, I actually flashed it before I saw your post. Updated to latest zstack and upped transmit power to 20, rebuilt the whole network. It works a bit better now probably due to the higher transmit power, but the problem persists.

The Sengled bulbs still refuse to consistently route via the Blue series and drop off the network seemingly randomly.

There’s a strong argument to made against increasing your coordinator Tx power: it doesn’t have any impact on Rx sensitivity. So, you can shout really loudly at all the routers and end devices, perhaps allowing the coordinator to send messages directly to devices that are not in receiving range. Best practice is to balance Tx/Rx effective range so that devices that are far away will do the appropriate thing and look for a router, instead of trying to make a direct connection. If the coordinator is sending them messages directly, they’ll get the wrong impression and do the wrong thing.

I’m starting to wonder if maybe it is a Zigbee 3.0 vs ZHA 1.2 issue… there are some (now older) Sengled bulbs out there that were designed with ZHA 1.2, which I can confirm has issues playing on a modern 3.0 mesh managed by zigbee2mqtt. My Zen thermostat, for example, worked fine with Hubitat as the sheriff, but once I switched to zigbee2mqtt it was a nightmare. There are firmware updates available for some Sengled bulbs, and OTA via zigbee2mqtt may be your solution. The trick will be keeping the devices paired long enough for the entire firmware update to run through. Perhaps rig up a test fixture right next to your coordinator, and pair the bulbs directly in that fixture just to get the OTA updates to push through?

*Edit: I’m assuming you have this bulb, which was released with both ZHA 1.2 and Zigbee 3.0 versions… E11 is ZHA1.2, and if your part # has E21 in it instead, it’s Zigbee 3.0: