Blue Series Signal Issues/Performance

I am experiencing some massive variability in my signal performance between switches. I am pairing them on the latest revision Home assistant ZHA platform with a Nortek husbzb-1 that I am also using to pair two Z-wave devices without issues. My Wi-Fi is broadcasting on Channel 11 on all access points. My coordinator is connected to my server via extension cable. My furthest Z-wave device is 50ft from the husbzb-1 and has no performance issues at all.

The switch that is closest (10 linear ft and only one wall) to the coordinator will not make it through an inclusion unless I plug in an additional blue switch via a “cheater cord” about 12 inches away and pairing through that device (which has full signal). This switch, even though it is literally inches away from another router has the lowest signal strength out of all switches in my network with the network map showing 34 if it is connected at all. I suspect this switch is defective in some way and I will attempt to use another one in place. I have non-metal boxes and my switch plates are plastic as well.

I also have two blue series in the same box. One of them has excellent signal directly to the coordinator which is roughly 15ft away, and the switch adjacent to it has poor or moderate signal to the coordinator AND the switch in the same box as it. Is this behavior expected?

In the process of including these three switches, I have had to factory reset the switches a few times to get them to configure with all of the options. Reconfiguring with the option in ZHA always fails. No device is more than 15ft away from the coordinator. They are all connected with a neutral.

Coordinator info:

 "ieee": "**REDACTED**",
    "nwk": 0,
    "manufacturer": "Silicon Labs",
    "model": "EZSP",
    "name": "Silicon Labs EZSP",
    "quirk_applied": false,
    "quirk_class": "bellows.zigbee.device.EZSPCoordinator",
    "manufacturer_code": 43981,
    "power_source": "Mains",
    "lqi": 255,
    "rssi": 0,
    "last_seen": "2022-10-23T20:47:16",
    "available": true,
    "device_type": "Coordinator",
    "signature": {
      "node_descriptor": "NodeDescriptor(logical_type=<LogicalType.Coordinator: 0>, complex_descriptor_available=0, user_descriptor_available=0, reserved=0, aps_flags=0, frequency_band=<FrequencyBand.Freq2400MHz: 8>, mac_capability_flags=<MACCapabilityFlags.AllocateAddress|RxOnWhenIdle|MainsPowered|FullFunctionDevice|AlternatePanCoordinator: 143>, manufacturer_code=43981, maximum_buffer_size=82, maximum_incoming_transfer_size=128, server_mask=0, maximum_outgoing_transfer_size=128, descriptor_capability_field=<DescriptorCapability.NONE: 0>, *allocate_address=True, *is_alternate_pan_coordinator=True, *is_coordinator=True, *is_end_device=False, *is_full_function_device=True, *is_mains_powered=True, *is_receiver_on_when_idle=True, *is_router=False, *is_security_capable=False)",

Moved this here out of the bug thread simply because I’m not sure if this is a bug yet, but if it turns out to be one, I will move it back. Just figured we could try to troubleshoot here with you vs just letting it sit in the enhancements/bugs thread that’s meant for fixes. Hope that’s ok?

I don’t know enough about ZHA to render any advice myself, but I’ll tag @EricM_Inovelli to help if he can. This definitely isn’t normal behavior as it wasn’t noticed in beta. Hang in there, we’ll figure it out.

1 Like

I have not yet seen this with my units but it does sound a little suspicious. I think the best test would be to do what you suggested:

The production switches that I have setup have been on the second floor with the Hubitat hub in the basement (in a closet). So there is quite a bit of range between them and many obstructions. They didn’t have any problems with inclusion (first attempt) and are very responsive. All configuration commands make it to them as well and they are the only Zigbee devices on the network.

I would also say to try a factory reset, but it seems like you have already done that. For reference, the antenna is actually right under the paddle which should result in pretty good range (since it isn’t buried in the switch electronics).

What zigbee channel are you using and is the coordinator plugged into an extension cable?

I have performed multiple factory resets in an effort to initially include the device in the network, reconfigure the device after a configuration failed to pull in all of the information. Is it possible that the ground wire could sever the antenna? it looks like the ground terminal has no protection from inserting the wire too far.

Do you have any thoughts on the 2 switches in the same box that have wildly different signal strength?

I forgot one detail of my setup. I have an existing Philips hue systems with about 10 devices connected. When I was having problems pairing the devices, I unplugged the Hue bridge to see if it influenced any performance changes.

I am using an extension cable because my server is in a rack with a metal door. I configured ZHA with the default settings. I believe that it selects channel 15 by default.

1 Like

Apologies, I totally missed where you even called the extension out in the OP. Is it a USB2 port/cable?

For additional data points, for the 2 switches in the same box, was the ‘good’ one joined first?

Any other Zigbee devices on the network?

Do you have the specific model/info for the coordinator?

EZSP = Silicon Labs EmberZNet protocol: Elelabs, HUSBZB-1, Telegesis
Channel: 15
frequency_band=<FrequencyBand.Freq2400MHz: 8>, 
     by ZHA
     Nwk: 0x0000
     Device Type: Coordinator
     LQI: 255
     RSSI: Unknown

I cannot seem to find a firmware version for the coordinator. I do have a Philips Hue System operating independently of this. I will try to verify the Hue network channel later today.

I only have the three switches discussed above installed and a fourth I have called “Bridging Switch” that I used to Include the poorly performing switch.

The extension cable Is USB2.0 and I am pretty sure the port is a USB 2.0 as it is the front panel connector that is usually used for mouse and keyboard on the server.

I do not recall which I paired first because I tried to reconfigure all of them and had to perform a factory reset to get them included again. The reconfigure was performed because only some of the configuration parameters were showing up in ZHA.

1 Like

15 seems to be the default channel for many systems, including Hue and zigbee2Mqtt. I’d place > even odds that you have two zigbee setups trying to use the same channel.

I assumed this was the case. Apparently it is very easy to initiate a channel change on Hue, so I will do that if Hue is on CH15. This however does not entirely explain the issue where one device is entirely non-functional despite being closer and even within inches of an additional switch operating as a router.

2 Likes

Do you recall, is this the Nortek HUSBZB-1? Where it does zwave/zigbee on the same stick? I know there is a recommendation to update the EmberZNet NCP firmware for it for ZHA, not a requirement but may help as well.

Is the Hue Hub in the same closet/rack?

This is the Nortek Combo stick. I did see the recommendation for a firmware update. I purchased this device less than a year ago, so I did not consider it necessary until now.

The hue bridge is in the same room about 10ft away. If I resolve my other zigbee issues, I may transfer all the hue devices to home assistant to allow for direct bindings.

1 Like

Not sure what firmware is shipped on them, etc just wanted to bring it up as a possibility. I’d be curious how things change if/when you’re able to change the channel used by Hue.

Wondering if it’s just interference on top of a ‘new’ Zigbee network leading to things not being stable enough currently.

1 Like

I was thinking that swapping the bad one out with a known good one would be a good test here. Trying to see if the one with the low signal is defective and if it improves after replacing it. Changing the channel is probably an easier thing to test out at first though so I would try that first. I’ll also have the engineers look at this thread to see if they have any ideas.

I’m also running into huge problems including the light switches in my hubitat.

It seems like the signal is quite weak for my dimmers. I have a dimmer within line of sight to my hub 14ft away, the LQI in hubitat logs is rather sporadic anywhere from 0-80. In comparison, I have a zigbee outlet 50 ft away that is one floor down, through a wall and behind a TV and it has an LQI of 253.

I installed 3 other dimmers and have had trouble pairing them. I managed to pair 2, but they lost the connection after a couple hours. The last one had a lot of trouble pairing, and was only able to pair when I installed a zigbee repeater within 6 ft of it. Once I moved that repeater, it lost the connection. All my switch boxes are plastic and house is typical wood joists and drywall.

In the same room as all of these dimmers, I have zigbee motion sensors and contacts that are paired without problems. I’ve tried rebooting my hubitat and factory resetting the switches multiple times and they still seem to have problems.

This is crazy because my beta unit was 2 FLOORS away and still joined every time. In fact it was so strong that about 1/2 of my zigbee devices used it as a router, even going up to second floor before down to basement.

Something has to be up either in hardware or interference, because these have been nothing but reliable and overwhelmingly the strongest RSSI on my ZHA network.

And we had to factory reset multiple times after firmware upgrades.

1 Like

Just as a point of comparison, I installed a blue series switch yesterday and had 0 issues getting it included into Hubitat and it continues to work without issue.

What channels are people using? I’m on channel 25 (that had the least interference from wifi signals)

I have verified that Hue was on channel 15 as well. I changed it to 25 and the poorly performing switches did not improve from this change.

I have installed the switch that I was previously using as a temporary router and the signal on this one is essentially perfect. LQI: 255, RSSI: -81 where as before the signal was, RSSI: -97. Same box, same wiring. The other switches are still performing poorly and are only 8 or so ft away.