Blue Switch /w Hubitat - Cannot ZigBee Bind to Hue Bulb

Hi there,

Recently received my Blue Switch and I was excited to play with Zigbee Bindings in Hubitat. I first paired a Philips Hue 4in Downlight through Hubitat + the Inovelli Blue /w latest driver. Both devices appear to be working properly, and I also verified that an automation rule as able to control the light via the switch in smart bulb mode.

Next I followed the Instructions here in order to setup Smart Switch to 1x Smart Bulb. The ZigBee Bindings app appears to be setup and functioning properly as I am able to see bind commands in my device logs. However, there doesnt appear to be any binding actually happening, and the switch is unable to control the light.

Here are a few relevant pieces of info:

Inovelli Blue Switch (Bedroom Hallway Switch above):

  • Zigbee Id: 040D84FFFE05F977
  • endpointId: 01
  • model: VZM31-SN
  • application: 11
  • firmwareMT: 122F-0101-01020200
  • softwareBuild: 01020200
  • manufacturer: Inovelli

Philips Hue Bulb (Bedroom Hallway Recessed above):

  • Zigbee Id: 001788010D0A5489
  • endpointId: 0B
  • model: LCD005
  • application: 02
  • softwareBuild: 1.93.11
  • firmwareMT: 100B-0114-01001C12
  • manufacturer: Signify Netherlands B.V.

Switch Logs After Binding:

dev:462022-10-19 06:17:06.311 pm traceBedroom Hallway Switch: PRIVATE_CLUSTER (0x8021) (clusterId:8021 data:[14, 00])
dev:462022-10-19 06:17:06.307 pm debugBedroom Hallway Switch: [raw:catchall: 0000 8021 00 00 0040 00 9C39 00 00 0000 00 00 1400, profileId:0000, clusterId:8021, clusterInt:32801, sourceEndpoint:00, destinationEndpoint:00, options:0040, messageType:00, dni:9C39, isClusterSpecific:false, isManufacturerSpecific:false, manufacturerId:0000, command:00, direction:00, data:[14, 00]]
dev:462022-10-19 06:17:06.305 pm debugBedroom Hallway Switch: parse(catchall: 0000 8021 00 00 0040 00 9C39 00 00 0000 00 00 1400)
dev:462022-10-19 06:17:06.144 pm traceBedroom Hallway Switch: PRIVATE_CLUSTER (0x8021) (clusterId:8021 data:[13, 00])
dev:462022-10-19 06:17:06.140 pm debugBedroom Hallway Switch: [raw:catchall: 0000 8021 00 00 0040 00 9C39 00 00 0000 00 00 1300, profileId:0000, clusterId:8021, clusterInt:32801, sourceEndpoint:00, destinationEndpoint:00, options:0040, messageType:00, dni:9C39, isClusterSpecific:false, isManufacturerSpecific:false, manufacturerId:0000, command:00, direction:00, data:[13, 00]]
dev:462022-10-19 06:17:06.138 pm debugBedroom Hallway Switch: parse(catchall: 0000 8021 00 00 0040 00 9C39 00 00 0000 00 00 1300)
dev:462022-10-19 06:17:05.961 pm traceBedroom Hallway Switch: PRIVATE_CLUSTER (0x8021) (clusterId:8021 data:[12, 00])
dev:462022-10-19 06:17:05.953 pm debugBedroom Hallway Switch: [raw:catchall: 0000 8021 00 00 0040 00 9C39 00 00 0000 00 00 1200, profileId:0000, clusterId:8021, clusterInt:32801, sourceEndpoint:00, destinationEndpoint:00, options:0040, messageType:00, dni:9C39, isClusterSpecific:false, isManufacturerSpecific:false, manufacturerId:0000, command:00, direction:00, data:[12, 00]]
dev:462022-10-19 06:17:05.951 pm debugBedroom Hallway Switch: parse(catchall: 0000 8021 00 00 0040 00 9C39 00 00 0000 00 00 1200)
dev:462022-10-19 06:17:05.836 pm infoBedroom Hallway Switch: bind([zdo bind 0x9C39 0x01 0x0B 0x0006 {040D84FFFE05F977} {001788010D0A5489}, delay 200, zdo bind 0x9C39 0x01 0x0B 0x0008 {040D84FFFE05F977} {001788010D0A5489}, delay 200, zdo bind 0x9C39 0x01 0x0B 0x0300 {040D84FFFE05F977} {001788010D0A5489}, delay 200])

Any idea what may be going on here? Im not sure what else I am missing, but I am seeing no binding activity nor any increment to the `Device Bind Number (read only) value for the switch.

Man that is really strange, it appears everything is setup correctly.

What model hub do you have (ie: c4, c5, c7, etc)?

Let me play around a bit tonight to see what my logs show (if anything).

Another random question - did you bind it with any other values first? Example, did you accidentally put in like 0x02 or something else? I did this once and I had to unbind using the same values for some reason.

I’m having the exact same issue. First time binding. Same settings as above but the binding doesn’t actually take.

I appreciate the quick response - this is with a C-7 hub. I did not try binding with any other value first. I also factory reset the switch yesterday so all configuration is fairly fresh.

I do happen to have one of the exact model Hue bulbs that you listed as a tested model in the setup guide. I will try that out tomorrow.

Are there any additional logs I could supply to be helpful?

Ok I screwed up the instructions - my bad guys.

Change Endpoint 0x01 to Endpoint 0x02.

I was losing my mind over here bc I just got it to work the other day, then deleted it and redid it tonight and couldn’t get it to work either and thought, “oh crap, what is happening?”

Changed it to 0x02 and it worked.

Sorry for the mixup!

Can you let me know if that fixes it?

3 Likes

Ah that was it!! Worked once I changed master to 0x02.

I had assumed I should take the endpointId for master from the Switch data section, but that’s not the case here. 0x02 was the correct value for me.

2 Likes

All,

I am using HE (C7) and Hue Bulbs as well and I am trying to make it work with Zigbee Binding (vs. Button mapping). However, I have not data for my bulbs (see pic) and no endpointID required in the app. The bulbs also do not appear on the menu offered by the app.

Is that because I am using a hue bridge integration and for this to work, the bulbs need to be directly paired to HE ?

Yes

So what are my options ? Button control only ?

Yep - on one of my Blues (smart-bulb mode), I use Button Controller to manage a couple Hue bulbs in a Hue group all integrated to HE via CoCohue. It’s very responsive/fast. I don’t doubt binding would be faster, but TBH, whatever that difference is would be lost on me.

So if you keep the bulbs joined to the Hue hub, then you’ll have to control them via scenes.