Cannot get Switch to pair at all

Any luck with this? I’m having the same problem. Using Z2M with a Conbee II on a USB extension. I have multiple other Zigbee devices (Aqara, Sengled light bulbs, Yale lock) all paired without issue. New Blue switches are about 10 feet from the Zigbee stick. After getting into pairing mode (flashing blue), no new devices show up after Permitting Join (All).

I’m running Core in Docker. I have a few aquara sensors and a few innr plugs.
The weird part for me is the first one paired. But acted weird (couldn’t reach it, didn’t expose anything, etc). I removed it and can’t see it again. However for the other 15 i have now installed, they never show up. I have a mix of with and without neutral. They all exbihit the same behaviour.
All switches start and can be made in paring mode (blue blinking) for 3 minutes but nothing shows up on Zigbee2M. I’ve tried some of the manual pairitin techniques as well, but same behavior.
I’ve reset and rebooted Zigbee2M, unplugged and repluged the coordinator. They never get seen, and nothing shows up in the logs either.
I have another coordinator (sonoff), that i can try to see.
I will also try repairing the one that once worked.

1 Like

Hi I am also having similar issues. I have 10 blue switches that were installed by an electrician yesterday, all w/ neutral.

I am using ZHA with the sonoff zigbee dongle attached to a usb extender.

The switch that is in the same room as the dongle only paired when I brought the dongle within a few inches of the switch. Two more that are only a few extra feet away show up as “interview starting” but never get further than this (at this step the switch itself blinks green once and holds a solid blue).

Even the switch that DID pair has many issues. Turning on/off the light from within HA had a ~30 second delay and only one out of every 3 tries would actually do anything. Running “reconfigure” on the device says it failed everything in the “bindings” section. This behavior repeats after resetting the switches.

I have a conbee stick also that I was going to try today using a brand new setup (or maybe Z2M) and see if that makes a difference but after spending $1200 between switches and install costs I’m pretty let down. Hoping this gets solved soon.

1 Like

Yeah similar issues here. I agree with @chack that we need to start looking at correlating factors to narrow down the issue.

I just spun up a brand new raspberry pi with the latest OS and installed nothing except Mosquitto (version 2.0.11) and Zigbee2MQTT (1.28.0). I’m using a Conbee II adapter on a 6ft USB extender. The Z2M UI reports the following:

Any chance it could be the firmware on the dongle? I just checked and it looks like there is one newer version available (0x26780700). I will try updating that and follow up.


I am using the sonoff dongle but still took the advice and ran a firmware update on it. I have to say that pairing is going much more smoothly now. I was able to add 4 switches in a row. Some after that started having slow interviews but the performance is improving so far. Will continue to test today.

1 Like

Just wanted to update this thread as well… the issue for me was interference with another smart hub: Unable to reset switch or start pairing - #21 by kcarbone


This makes me think that also Alexa devices might be interfering if they have zigbee capabilities.

The following Echo devices have built-in smart home hubs that seamlessly connect and control Zigbee smart devices:

  • Echo 4th Generation
  • Echo Plus
  • Echo Show 10 (all models except 1st Generation)
  • Echo Studio

Make sure these are unplugged or zigbee is otherwise turned OFF when trying to pair switches.

1 Like

I did a few things:

  • Updated my ConBeeII firmware to the latest: same issue.
  • Created a brand new Z2M instance with the Sonoff coordinator: same issue.
  • Unplugged my water FLUME base station: same issue.
  • Unplugged my water BeeHyve base station: same issue.

I was able to get my blue switch paired with Deconz - but I understand now why the manual recommends ZHA or Z2M.

First, i had to physically turn off all Hue bulbs in my house. I also disconnected my Amazon Echo’s and my hue hub.

I’m not sure if this actually resolved it or not - but afterwards, I noticed that the Blue switch had been added to Deconz as a light.

The behavior i’ve experienced is the following. When pressing the top paddle of the switch, all lights in Deconz turn on. When pressing the bottom paddle, all of them turn off.

Deconz appears to also not be passing deconz_events to Home Assistant when buttons are pressed.

Not sure how to deal with this other than switching to ZHA or Z2M, which I was planning on doing once my SkyConnect arrives.

I think the reason for the recommendation for ZHA or Z2M is also that there are quirks/handlers/drivers, etc written and now built into those platforms as they seem to be the most common when using HA (and are what beta testers on HA were using).

Nothing is really stopping someone from getting Deconz working with it, just a matter of needing to know how to configure them as well as potentially changes to Deconz for stuff like the events to get multi-tap working, etc.

Just another data point.

I’ve updated the firmware on my Conbee II and still no dice. After putting it in pairing mode (pulsing blue), nothing ever shows up in Zigbee2MQTT - both eventually time out.

  • I have ~6 other Zigbee devices already on my network
  • No other hubs in the house that could be interfering
  • No logging information showing up in Z2M
  • Tried with 3 different Blue 2-1 switches, two of which are about 10 feet from the controller with no obstructions
  • Coordinator is on a USB extension
  • Zigbee2MQTT version 1.28.0
  • ConBee2/RaspBee2 Coordinator revision 0x26780700
  • Zigbee channel 11, Wifi 2.4 Ghz channels 1 & 6

I also submitted this in the form posted in the troubleshooting thread.

1 Like

Any updates here?

1 Like

This is likely a huge part of your issue. Zigbee 11 directly interferes with WiFi 1.
If your WiFi is 1 & 6, your Zigbee should be somewhere between 21-25. And yes changing your zigbee channel WILL require you to re-pair all your devices.

1 Like

If his other devices work just fine, it’s not just channel conflicts.

Not necessarily. Joining a new device and sending an on/off command require 2 different levels of communication.

1 Like

I’m afraid I’m also experiencing a failure to pair on one of my new Blues. This is setup in a dumb switch (no neutral) configuration. Of the 8 switches I’ve installed so far, this is the only one which I’ve not been able to pair. I have another blue about 10 feet away in the same room that pairs fine and I have a Sylvania smartplug that serves as a hub that is in the same room so plenty of signal. Multiple power disconnects, factor resets and attempts to use the airgap switch all to no effect. About 22 devices on the network at this time.

1 Like

Add me to this list as well. I bought a 10 pack. I added 4 with no issue. #5 will not connect no matter what I do. I added a 6th switch no problem but #5 still wont connect.
I have pressed the up paddle and config for 20 seconds to get the blue blink 10 times now. I have also held down the config for 20+ seconds to factory reset and that didnt change anything.
I also pulled the air gap out and put it back in and nothing happened.

Is there any thing else I can try?

1 Like

+1 to the list here. I bought 2 and the first one worked great - paired right away no issues. 2nd one I cannot get to pair at all. Hass OS, ZHA with 17 other zigbee entities all working great.
I have been able to find the device 2 times after 3-4 factory resets of the switch and ZHA will say “starting interview” but the switch will blink red and go back into pairing mode never to be found again.

For troubleshooting the ieee is 943469FFFE05C607

So far, I’ve installed 23 switches of 38. Currently 8 of them show an LQI of 0. and they are all listed as unavailable in z2m. I have around 45 ZigBee devices on my network and everything was rock solid, but all the sudden other ZigBee devices (endpoints and routers) have started to either lock up or respond poorly. I’m not sure what’s causing the low LQI issue, but I’m guessing buggy firmware is to blame for the routing issues. Hopefully it’s a quick fix they can push out, because the switches that work are really nice.

Subscribing here.

I’m having similar issue, but I’m setting up my first smart switch(ever) and also have a new Conbee II with deconz.

Conbee II - firmware: 26720700
deconz: docker deconzcommunity/deconz:latest

I’ll give it a try with the second switch tomorrow :crossed_fingers: