Can't get LZW31-SN to work locally or on Hubitat

I’m a confident amateur electrician (rewired three houses, passed inspection). Which means I’m not a professional electrician; but so far as I can see the wiring I’ve had to figure out is really simple.

New to home Zwave and Hubitat and Inovelli, like just a week, but using X-10 for 30 years or some such.

I’ve got a small (< 12 devices) working Hubitat installation, mostly wired-in dimmers.

I’m in an old ( > 100 years) house, and the lighting circuits on the main floor are all knob-and-tube, and they all (all the ones I’ve looked inside) are wired as switch loops – so, no neutral wire in the switch boxes.

However, what I want in this case is really simple – there’s a ceiling fixture with 5 lamps, modern LED bulamps (so shouldn’t be a problem with either min or max load draw), and then one wall switch, simple switch loop, only two wires in that box. Neon tester easily identifies the hot side, so that goes in the “line” screw, and the other side goes in “load”. Nothing else to hook up (no ground in box; no conduit, no ground wire, no additional switch desired).

The instructions however are vastly confusing; to the point of being self-contradictory. The wiring insert, for example, appears to say I need to be telling the switch it’s in a no-neutral configuration by pressing buttons 12 times and various other things (step 5, “non- neutral configuration”) – at the same time the big instruction sheet seems to tell me that I’ve got a 60-second window after power on to accomplish pairing with the hub. And then buried in the Hubitat-specific instructions it notes I need to install a driver from Github before that. Oops! (Also, I have to run to the basement to turn the circuit on or off, and back up to the first floor to do anything with the device, cutting into that 60-second or sometimes 30-second window).

So, I achieved a state where:

The device is known in Hubitat (and S2 connected) and has the right name and the right driver, I think.

The device in the wall has the blue light bar on, bottom brighter than top half way up. The overhead light it controls is on, but flickering. And no buttons, neither the paddles nor the config button, does anything with any compbination of presses I now try. Specfically 10 seconds, 20 seconds, and 30 seconds of holding the config button, button “A”, the upper right button do nothing, no change to LED state and no change to overhead light state.

I’ve had to pull the device back out of the wall and cap off the hot wire, for now, since too much of the first floor is on that same lighting circuit, can’t leave it off.

I’ve force-excluded the devince from Hubitat now. So, the question is where to pick up tomorrow. I have no idea how the timing of powering on the new device, and doing the non-neutral switch config (step 5 on the wiring insert), and attempting inclusion in Hubitat, should go; last time the switch auto-included in Hubitat before I could configure the switch as non-neutral, I think. And…I should presumably do a factory reset on the switch first also? But that’s a 20-second push on the config button, which did nothing last time.

Because you have a Hubitat, you can ignore all of the instructions about configuring the switch locally with a ton of button presses. The driver exposes all those options for you, including the non-neutral/neutral setting, etc.

This is where the coming wiki’s will be so helpful.

Step 1a, install the driver on Hubitat in preparation
Step 1b, CUT POWER, install the physical switch, return power.

Step 2, pair the switch to hubitat by putting the hub in pairing mode and hitting the config button (small/upper-right) 3 times. Pair success indicated by 3 green flashes.

Step 3, in Hubitat, go to the configuration settings of the switch and all parameters will be set there. The description of each configuration parameter will be there and you can set it to the value you desire. Most important is the following:

Parameter 5: Min Level - set this at the minimum level where the LED’s are on and behaving well.
Parameter 6: Max Dim Level - set this at the max level were an increase in level doesn’t result in a noticeable increase in brightness, 50-99 are accepted values.

Note: the switch does the hardware scaling from parameter 5 to parameter 6, but still shows level 1-100. This is normal.

Parameter 21: AC Power Type, change to value 0 for non-neutral (likely comes with 1 as default from factory).

I am not on Hubitat so I can’t give you screenshots, but post back if that gives you issues.

1 Like

With the switch properly powered it’s as simple as putting the hub in the inclusion mode and hitting the config button 3x. Once it’s connected to the hub, configure the settings there. The instructions about doing the settings at the switch are largely for those that are hubless.

With the lights flickering, don’t discount the fact that you might need a bypass. I know the published spec is 25W, but LEDs and smart switches are still like the wild west to some extent. This is particularly true with non-neutral installs. A quick way to test is to swap out for incandescent bulbs.

1 Like

I did notice the non-neutral option in the device config. Okay, that simplifies things a lot, thanks!

1 Like

Ouch, don’t wanna have to buy the bypass (and even worse, wait for it)! Well, will pursue that possibility. Current lamps are 5x LED rated at 7 watts each; so substituting incandescent for 2 or 3 of them would give me a solidly adequate load, I think, without threatening the upper limits. Thanks for suggesting it—and, should have thought of it myself. I was kind of assuming that the 25 watt figure already had safety margin, so being safely past it sounded safe, but so it goes here in the wild west!

But the other thing—being stuck with the bar half on blue on and no buttons doing anything—how do I get past that? It’s been sitting unpowered overnight and I excluded it from the hub, so maybe it’ll be clean when I get back to it now? That’d be nice. Switch in some incandescent bulbs first of course. If I can find them, not sure I’ve bought any new ones in 25 years.

Hey @Eric_Inovelli is the 25W the minimum CONSTANT load or CONNECTED load? This is about the 50th time someone has been confused on this, and I think there may be some rephrasing needed in Wiki/manual.

Edit: @dd-b on the no dimming operation, confirm you have not accidentally set disable local control. Hit the config button 8 times in succession, and it should blink red 3 times if you JUST disabled it (meaning it was off), if it blinks 3 times green then you had accidentally disabled it. If it did blink red, then just do it again to get it to blink green (local control enabled).

Double edit: seems like you got it, so disregard lol.

2 incandescent bulbs (3 LEDs still in place), re-installing the switch, and re-including the device has things behaving. Thanks to seth, kreene1987, and Bry, all of whose responses were useful getting me to this milestone!

Weirdly, when I pressed the config button 3 times (after putting the hub in inclusion mode), I didn’t see three green flashes. However, the hub reported the device discovered, and setting its parameters and manipulating its controls then worked.

1 Like

So—now it’s working with two incandescent and 3 LED lamps :-).

Are the dimming limits and the total load related? Should I try going back to all LED, and see what happens? And if it’s not good, play with upper and lower dimming limits and see if I can find a range within which it’s good? (Leaving it in this mixed state is of course NOT a long-term option, color balance clashes horrible and such.) Or should I go straight to a bypass?

Certainly not for my first bypass, but I’m also wondering about what exactly is in that bypass; I’d give odds it’s a pretty simple RC network of some sort, and while the packaging makes it much easier to install in a metal box without shorting out than bare components, I’m still curious. Has anybody worked out something that works?

I’ve got at least two locations with less load on them that I want to automate, so I guess I’m gonna start buying bypasses; sigh.

Any load resistor will work. 25W at 120V requires a ~550 ohm resistor (remember lower will allow more wattage here):


But the Aeotec one works REALLY effectively in a small package.

So a very simple RC circuit; C = 0 :slightly_smiling_face:. (Somewhere on the Aeotec page it’s described as “a capacitive device”.)

And I’ve got 470 Ω resistors in stock here. And heat-shrink tubing.

The bypass goes in parallel with the load, which means in my switch-loop setup, it has to go up in the ceiling fixture, not down in the switch box. Sigh. I hate re-hanging chandeliers.

Well, anyway; I’ve got a working short-term solution, with the incandescent lamp. I’ll try just one lamp, and I’ll try playing with the dimmer limits, and see if I can get something satisfactory with no incandescent bulbs. And order a few bypasses, since I see 4 fixtures coming with just 1 or 2 lamps installed.

Could you elaborate here for me? Happy to get some clarification from the engineers.

Operating stably with one LED replaced with a 50-watt incandescent. Just adjusting the minimum dim level is not enough to make it happy; it clearly needs more juice than 5 7w bulbs were allowing (so 35w, when the limit mentioned is 25).

It’s all dark arts; I’ve got some bypasses on order to deal with this and 3 other cases with fewer bulbs where I expect to have the same problem. Which is not to say I’m not ever going to install my own simple load resistor, but I’m not starting there.

Replaced a second switch, also no-neutral configuration. Working stably with one LED and one incandescent, haven’t actually tried the pure LED version (who knows?). Will try it before actually taking down the fixture to install the bypass, when those arrive.

No problem.

25W Connected load would be equivalent to 5 x 5W bulbs connected, but could be on/off/dim and could pull anywhere from 0W (off) to 25W (on).

25W Constant load is where there is a minimum of 25 Watts of power flowing through the load at all times.

The reason I am thinking this is an issue is the switch is engineered to “bleed” some of the available power flowing through the switch to power itself when installed without a neutral wire.

This is how the Aeotec works, it essentially allows power to flow constantly at a rate that is above the minimum of your switches (I believe it has been stated the switch requires around 1.5W to operate). This is also why in a neutral installation it can flow power directly from the line to neutral, so it has unlimited power to operate. In a non-neutral it has no place to ground itself from line, so it has to grab power from “flowing” power, again produced artificially by the Aeotec.

My guess is that the switch requires 25W of power flowing through the switch so that it can take ~5% of that to power its own circuits and boards. Anything below this would likely make such an impact on the load that flickering would occur, and therefore the end user experience would not be great, so they engineer in a max on how much power it is able to bleed.

If that is correct, then when 25W worth of connected load (5x5W bulbs for example) dimmed down to 50% would only require 12.5W (assuming linear power conversion, not actually the case, but whatever), then the switch “bleed” would only be 5% or 0.625W which is not enough to power the electronics, so the switch shuts off and reboots once enough power is available.

This all relates directly to the flickering LED at low load as well AND the min dim being 40+% of switch power for VERY low loads, but that is for a different time (and for the experts that have posted elsewhere).

Hopefully that explains it enough. We can talk more in PM if you need.

@EricM_Inovelli – do you know the answer to this?

If you don’t want to mess with the bypasses (I didn’t—), the other alternative is to find a different LED bulb. The Compatible Bulbs for Dimmer Switch (Gen 2) - #47 by amdbuilder thread contains a lot of reports from people on what brand/model bulb worked and whether they required a bypass; I simply replaced my LED bulbs that required bypasses with some GE ones that didn’t. Even adding just one of the GE bulbs fixed it for all the other bulbs on the same load.

1 Like

Bumping for interest in developments!

BTW: I just figured out how to multi-quote. My efficiency of posts just increased substantially!