Can't update firmware with Z-Wave PC Controller

I am attempting to update the firmware to my black series dimmer using Z-Wave PC Controller. I’ve got the device paired, and I can turn the light on/off using Z-wave PC Controller. When I go to “OTA Firmware Update,” I am able to hit the “Get” button, and it returns the current firmware versions, and I am able to see Target 0 and Target 1 in the Firmware Targets list. So far, so good. But when I attempt to update, I get the following error:

Status: unable to receive=0x01

Is there a special mode I need to put the dimmer in prior to updating firmware?

No, nothing special. You ought to be able to “get” and then flash.

What version of the PC Controller are you using?

What are the names of the firmware files you are anticipating flashing?

I’m using Z-wave PC Controller v5.52.301. The names of the firmware files are:

Target 0: LZW31_1.57.otz
Target 1: LZW31_1.44.bin

I would try 5.39 for the PC Controller. That version is solid for flashing Inovellis.

EDIT: Replaced link.

Z-Wave PC Controller from Silicon Labs (Free): Download Here (you’ll have to sign up for an account with Silicon Labs – it’s free) (Mirror link)

I appreciate your assistance - Thanks!

I tried to get it from that link earlier, but it says I need to download an SDK first. I signed up for an account, and downloaded and installed Simplicity Studio - that’s how I got access to PC Controller (chose the Microcontroller option and installed all the bloat I don’t n need just to get access to this little tool!). However even after all of that, it still says my account can’t download PC Controller because I need to download an SDK first. Is there something else I must download first? Or should downloading/installing Simplicity Studio, logging in, etc. “unlock” it. Is there any other way to get access to it?

This is from memory. I THINK you can just download the SDK first, but don’t install it. Then try the download again.

When I click on the link I posted, it takes me to a 5.39 download link, so I’m guessing that I downloaded the SDK in the past.

Someone that has downloaded more recently may recall.

This also works for me:

I have downloaded and installed 3 SDKs (Gecko, Zwave SDK, and Zware SDK), but it still says I need to download an SDK first. It’s like it’s not registering my download. I know this is not Inovelli’s website or product, so there is really nothing you can do about what the website says.

But would it be possible to post PC Controller 5.39 somewhere it can be downloaded? I have seen several download links to Dropbox or Google Drive, etc., but they are all broken links. Or is there another tool that can be used to update the firmware on the switches?

1 Like

I also opened a support case with Silicone Labs, but not being a “real” customer, I don’t know how much attention it will get.

I had the same issues with Silicon Labs. Try the link over in this iBlinds support page :wink: :

1 Like

Thank you so much!! Once I got a hold 5.39, it worked like a charm. I truly appreciate the assistance!!!


Just so everyone knows, both links on the official firmware update page for the PC Controller don’t work, but the link @zacs posted does.

@EricM_Inovelli perhaps an update of that article or a pin of an inovelli supported link would be good?

The first link works for me . . . after I login. What does it do for you?

I can replace the dropbox link though.

That’s not exactly right. You’ll have to sign up for an account and probably have to download a sdk, but the link does take you to the right place to get started. The link in the support article is this .

Admittedly some have problems with it, but it works fine for others. Here is what I get when I navigate to it:


@EricM_Inovelli @Bry The link (yes, I had the correct siliconlabs SalesForece link) requires an SDK download first (which, it doesn’t say what the SDK requirements are exactly) and none of them seem to allow the PC Controller download for whatever reason. (After account creation and login, of course.) No matter what I try (using a new account, with N/A as the company as instructed by the new account creation process), the site will not allow me to download and continues to say the same thing. Perhaps there’s a specific SDK that’s required, or a “company” account to access said SDK, or… Who knows? I absolutely despise sites that require jumping through all those hoops for something like a simple download like this. (I know, that’s more of an issue with Silicon Labs, but… perhaps Inovelli can reach out to them to see if they’ll open up the download to non-SDK users or provide a mirror for USB dongle users, that sort of thing?) I unfortunately seem to be one of the users who can’t seem to get the official link working, despite even having experience as a software developer and doing IT work for a living. I already have the version that is from the myiblinds site zacs posted, just suggesting some options for those who jump through the hoops and have things still fail in the end from the How-To page.

Gotcha, that is strange that your account doesn’t support the download via those links. Maybe it is just newly created accounts? A temporary bug in their site? I’m not sure.

I have upgraded the mirror URL so that it should work.

1 Like