Can't upgrade firmware using Zooz S2 Stick 700 and Smart Things


I’ve trying to upgrade my Red Series Dimmer Switch using these instructions:

Unfortunately, I’m getting stuck at this part:

Instead of getting a pop-up window, I get a “Learn mode Replicated complete” message:

SmartThings app continues to wait, but doesn’t bring up a QR code. Eventually it times out and says “It looks like we couldn’t connect”.

I’m not sure where to start. Is there some info I could provide to help troubleshoot?



I can’t address your issue directly, but I’m going to suggest that you flash directly using the PC Controller and not use the SmartThings secondary method. From your other post, it looks like you recently installed this dimmer, so I am guessing that it is not yet added into a bunch of automations, scenes, etc.

The advantage of the secondary method, if it works, is that you don’t have to remove the device from SmartThings. The disadvantage of using the PC Controller is that you do have to remove the device from SmartThings, and then you have to re-add back into ST and reconfigure it for scenes, automations and the like. But if that switch isn’t included into anything, or very much, that is not a big deal.

I recently tried the secondary method and while I got it configured properly, the flash failed halfway through. Since others had reported the same issues previously, I put the secondary controller into the “bad idea” category (IMO) and went back to flashing by using the PC Controller alone.

1 Like

Okay let me give that a shot! Thanks!

Screenshots are a bit outdated but the concept is the same. I use the stick.

Thanks! I was able to get the Target 0 / .otz update done, but when I try to do the same for Target 1 / .bin, I get "Status: unable to receive=0x01:

Any ideas?

Did you wait for the switch to reboot? Wait 30 seconds to 1 min before trying again. I even toggle the switch on and off before trying again.

1 Like

Actually now it’s happening for both. Is there a factor of time after you’ve added the switch to the controller? Does it need to be in some sort of mode (3 config clicks)?

Which version of PC Controller are you running?

Also, it’s been a while since I’ve updated, but I thought all the upper fields went white (not shaded) when the switch was 100% communicating with the software (like manufacturing ID). (Could be wrong) Press the “Get” button to refresh it. All the fields should populate.

I am using a Zooz S2 Z-Wave 700 USB Stick (ZST10 700). I’m wondering if the 700 is the problem, though supposedly Z-Wave is backwards compatible:

In regards to get, here’s the video of what I do, which starts with a get

After the video, the operation continues for 1-2 minutes and eventually fails with this:

There’s an example of someone using this stick for firmware upgrades with Inovelli, but it’s a bit dated and uses an older version of Z-Wave Controller software:

I attempted to use the zooz 700 stick for my Home Assistant setup, actually 3 of them, and found them unusable with Inovelli for basic control because of duplicate messages on the network, even when using the PC controller software LZW31 Duplicate messages flooding zwave network - #24 by flipontheradio

I never updated firmware with the zooz 700 but there does seem to be some odd communication between them.

Agreed. I just finished rebuilding my zwave network yesterday using my zooz 700 and my zwave network has been the most unstable it’s been in I can’t even remember how long. I have some firmware updates to run on my end, but because of the instability I’m too nervous to personally run the update using this stick.

I’m hoping it will be able to limp along until the weekend where I’m going to give the Silicon Labs SLUSB001A a shot. A little sad no one has the US Aeotec 700 in stock, was going to go that route.

Both the Zooz 500 and 700 have given me troubles for some reason.

Just bought this (will deliver tomorrow) and will post results:


1 Like

That one I can personally vouch for; it should work very well for upgrading!

1 Like

This is from memory, but I think you will need to reset the adapter in PC Controller. You shouldn’t be seeing all those devices since you are now using the PC Controller in the “standalone” mode. They are left over from the aborted SmartThings integration.

I went through similar secondary controller drama recently. I was eventually able to get it working. Possibly this thread my provide some clues

Okay so I just tried the HUSBZB-1, followed the directions here (trying to add the controller as a secondary controller to smartthings) and am having the same problem. I’m able to get through step 3, adding the controller and providing the DSK. The smartthings app hangs on the DSK input screen, but when I look at, I can see the controller is there. The Z-Wave Controller software seems to recognize that it has been added and has the [S2] indicator.

Then when I move to step 4, I click “Node Info” on the switch. It does NOT get the [S0] security scheme prefix like the instructions suggest. Not sure if that’s important.

When I specify the otz file and go to update Target 0, I see the following:

It stays on “packet# 1 of 5051 written” until it finally fails with:

I tried a fragment size of 40 and 20. Same results.

Grrr…pretty much the same as the other stick, so I’m not sure what I’m doing wrong.

Gonna try the non-smartthings way of upgrading now, but let me know if you see something stupid I’m doing.

Okay, using the exclusion method seems to be working now. otz file is processing. bin is up next. Will let you know the results!

1 Like

If only we could all get paid for the amount of frustration we’ve all had with our smart homes… :joy:


Bin worked too. Of course now when I try to add the device to smartthings it hangs after the DSK entry. SmartThings seems to think it’s there. It’s in the app and api.smartthings, but when I try to control it through the app it says “server error occurred”. Grrr…maybe I’ll reboot the hub.