Ota firmware update iniitalization failed - secondary controller method - not prompting for security anymore?

So the few times I’ve updated firmware, I’ve always used the simple approach of adding my switch to my z-wave stick (Aoetec), updating, then having to exclude/include back to SmartThings. Yes, a massive pain as that process breaks all existing automations, routines, etc. So I was pleased to learn about the secondary controller method.

It *seemed like I was on the right track, as I followed the instructions in the Inovelli tech notes as well as similar guidelines elsewhere. I seemed to have added my z-wave stick to SmartThings as a secondary controller and it looks like I was able to perform a “GET” to get the firmware version. I ended up reseting my z-wave stick to factory defaults, manually deleting it from SmartThings and trying to add it back to ST. It adds back, my devices come over into SIC Z-Wave controller software but I cannot perform a “GET”. It fails with “ota firmware update iniitalization failed”. So the big thing is that on subsequent re-adds I am not getting the security prompt, it just adds it and the slave devices. I actually looked at the log and it made mention of security failing during the add. I was researching this and I remember reading somewhere that someone reset the S0 and S5 security? I have no idea how to get my z-stick and/or ST to go back to a state and re-prompt for the security pin/code.

Any thoughts?

In Smartthings you have been using the stick and adding devices to it with security, right?

Then, when you move the stick to a PC and use the SL software you’re having this problem, right?

Somewhere is that software you would have to enter the zwave network key if the devices are already paired to the stick using security. I believe it can also be set in the Aoetec stick itself.

Hi, I’ve used the aeotec z-wave stick gen 5 previous as a standalone controller, unpairing my device (i.e. a switch) from ST, pair to the z-wave stick in SL and upgrade. Now when I try to add the z-wave stick (after a factory reset on the stick) to ST as a secondary controller, it adds but I am not prompted for the DSK key. It brings over the devices from ST but that’s it, I can’t do a GET on any of them.

Now after spending a weekend on this, I am guessing the issue is the aoetec gen 5 stick is not S2 ready. I know I mentioned that the first time I tried to add it to ST I got prompted, but every since then trying to re-add I can’t get it to prompt. I don;t know if the first time it was a fluke or what. I’ve made sure there’s no ghost z-wave controllers in ST and the zwave stick was reset.

I would be really curious if anyone else has been able to use the Aeotec z-wave gen 5 stick (not the gen 5+ which is S2) as a secondary controller. I’ve order the one specifically recommended by Inovelli (the zwave.me) and the Aoetec Gen 5+ S2, in order to test this theory.

I should add that I am using SL 5.52 of the PC controller software. The technote that Inovelli wrote references 5.39 - I am also wondering if something has changed since then. Like I said, I think (and hoping) is that I just don’t have an S2 z-stick and that getting one will fix this. I tried on a completely different computer and same results. My last (awful) theory is that something might be hosed in my ST v3 hub and there’s a ghost controller device that I can’t see and requiring a factory reset :frowning:

So I think I figured out my issue(s). I received my z-wave.me stick yesterday and retried adding it as a secondary controller. It still didn’t work. I realized though I was not following the instructions closely. When adding the generic z-wave in ST app, I selected “by brand” and not “by device type” - not sure why this makes a difference (as you see the same generic z-wave device icon in both), but when I selected, “by brand” I did not get the DSK pin prompt (which caused security to fail). Even though the device list comes over from ST, I can’t do anything as security failed on the z-wave stick. Retrying adding the z-wave stick from scratch (remove the z-wave stick from ST, reset it in PC controller) and then selecting “by device type” I was able to get the DSK pin prompt, added the 5 digit pin, and it added properly. I can then select one of the imported device (i.e. any of my switches), perform a “get node info” (very important to do this, I missed this also), and then go into the OTA update section and the “GET” button should now work.

So I think this was a case of “Read the Darn Manual” closely. I also went back and tried my original Aoetec Gen 5 (not the 5+) stick and still couldn’t get the DSK pin. As mentioned in the original post, I got the DSK pin prompt before (which tells me I follow the directions correct the very first time ) but not getting the DSK prompt when trying to add it again. I am going to reset the Aoetec Gen 5 stick using the Aoetec z-wave tool and try again later today.

I also ordered and received the Aoetec Gen 5+ S2, and Zooz S2 sticks as well (I was paranoid and wanted to try and find one that worked) and will test and write a more elaborate post.

I tested the procedure with the Z-Dongle stick (which I believe is from Zooz) and that worked as well.

Also as an FYI, when actually burning the firmware using the secondary controller method, It defaults to a fragment size of 40. This works when unpaired from ST and connected directly to the stick, but apparently with S2 enabled in secondary controller mode, I get the dreaded “invalid fragment size” error. I found this post on the Home Assistant board and found the following advice:

***update to fail with a “Status: Invalid Fragment Size=0x02” error. My solution was to decrease the “Fragment Size” field from 40 to 20.

I was able to continue by setting the Fragment Size to 20. I also noticed it goes a bit slower (probably because the packets are being encrypted).

Hopefully this saves someone some time and agony.

sorry folks, I was in a hurry type the above - I’ve gone back and corrected some mistakes in the post. Should be accurate and easier to follow