Current Firmware versions and best way to update via Hubitat

I was able to turn the light on/off from the Hubitat Dashboad on my iPhone, but the LED is a solid red. (Even though I did not try to push the BIN (Target 0) firmware).

How I do I reset the to “normal”?

If you hit configure from the switch screen it’s still showing the old code version? Can you just update the led color and will it take that?

I tried to push configure, refresh, child refresh, and component refresh and none worked. I had changed the color from Blue to Violet, and saved preference and save device.

When I turn the switch on or off I see if turns purple for a second, but then it reverts to solid bright red.

I’m afraid to try “reset” as I don’t want to go all the way back to whatever it shipped with (and I bought it in Feb, 2021).

A factory reset is going to load from the currently installed firmware. It won’t revert to a previously installed version.

The reset button didn’t work either. I still get the same result: i.e. it turns purple for a second and then reverts to bright red.

Are you talking the reset button in hubitat or doing a factory reset?

The reset button in Hubitat

Gotcha, the factory reset Bry mentioned should be holding the config button for 20s on the switch itself and you’ll see it turn or blink red (or blink once in this case maybe?). You’d then need to re-include it to Hubitat (or exclude/re-include from the hub should do the same) - https://support.inovelli.com/portal/en/kb/articles/installation-setup-lzw31-sn-dimmer-red-series-gen-2-hubitat

I held the config button for 20+ seconds to reset it from the switch. After that the solid red light went off and I was able to change the color to blue.

I’m going to wait a couple of hours before trying to do anything else with it through the hub, such as turning it on/off via my Hubitat dashboard.

But, since changing the color worked do I still need to do the exclude/include?

If you can still control it through the hub you should be fine. I was under the impression that it was the equivalent of resetting from the hub (excluding), but that doesn’t appear to be the case.

If you factory reset it then the switch no longer is included to the hub even though the hub still lists it. You’ll have to force remove the device from Hubitat and then include it back to the hub.

1 Like

It’s been a good while since I did an exclude/include. I know I need to press the config button 3 times quickly to put it into include/exclude mode, but I can’t find where in Hubitat that is. I thought that it was on the Z-Wave details page, where the Z-Wave Exclude button is, but when I click that nothing happens.

Screen Shot 2021-11-28 at 3.48.02 PM

So how to I get Hubitat into exclude/include mode?

I believe when you click that, there’s a 30 sec timer that starts just below the button.

Devices > Discover Devices > Z-Wave > Start Z-Wave Exclusion (and Inclusion is in the same menu)

The Z-Wave Exclude button didn’t work.

I found the Include/Exclude button on the Discover page:
http://hubitat.local/hub/scanDevice

I put the switch into include/exclude mode by clicking the config button 3 times and it started to flash blue on and off.

I then clicked the exclude button. Although the timer ran out and it didn’t say it excluded it, after a while I got a message that an unknown device was excluded.

I then updated the Z-Wave page and the switch (which is my dinning room) appeared as a ghost now. (Not terribly surprising).

I then went and included the switch by clicking the Config button 3 times quickly and using the Start Z-Wave Inclusion button on the Discover Devices page. But a few things were strange about that:

  1. It never asked for the DSK.

  2. It only asked if I wanted to include it as S2. I didn’t get the page to pick none, 0, 2, etc.
    I don’t see any security listed inside the device. Does that mean I included it with no security?

.

If not, is there a way to pick no security? All of my other devices were added with no security.

  1. Also weird is that I thought Z-Wave devices can only make 4 hops. Here it looks like it is making 5 hops:

4, I used the Remove button for the ghost dinning room and it went away. But, after a few minutes it reappeared. I tried doing it a 2nd time and it went away again, but came back yet again. I then went into the device itself and used the Remove button at the very bottom. That seems to have worked.

While I finally did get my switch working again, I still don’t know what to do about upgrading the firmware as neither the Device Firmware Updater app nor the Z-Wave Firmware Updater “driver” method worked for me after many tries. The driver method typically got to the high teens or low 20 percent range before it failed. One time it got to the low 40% range. That took well over a 1/2 hour to get there. The Device Firmware Updater failed much faster.

The switch was at 9.6 Mbps, but was updated before and always worked with my rules. Now that I’ve re-included it, it is at 40 kbps. I have lots of Inovelli switches around it (including another one in the same 2 gang box) and even an Aeotec 7 extender (though it isn’t routing through it)

I also looked into the PC Controller, Z-Wave stick method, but I don’t have a PC, just a Mac. And while I am running Parallels on it, I also read about the extra difficulties that entails. Plus, my Mac is a 27” all-in-one so I can’t just pick it up and bring it close to the switch. So I don’t know what I can possibly do to update my firmware. I am running 1.48 otz and 1.41 bin on my 20 something red dimmers.

I honestly wonder if there’s something going on with Hubitat as I seem to fielding a lot of these questions recently. @jeremykeen’s thread being the most recent one outside of yours.

As mentioned over at that thread, I experienced the same issues as you guys when trying to update everything – for fun, I went over to the Hubitat forum and found a lot of threads experiencing this issue too, and it’s not just Inovelli stuff failing, so it’s likely something on the HE side.

(this one was ultimately successful with S2 removed)


Anyway, not trying to place blame at all as at the end of the day, it could be our switch firmware, I’m honestly not sure. I’m not a Z-Wave expert when it comes to coding and implementation and there’s a ton of things we’ve discovered via the smart guys at Hubitat and also one of the other companies we white-label for about our own switches that we’ve improved on over the years. I used to think that if your product was Z-Wave Certified, it meant that everything should work flawlessly, but I’ve since figured out that was very naive and there’s different ways firmware can be implemented, which can cause small issues.

The guys at Hubitat are definitely pushing the boundaries in terms of what Z-Wave can do and have been one of the leaders in Z-Wave innovation for some time now.


How far is your furthest switch from your Mac?

I have a MacBook that I run Parallels on and while I can technically move it, I haven’t had to luckily because my house isn’t that big and I’m typically in the middle of the house where the MacBook is docked (the USB stick is in my monitor as of course Apple got rid of USB ports on the MacBook lol).

I made some updates to the “community firmware update driver” for hubitat, which fixed some issues I was having when updating my inovelli devices.

Feedback welcome. Questions welcome too. I’ll do my best to support it but it’s just one of many projects I’m working on, so I can’t promise anything.

My personal opinion is that the issue has to do with something in the Hubitat or zwave SDK systems. The PCController software almost never fails, even from across the room, while the Hubitat updated fails on almost every single device. Play it safe, and join a Z-Stick to the Hubitat X-Wave network. Now you can walk around with a laptop or other computer to get the z-stick near the device before you update.
Even if you are not right next to the device, it usually works through PCController which uses older SDK drivers (from what I am told). Distance only affects speed when using z-stick with PCController software.
Good luck.

1 Like

As someone who’s been performing a firmware update to all my inovelli switches, I found many issues with Hubuitat’s firmware updater. There seems to be quite the memory/process leaks. You need to bring the hub within 10 feet of a switch so that it prefers a direct connection (higher # of hops creates route changes/hanging of firmware updater). Monitor the z-wave logs while you’re performing an update and if you notice that the output of logs is slow but it’s reporting a 100kbps speed, it’s likely the app has gone into a weird state (may cause update to take 10x longer). I’ve had to reboot my hubitat when the firmware update process became really slow and the speed came back up after a reboot.

Also to note that there is something weird with S2 Inclusion && Firmware updates… Either with the firmware of my switch (LZW31) or Hubitat.

After firmware updating to 1.57/1.44, physical events were no longer reported and updated in hubitat, while z-wave commands and sending a refresh command still worked. In order to fix it, I had to exclude/re-include the device into Hubitat.

1 Like