Upgrading firmware failing

I have repeatedly tried both the Z-Wave Firmware Updater driver code and the device firmware updater app to attempt to update the firmware on several dimmers - red and black.

I have had upload progress up to 60% and then always get a failure message like: “FAILED: The device was unable to receive the requested firmware data”

From my black dimmer:

currentFirmwareVersion : 1.35

firmwareFragmentSize : 40

firmwareTarget : 0

firmwareUpdateProgress : FAILED: The device was unable to receive the requested firmware data

firmwareUploadPercent : 1%

lockedBy : None

I have attempted both 1.48 and 1.57 otz to target 0. Please note the listed product code contradicts the production version and beta versions on this page. Following directions here and here.

Hubitat I’m guessing? Are the devices joined securely (S2 or S0) or without security?

If without security, have you tried powering off hubitat and unplugging it for 30s before powering it back on? Could be something with the radio or hub itself as well.

Building on @chack’s response – how far away are your switches?

I just migrated all my switches off Hubitat but before I did, I tried to upgrade them all and got the same errors as you and just ended up giving up. It was super frustrating.

I did get the ones closest to the hub to work great, but anything outside of a couple walls or maybe 30ft all failed.

It never used to be like this, which maybe one of the latest updates to the hub messed something up, idk?

Anecdotally, when we released v1.52 (back in January), I updated all of my switches no problem, so I have to imagine something is going on with the hub.

I ended up using the PC Controller and a Z-Stick to finish updating the switches that were out of range.

I realize this didn’t help the solution at all, but wanted to at least call out that I experienced the same thing :confused:

1 Like

I have recently rebooted or shutdown and started fresh, my hubitat hub several times. The switches I have tried are just on the other side of a wall from my hub - mere feet away. What’s up with Hubitat these days? Maybe I joined the trend to Hubitat too late and now it sounds like many are moving away due to issues. :frowning:

Question for ya – do you remember if your switches were paired non-securely or via S2?

I didn’t mean to paint a bleak picture, I promise lol. I have a lot of respect for the guys over there, many of which have been extremely helpful in trying to get things to work and they’re definitely on the cutting edge of technology (700 Series, OTA firmware updates, local control, etc).

My personal reason for switching back was simply because some of the scene control was failing (idk who’s fault it was – could honestly be user error, idk), and I just was too, “simple” for Rule Machine that it was getting discouraging to me to do anything with home automation. Like I lost interest in setting up automations, which is obviously not good when you’re an owner of a smart home company lol.

I do think they have an amazing product and it’s definitely way more powerful in terms of what you can do than the competition (aside from Home Assistant), but for the simple people like me, I just need a pretty interface that allows most of what I dream up.

Intentionally NOT securely joined as I read many were warning against it. I hear you on Hubitat. In fact the same struggles it seems you were faced with is precisely what is turning me off a bit right now - many simple automations are just failing to work consistently. That is actually why I am trying to get my Inovelli’s upgraded to see if there is any improvement in my z-wave mesh reliability. I’ll try a few more times via hubitat and then go to the UZB stick method.

Yeah, I’ve heard this a lot too – and there will definitely be champions of both side of the argument (ie: security or non).

I fall in the camp of non-security (except for locks and maybe a few other security devices). I understand the argument of people hacking into smart home devices, but my understanding (and I am far from a networking/security expert) is that it’s still incredibly hard to hack into a Z-Wave device for the average person. Worst case scenario, someone does get in to your Z-Wave bulbs and switches… they can’t do much other than turn off your lights. If that’s the case, just factory reset the switch and start over.

I find the security advocates are usually power users or security is just inherently important to them (which is fine, I can respect that – we all have our own hierarchies lol).

It’s just that the added layers seem to really slow down the network and cause issues and to me personally, it’s not worth it.

Ok, I’ll get off the ol’ high horse :rofl:

I will say that the 1.61 update helped a little with network traffic. This was one of the updates where we had to humble ourselves a bit. One of the companies we white-label for really hit us hard (in a good way) around the duplicate packets being sent that, compounded over time, could cause some issues with certain hubs.

The majority of our users use SmartThings and the network traffic didn’t seem to really interfere (or people just didn’t notice or care, I’m not sure) so we didn’t really hear anything until it was reported with Home Assistant and then Hubitat and finally this other company.

But, what perplexes me a bit about the Hubitat issue is that it wasn’t just Inovelli switches that caused the issue – after I updated to 1.61, I still had issues with scene control. I have a Zooz remote (I know… I know…) by my bed that I used to turn off all the remaining lights and I would have to push that thing like 5 times in order for the scene to finish executing.

Idk, it’s been a fun ride haha!

I just went thru all the updates via hubitat and most were flawless, but I had 2 or 3 that needed their hands held. What seemed to work for me was pulling the airgap on affected switches, then running a zwave repair, then updating firmware again. I still had one that took a few tries but eventually got it. Once it failed at 95 percent lol.

To add a datapoint for failing firmware upgrades on other hubs (ZwaveJSMQTT), I was unable to update firmware to 1.61 with a Zooz 700 stick on anything requiring a hop to the controller. Once I switched to a Nortek HUSBZB-1 I can update everything across the network even while joined in S2 mode.

UZB stick was the way to go. Got through all of my dimmers quite quickly with no failures whatsoever. I was even able to update the devices without removing and re-joining the Hubitat network by first joining the UZB to my hubitat Z-wave network.

Since we are piling on about Hubitat… I have been testing some of my Inovelli dimmers with motion sensors on SmartThings again. The constant failures on Hubitat are starting to wear on me. Now that SmartThings edge is a thing and you all are starting to release beta drivers for running locally on the hub (thx), it might make me switch back to ST.

I hope I’m posting in the right place. I have three LZ31 dimmers which worked OK on v1.35 firmware. But, I noticed that new firmware was available, and so I tried updating one to v1.57. All worked fine, though the detail page in my Hubitat showed much less detail after the update than it did previously. So, I proceeded to repeat this to the second of three dimmers.

The second update started OK, until it got about 10% of the way through, at which I saw an error message (sorry, don’t recall what it was). The update stopped, and I tried clicking on the “Update Firmware” again, but the process did not continue. “firmwareUpdateProgress” reports “Please wake up your sleepy device”.

So, I looked at the dimmer itself. The LEDs on the dimmer are lit up all red. It responds to manual up/down control and the attached lights to up and down. During manual up/down control the blue lights respond normally, but after that the red LEDs turn on. Pressing the configure button repeatedly changes the lights, but does not re-start the firmware update process. I’ve left the Hubitat in the same place (have not clicked “abort” or “clear lock”) in order to reduce the chances of bricking the dimmer.

I sent in a query to Innovelli, but support is closed until the new year. I’d appreciate any help that you folks in the community might have to offer.

One important question I’d like to understand (and couldn’t find in the documentation on line) is whether resetting the dimmer will restore the original factory-equipped firmware or not. I understand that a factory reset is done by restoring power (using the air-gap) and holding the configure button for at least 20 secs. Do I have that right? Will doing that reset the dimmer to the original firmware?

Thanks in advance for any and all help you folks can offer on this holiday weekend!

So here’s my understanding and please set me straight if I get something wrong. These are the black series LZW31 dimmers. You flashed the LZW31_1.57.otz file successfully on dimmer 1 to target 0, but when you tried to repeat it, dimmer 2 errored out around 10%. That all right?

For the LED bar - did you also flash the LZW31_1.44.bin file to target 1 of the first dimmer that did take the firmware update?

To resolve the sleepy devices issue, you can try repeating the upgrade process, but if that doesn’t work it may be worth shutting down Hubitat, unplugging it for 15s or so and then plugging it back in and trying again.

Yes, a 20 second hold (until the LED turns red) will do a factory reset. However, that will load from the firmware currently flashed to the switch. It will not reload the original firmware if you have flashed a more current version. If you want to revert to a previous version, you will have to flash that version.

1 Like

Blockquote that will load from the firmware currently flashed to the switch. It will not reload the original firmware if you have flashed a more current version.

Thanks. So, Inovelli does not reserve a space in memory for the original firmware.

I’ve partially flashed new firmware (11% completed). I’m afraid that if I do a factory reset it’ll reset it to half 1.35 and half 1.57, which probably won’t be good. I don’t want to end up with a bricked device if I can avoid it. Inovelli seems quite clear that if something goes wrong in flashing new firmware, they’re not responsible.

These are the black series LZW31 dimmers. You flashed the LZW31_1.57.otz file successfully on dimmer 1 to target 0, but when you tried to repeat it, dimmer 2 errored out around 10%. That all right?

Mostly right. I flashed LXW31_1.57.otz to target 0, dimmer 1, plus LZW31_1.44.bin to target 1, dimmer 2.

When I tried to repeat that with dimmer 2 (installed in the same electrical box as dimmer 1) the process stopped on target 0, LXW31_1.57 at about 10%. See screen shot from my Hubitat below

I want to avoid bricking the dimmer. I haven’t tried clicking “abort” or “clear lock” yet. Do you or anyone else have any experience with what these functions do and what state they’ll leave the dimmer in?

Do you mean the LZW31_1.44.bin to target 1 on dimmer 1? Or you flashed that successfully to dimmer 2 but not the LZW31_1.57.otz firmware to target 0 on dimmer 2?

I don’t have as much familiarity with that firmware update method as I used the Device Firmware Updater, but you’ll run into the same issues with that too from time to time. From personal anecdote and reading forums only, I’ve not seen issues persist with a switch or dimmer from a firmware update that couldn’t be resolved with a factory reset and/or air gap.

I’d go with powering down Hubitat and then removing the power cord for 15s and then plugging it back in and trying again.

Sorry, I mis-typed! I flashed both LXW31_1.57.otz to target 0, dimmer 1, plus LZW31_1.44.bin to target 1, dimmer 1. Both of those went through without any trouble.

But, the .otz update for Dimmer 2 stopped at about 10%. I haven’t gotten to the .bin update yet.

From personal anecdote and reading forums only, I’ve not seen issues persist with a switch or dimmer from a firmware update that couldn’t be resolved with a factory reset and/or air gap.

I hope I might hear from someone who has had experience with this situation, to give me the courage to try a few alternatives. But, I suppose if I brick the thing, it’s not all that much lost!

1 Like

So dimmer 1 is totally good, just stuck on dimmer 2? And sounds good re otz first on dimmer 2.

I can get the concern around bricking the device, but it seems to be very rare in my experience and from what I’ve seen. I would definitely recommend the power cycle on the hub as a next step though, Hubitat seems to have some issues with updates sometimes (not sure the specific cause), and that’ll help if there’s a memory leak, etc that could be causing the issue.

Thanks for your additional thoughts. I threw caution to the winds, and tried the following:

  1. Clicked “abort”, then “update firmware”. I did not reboot or power off the Hubitat. Firmware upload started, LEDs changed to blinking blue. The upload got to ~16% this time, and failed.

  2. Tried again. almost the same story, but stopped after 5%.

  3. Tried one more time. This time, after over 1-1/2 hours of slow progress, it got all the way through. Wow!

  4. So, I tried switching to LZW31_1.44.bin (at target 1), and got an abort right away.

  5. Clicked abortProcess and Update firmware again, this time it went through 100% (must faster, about 7 minutes).

The dimmer seems to be responding OK now, so your advice worked out OK. Thanks! I’m going to try and brave updating the third Inovelli dimmer next. Wish me luck!

1 Like

You might want to consider using SILabs PC Controller software with a Zwave stick. Those upgrades don’t fail. It seems that a number of people have issues upgrading firmware via their hubs.

Yes, there is additional time involved. You have to exclude the switch from your hub and add it to the PC Controller. Then put it back and restore your rules, scenes, etc.

1 Like