Disabling relay without disabling LED

I have some red series switches in a 3/4 way configuration. In the non-load switches, I have line and load connected together to pass through to the last switch. So only the last switch actually does anything. I have set up z-wave associations to/from each of the non-load switches from/to the load switch. I have disabled local control on the non-load switches, but the association causes the relays to flip anyway. I disabled remote control, and now the LED will not update when the switch is turned on or off. Is there a way to disable the relay without disabling the LED?

I might be mistaken, but I don’t think there is. The LED is the load status indicator.

However, if you want the LED to indicate the load status of the last switch, you can create a Light LED child object for the first two switches and then use a rule to turn the LED child objects on and off predicated on the load status of the last switch controlling the load. This works fine with a switch with a load on it. Don’t have any with associations, but the same concept ought to work.

I’ll try that. Thanks!

I tried creating an LED child object, but I did not see that option anywhere. There was an LED Color child object, but it did not control the light itself, unless I was missing something.

How do I create the LED child object?


The child object I referred to was created with SmartThings. I see you are using Hubitat, with which I’m not familiar.

@harjms ??

Should be shown something like this. Under the device itself. Make sure you’re using Inovellis driver and not Hubitat.

1 Like

Yes, I have those, but my only options are “LED Color”, “LED when off”, “Disable local control”, and “Disable remote control”. I have tried the first two, but they don’t seem to have any control over the LED on the switch.

Just trying to understand. These (all) are in a zwave associated right? Which associations do you have programmed?

I originally had them in 2-way Z-Wave associations, but I don’t want the non-load switches triggering their relay. I only want the LED to show the status of the load switch. I removed the return Z-Wave associations (going from the load switch back to the non-load switches)

EDIT: I have 3-way setups with dimmers using groups 2, 3, and 4, and regular switches using group 2. For this test, I am using just the regular switches, and one-way associations from the non-load switches to the load switch.

I thought you had to change one of the parameters on the slave switch(es).

I don’t have anymore reds to play with but you should be able to use rule machine to mimic the led level master to slaves. However , I’m not sure the best way. I could’ve swore this has been mentioned before for people with 3+ ways. However, I think they used their slave switches as alternative switch for control.

I know there is a setting to prevent the association signal from propagating endlessly. On the LZW30-SN switch, it is parameter 4. Setting it to 11 (15 - 4 == all - z-wave hub) on the non-load switches prevents signals coming from the Z-Wave hub from propagating. This is used to prevent the 2-way association from bouncing back and forth infinitely.

Not sure that parameter really applies in this case, since the z-wave association is only one way (from non-load to load, allowing the non-load switches to control the light).

Anyway, I made SOME progress. I created a notification child device that would mimic the on state, and set up a basic rule that would turn it on when the load switch was turned on. It worked when flipping the load switch directly, but when turning it on via a Z-Wave association (from the 3-way switch), it did not trigger the rule.

I also tried resetting parameter 4 to 15 to make sure that wasn’t preventing it, but it didn’t help.

Interesting. What firmware and driver version you using?

I’d hate to rely on RM to do something that you’d think could be passed along with zwave associations.

I honestly never had good luck matching led bar matching bulb dim level. I tried setting 2, 3, 4 in both directions but never got it to work.

Maybe @mamber or @EricM_Inovelli have some pointers for Hubitat configuration.

I haven’t had any problem with the dimmers. Since they don’t ping (relay sound) when turning on and off, I’m not going through this issue with them. Just have to remember to set Parameter 12 to 11 BEFORE you set up the 2-way Z-Wave associations. (Parameter 4 on switches, 12 on dimmers)

I sold my home with about 40 red/black dimmers and switches so nothing to play with anymore. I have Blue series on order for new to us home, but that obviously doesn’t help solving this issue.

There is a bug in the lzw30 with associations. I had to setup an automation on the non load switches to show the proper state.

1 Like

That’s disappointing. And it looks like there is no firmware incoming.

The great @EricM_Inovelli just has to reverse engineer the current one :grin:

1 Like

I’ve had good luck with LED bar sync by using these associations:

Load switch sends Groups 2 and 3 to Aux switch and Parameter12 set to 15
Aux switch sends Groups 2 and 4 to Load switch and Parameter12 set to 11

1 Like

I see on the dimmer switches that there is a smart bulb mode. I presume this is to keep full power to the load while using the dimmer functionality separately to control things “smartly”. Is this functionality available on on/off switches?

Your presumtion is correct regarding the SBM.

That isn’t available on the switch as a setting per se, but you can replicate it easily.

When you turn the SBM mode on a dimmer, that ensures the smart bulbs are constantly fully powered. The paddle will no longer control the wired load, meaning that you cannot dim/brighten or turn on/off the wired bulb(s) using the paddle. You can then control the smart bulbs either through associations, binding or scenes via the paddle.

When you turn the SBM on the dimmer, the LED bar will still work in sync with the paddle presses, so the LED bar will turn on/off or indicate brightening/dimming, even though the bulbs remain fully powered.

There is not a SBM for the switch. To replicate this, turn the wired load on and then turn on Disable Local Control. This leaves the wired load turned on, and paddle presses will not turn it off. You can then control the smart bulbs either through associations, or scenes via the paddle.

The one thing that is missing using this technique is that the LED indicator on the switch does not turn on and off in sync with switch presses with DLC turned on, in contrast to how it works with SBM on the dimmer. However, the LED on the switch is addressable as a child object, so you just need to code in something that turns that LED on or off to sync with the bulb(s) status.